IT Tools
Student Handbook
Class XI
भारत का संविधान

उद्देशिका

हम, भारत के लोग, भारत को एक सम्पूर्ण प्रभुत्व-संपन समाजवादी पंथनिरपेक्ष लोकतंत्रात्मक गणराज्य बनाने के लिए, तथा उसके समस्त नागरिकों को:

सामाजिक, आर्थिक और राजनीतिक न्याय,

विचार, अभिव्यक्ति, विश्वास, धर्म

और उपासना की स्वतंत्रता,

प्रतिष्ठा और अवसर की समता

प्राप्त करने के लिए

तथा उन सब में व्यक्त की गरिमा

'और राष्ट्र की एकता और अखंडता सुनिश्चित करने वाली बंधुता बढ़ाने के लिए

दुबलसंकल्प होकर अपनी इस संविधान सभा में आज तारीख 26 नवंबर, 1949 को एनाद्वारा इस संविधान को अंगीकृत,

अधिनियमित और आत्मसारित करते हैं।

1. संविधान (बंगालीसंस्करण) अधिनियम, 1976 की धारा 2 द्वारा (3.1.1977) से “प्रभुत्व-संपन लोकतंत्रात्मक गणराज्य” के स्वाभाविक।
2. संविधान (बंगालीसंस्करण) अधिनियम, 1976 की धारा 2 द्वारा (3.1.1977) से “राष्ट्र की एकता” के न्याय पर प्रतिस्थापित।

भाग 4 के
मूल कर्त्तव्य

51 क. मूल कर्त्तव्य – भारत के प्रत्येक नागरिक का यह कर्त्तव्य होगा कि वह –

(क) संविधान का पालन करे और उसके आदेश, संस्थाओं, राष्ट्रीय और राष्ट्रीय का आदर करे;

(ख) स्वतंत्रता के लिए हमारे राष्ट्रीय आंदोलन को प्रतिष्ठा करने वाले उच्च आदेशों को दृढ़त में संगठो रखे और उनका पालन करे;

(ग) भारत की प्रभुत्व, एकता और अखंडता की रक्षा करे और उसे अवृद्धि रखे;

(घ) देश की रक्षा करे और आत्मवस्तान्त्रिक जाने पर राष्ट्र की सूचना करे;

(ड) भारत के सभी लोगों में समस्तता और समान प्रारूप की भावना का निर्माण करे जो धर्म, भाषा और प्रदेश या वर्ग पर आधारित सभी भेदभाव से परे हों, ऐसी शासन का लागर करे जो सिद्धांतों के समान को विरुद्ध हों;

(च) हमारी सामाजिक संस्कृति की गौरवशाली परंपरा का महत्व समझे और उसका परिवर्तन करे;

(छ) प्राकृतिक पर्यावरण को जिसके अंतर्गत वन, झील, नदी, और वन जीव हैं, रक्षा करे और उसका संरक्षण करे तथा प्राणी मात्र के प्रति दयाभाव रखे;

(ज) नैजानिक बुद्धि को, मानवता और ज्ञानान्वित तथा सुधार की भावना का विकास करे;

(झ) सार्वजनिक संस्कृति का सुरक्षा रखे और हिंसा से दूर रहे;

(ञ) व्यवस्थापित और सामाजिक गतिविधियों में सभी क्षेत्रों में उत्कृष्ट को और बढ़ने का सत्ता प्राप्त करे जिससे राष्ट्र निरंतर बढ़ते हुए प्रगति और उपलब्धि की नई उंचाईयों को ले ले;

'ट) यदि माता-पिता या सर्वकाल हैं, छह वर्ष से चौदह वर्ष तक की आयु बाले अपने, यथास्थिति, बालक या प्रतिपालक के लिये शिक्षा के अवसर प्रदान करे।

1. संविधान (बंगालीसंस्करण) अधिनियम, 2002 की धारा 4 द्वारा प्रतिस्थापित।
THE CONSTITUTION OF INDIA

PREAMBLE

WE, THE PEOPLE OF INDIA, having solemnly resolved to constitute India into a SOVEREIGN SOCIALIST SECULAR DEMOCRATIC REPUBLIC and to secure to all its citizens:

JUSTICE, social, economic and political;
LIBERTY of thought, expression, belief, faith and worship;
EQUALITY of status and of opportunity; and to promote among them all FRATERNITY assuring the dignity of the individual and the unity and integrity of the Nation;

IN OUR CONSTITUENT ASSEMBLY this twenty-sixth day of November, 1949, do HEREBY ADOPT, ENACT AND GIVE TO OURSELVES THIS CONSTITUTION.

---

THE CONSTITUTION OF INDIA

Chapter IV A

FUNDAMENTAL DUTIES

ARTICLE 51A

Fundamental Duties - It shall be the duty of every citizen of India-

(a) to abide by the Constitution and respect its ideals and institutions, the National Flag and the National Anthem;
(b) to cherish and follow the noble ideals which inspired our national struggle for freedom;
(c) to uphold and protect the sovereignty, unity and integrity of India;
(d) to defend the country and render national service when called upon to do so;
(e) to promote harmony and the spirit of common brotherhood amongst all the people of India transcending religious, linguistic and regional or sectional diversities; to renounce practices derogatory to the dignity of women;
(f) to value and preserve the rich heritage of our composite culture;
(g) to protect and improve the natural environment including forests, lakes, rivers, wild life and to have compassion for living creatures;
(h) to develop the scientific temper, humanism and the spirit of inquiry and reform;
(i) to safeguard public property and to abjure violence;
(j) to strive towards excellence in all spheres of individual and collective activity so that the nation constantly rises to higher levels of endeavour and achievement;
(k) to provide opportunities for education to his/her child or, as the case may be, ward between age of 6 and 14 years.

---

1. Subs. by the Constitution (Eighty - Sixth Amendment) Act, 2002
In an increasingly globalised world and the changing paradigm of urbanized living the demand for Information Technology (IT) has increased manifold throughout the world. In this ever expanding sector, it has become essential to provide competency based Vocational Education. It is in this context that CBSE has launched a course in Information Technology under NVEQF/NSQF from level 1 to 4.

This student workbook, “IT Tools” for class XI which forms a part of vocational qualification package for students was prepared by expertise in the field. The IT-ITeS Skill Development Council approved by the National Skill Development Corporation (NSDC) for the IT/ITeS Industry developed the National Occupation Standards (NOS). The National Occupation Standards are a set of competency standards and guidelines endorsed by the representatives of IT Industry for recognizing and assessing skills and knowledge needed to perform effectively in the workplace.

It has been a deliberate effort to keep the language used in this student handbook as simple as possible for the benefit of the student. Necessary pictorial illustrations and tables have been included to help the students to understand the concepts without any difficulty.

Practicing professionals from the field of Information Technology (IT) comprised the team of authors for this book. I hope this book will help the students to serve a useful resource in this subject.

The Board is grateful to the members of the Committee of Course for their advice, guidance and total commitment towards development of this course. We are indeed indebted to these academic advisors who have lent us the benefit of their rich and insightful experience. I would like to appreciate Vocational Education Cell, CBSE for coordinating and successfully completing the work.

Comments and suggestions are welcome for further improvement of the book.

Chairman, CBSE
Acknowledgements

Advisors

1. Shri Y.S.K. Seshu Kumar, Chairman, CBSE.
2. Shri K.K. Choudhury, Controller of Examinations & Director (V.E.), CBSE

Authors

1. Naveen Kumar, Associate Professor, Computer Science Department, Delhi University, Convener
2. Anita Goel, Associate Professor, Computer Science Department, Dyal Singh College, University of Delhi
3. Hema Banati, Associate Professor, Computer Science Department, Dyal Singh College, University of Delhi
4. Sheetal Taneja, Assistant Professor, Computer Science Department, Dyal Singh College, University of Delhi
5. Shikha Badhani, Assistant Professor, Computer Science Department, Maitreyi College, University of Delhi
6. Jyotsna Talreja Wassan, Assistant Professor, Computer Science Department, Maitreyi College, University of Delhi
7. Mona Adlakha, Visiting Faculty, ARSD College, University of Delhi

Editing & Coordination

1. Dr. Biswajit Saha, Additional Director, (V.E.) CBSE.
# Contents

<table>
<thead>
<tr>
<th>Unit</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit–1</td>
<td>Computer Organization &amp; OS: User Perspective</td>
<td>1</td>
</tr>
<tr>
<td>Chapter–1</td>
<td>Computer Organization &amp; OS: User Perspective</td>
<td>2</td>
</tr>
<tr>
<td>Unit–2</td>
<td>Networking and Internet</td>
<td>15</td>
</tr>
<tr>
<td>Chapter–2</td>
<td>Networking and Internet</td>
<td>16</td>
</tr>
<tr>
<td>Unit–3</td>
<td>Office Automation Tools</td>
<td>45</td>
</tr>
<tr>
<td>Chapter–3</td>
<td>Word Processing</td>
<td>46</td>
</tr>
<tr>
<td>Chapter–4</td>
<td>Spreadsheet (OpenOffice Calc)</td>
<td>68</td>
</tr>
<tr>
<td>Chapter–5</td>
<td>Presentation</td>
<td>130</td>
</tr>
<tr>
<td>Unit–4</td>
<td>Multimedia Design</td>
<td>149</td>
</tr>
<tr>
<td>Chapter–6</td>
<td>Multimedia Design (Open Source Design Tools)</td>
<td>150</td>
</tr>
<tr>
<td>Unit–5</td>
<td>Troubleshooting - Hardware, Software and Networking</td>
<td>285</td>
</tr>
<tr>
<td>Chapter–7</td>
<td>Troubleshooting - Hardware, Software and Networking</td>
<td>286</td>
</tr>
<tr>
<td>Unit–6</td>
<td>Work Integrated Learning IT - ISM</td>
<td>315</td>
</tr>
<tr>
<td>Chapter–8</td>
<td>Work Integrated Learning IT-ISM</td>
<td>316</td>
</tr>
</tbody>
</table>
### PAPER - I

**Total Marks: - 100**  
*(Knowledge- 50: Practical-50)*

<table>
<thead>
<tr>
<th>Unit Code</th>
<th>Unit Title</th>
<th>Total Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>ITDC-301</td>
<td>Computer Organization &amp; OS: User Perspective</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>• Understanding of Hardware</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Basics of Operating System</td>
<td></td>
</tr>
<tr>
<td>ITDC-302</td>
<td>Networking and Internet</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>• Network Safety Concerns</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Network Security Tools and Services</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Cyber Security</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Safe practices on Social Networking</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Email Messaging</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Digital Literacy</td>
<td></td>
</tr>
<tr>
<td>ITDC-303</td>
<td>Office Automation Tools:</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>• Spreadsheet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Word Processing</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Presentation</td>
<td></td>
</tr>
<tr>
<td>ITDC-304</td>
<td>Multi Media Design: (Open Source Design Tools)</td>
<td>35</td>
</tr>
<tr>
<td></td>
<td>• Interface and Drawing Tools in GIMP</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Applying Filters</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Creating and Handling Multiple Layers</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Using Stamping and Smudging Tools</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Importing Pictures</td>
<td></td>
</tr>
<tr>
<td>Unit Code</td>
<td>Unit Title</td>
<td>Total Hours</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| ITDC-305 | Troubleshooting: Hardware, Software and Networking  
  - Commonly Encountered Problems  
  - (Monitor: No display, KB/Mouse not responding, monitor giving beeps, printer not responding, check for virus, Delete temporary files if system is slow, adjust mouse speed) | 10          |
| ITDC-306 | Work Integrated Learning IT - ISM  
  - Identification of Work Areas  
  - Work Experience               | 14          |
|          |                                               | 124         |
UNIT - 1

Computer Organization & OS: User Perspective
This unit aims at making the students aware of the fundamental concepts of a computer system. The key concepts that will be addressed are

- Hardware
- Software
- Functionality of a computer
- Operating system
- Types of operating system

1.1 Fundamentals

In the technological era that we live in, we use computer day in and day out. It is therefore but natural that we be aware of what constitutes this machine which solves so many of our technological and apparently not so technological problems.

In common terminology, we talk of a computer as a machine which executes a set of instructions provided by the user to produce the desired output. As per Oxford Dictionary, a computer is defined as “an electronic device which is capable of receiving information (data) in a particular form and of performing a sequence of operations in accordance with a predetermined but variable set of procedural instructions (program) to produce a result in the form of information or signals.”

The language understood by computers is what is termed as binary language, a language formulated as sequences of 0s and 1s. However, the instructions which are provided by the user are in the form of English like language. These therefore need to be converted to
machine readable format (the binary format i.e. 0 and 1) and then processed by the machine. Similarly, the result of the processing is also in a format understandable only to the machine. This also needs to be converted back into a format which humans can understand. All this is achieved by an effective co-ordination of the components of the computer; broadly categorized as hardware and the software.

The term hardware refers to the tangible components of a computer that we can touch and feel like the keyboard, mouse, monitor. However, the term software refers to the intangible components like word processor, operating system, and data. The data and/or instructions given by the user to the machine are termed as Input and the result generated by the machine for use by humans is termed as Output.

Before we look in detail these concepts let us understand the characteristics of computer that make it so special!!

1.2 Characteristics of a computer

- **Speed:** A remarkable quality of computers is their ability to process data and instructions at a very high speed. A typical high-speed computer can perform about 3-4 mips (million instructions per second). Note that this is different from the speed with which information can be sent to and from a computer, which is normally measured in baud.

- **Versatility:** is the ability of a computer to do a variety of jobs with ease. One moment you can type a letter using any of the available word processing packages, and the other moment you can use the same machine to do calculations yielding the salaries of employees of an organization.

- **Accuracy:** Not only does the machine performs varied jobs with high speed, but also does them with high precision and accuracy. Note that the errors that one may see in output produced by the computer is not because of the machine, but because of either wrong entry of data or wrong instructions given to compute. In computer terminology, this phenomena is often referred to as GIGO (Garbage In Garbage Out)

- **Diligence:** Another noteworthy feature of computer is its ability to perform the same task repeatedly over and over again without getting bored! For example a task of adding 1000 numbers repeatedly for 10000 times if given to a computer, it would be able to do the task with the same accuracy every time without complaining that it is being asked to do this job over and over again!!
Memory: One of the notable features of a computer is its memory. However, the computer’s main memory is volatile, i.e., it is lost when we switch off the computer. Therefore, computers are provided another form of memory that does not fade away when it is switched off. It is called secondary memory and is available in the form of floppy disks, pen drives, portable hard disks.

Storage: Huge amount of data and information can be stored in a computer for future retrieval. The human memory is limited and fades away with time, which is not true for a computer.

Intelligence: In the early days, although computers possessed striking characteristics yet a prominent drawback was that they are merely dumb machines which were programmed to perform certain tasks. With the advent of artificial intelligence techniques, we now have machines which can drive a car without a human driver or play chess against the best players.

Thus to summarize, this electronic device is capable of storing, processing huge amount of data and/or instructions with accuracy, diligence and high speed in an untiring manner.

Having seen the characteristics of a computer, now let us understand the way a computer works.

1.3 Block diagram of a computer

![Figure 1.1: Block diagram of a computer](image)
To understand the functionality of a computer we need to understand the processes of task execution. Following are the steps to be performed

1. **Accepts Input:** To initiate the process, the computer needs to be told of the problem to be solved. For this purpose, a set of instructions and data is provided through the input devices such as keyboard and mouse. A set of instructions provided to the computer for doing a task is called a program.

2. **Storage:** The inputs received in the above step are stored in the computer memory, called random access memory (RAM). It is also called main memory, primary memory, or working memory of the machine. Storage plays a very important role. All the inputs, the intermediate results of computation carried out, and the final result are stored in the memory of the computer. The computer also has another form of memory called secondary memory. The programs and data not currently required are stored in secondary memory. It comes in the forms such as a hard disk, pen drive, and CDROM. When required, for processing, these can be retrieved and transferred to the main memory of the computer.

3. **Control:** The manner in which the program is to be executed is managed by the control unit of the computer. This entails deciding the address from which the instructions to be executed is to be picked up, the memory location where the data or intermediate result is to be stored, etc.

4. **Processing:** The inputs provided by the user are processed by the central processing unit as per the specified instructions. The result of the processing is then either directed to the output devices or to a memory location for storage.

5. **Provides Output:** The outcome of the computation carried out by the computer is often directed to the display device such as the monitor or printer. Other forms of devices are not uncommon, for example, the computer may output music or video.

We have seen above that the input unit receives data, which is stored in the main memory, from where it gets transferred to the Central Processing Unit and subsequently to the output device. The Central Processing Unit comprises of two modules; the Arithmetic Logic Unit and the Control Unit.

*Arithmetic Logic Unit (ALU)* is responsible for processing of data. It retrieves the data from the storage unit and performs the arithmetic calculations and/or comparisons on them and the processed data is then sent back to the storage.
Control Unit is responsible for coordination between the different units of a computer. For example, it coordinates with the peripheral devices to accept the input or display the output. It also coordinates between memory and ALU by issuing timely signals.

As mentioned above, the storage unit comprises of the primary storage and the secondary storage.

**Primary Storage:** The main memory in the computer, also called primary storage comprises of RAM. This storage is relatively fast and expensive as compared to the secondary storage. As seen in Figure 1.1 primary memory is directly connected to the CPU.

**Secondary Storage:** The memory which is external to the computer system forms the secondary storage, for example, the magnetic tapes, compact disks, pen drives are all examples of the secondary storage. These are not directly connected to the CPU.

### 1.4 Inside the Computer

There are various types of computers in the market these days, desktop personal computer – popularly known as PC, laptop (also called notebook) – a small computer that can easily put on your lap, tablet – a light computer of the size of a handbook, often used for working on the Internet.

If we look at a personal computer, from outside, it comprises of a box (sometimes called CPU) that contains CPU and hard disks, keyboard, mouse, monitor and speakers. The keyboard, mouse, speakers constitute the peripherals. The major functionality is in the processing unit. Let’s now peep into the chassis of a processor!

![Figure 1.2: A peep in the computer](image)
1.4.1 Components

- **Motherboard**: This is the main circuit board which holds together various components like CPU, memory, connectors for the hard drive and optical drives, expansion cards to control the video and audio, and connections in the form of various ports (such as USB ports). It provides a connection to every component of the computer.

  ![Figure 1.3: Motherboard](image)

- **CPU**: The motherboard houses the main processor or the CPU (Central Processing Unit). CPU executes the user instruction and coordinates amongst all other units of the computer. Thus, it is primarily responsible for the performance of the machine. There are a variety of processors in the market categorized on the basis of their speed, technology (dual-core, quad-core, octa-core) and their manufacturers (Intel and AMD to name just two). Speed of a processor usually measured in **megahertz (MHz)** – millions of instructions per second; and **gigahertz (GHz)** – billions of instructions per second, is indicative of its power.

- **Power Supply Unit**: This component of the computer is the one which converts the alternate current power supply being received by homes or offices to the low voltage direct current required by the machine.

  ![Figure 1.4: Power Supply Unit](image)
**Hard disk:** It is the secondary storage device for storing the data. The program which is to be executed is first stored in the hard disk from where it is transferred to RAM. On completion of work, the program is again saved on the hard disk.

![Two sided view of a sealed hard disk unit](image)

It is usually characterized by the performance and its capacity. Memory capacity is specified in terms of bytes. These days the capacity of a hard disk is expressed in terms of Gigabytes, Terabytes.

Let’s look into the hierarchy of the terms used to specify the capacity

Everything in computer is stored in terms of Bits (Binary Digits) i.e 0’s and 1’s

- 1 nibble = 4 bits
- 1 byte = 8 bits
- 1024 bytes = 1 Kilobyte (KB)
- 1024 KB = 1 Megabyte (MB)
- 1024 MB = 1 Gigabyte (GB)
- 1024 GB = 1 Terabyte (TB)
- 1024 TB = 1 Petabyte (PB)

And this is how a Compact Disk drive looks like
**Random Access Memory (RAM):** This memory storage plays an important role in the functioning of a computer system. Every time you start up the computer, the operating system (the system software that manages the device’s interaction with the peripherals and the internal resources) is loaded in the RAM. The program that needs to be executed at any point of time also needs to be brought in the RAM. These days the PCs have around 8-32 GB RAM. More the RAM, more will be the space for the programs leading to faster execution. Of course, everything in computers is subject to some limits.

All these components need to work in co-ordination and this is accomplished by the operating system. It initializes the system for our use. In the next section, we study the basics of operating systems.

**1.5 Operating system**

A computer needs to communicate with both the hardware and software; to do this; it utilizes the services of an Operating system. Examples of some popular operating system are Windows, Linux, Unix, MS-DOS, SOLARIS, MAC OS. The operating system acts as an interface between the users of the system and hardware of the system. It also acts like a government which lays down policies for efficient utilization of the resources and provides for effective co-ordination amongst the various components of a computer. Every computer system whether it is an independent system like a desktop or a cell phone must have an operating system for performing the core functionalities like accepting input from various input devices, directing the output to the display, managing the files and directories, communicating with hardware, and installing/uninstalling of peripheral devices.
1.5.1 Functions of an Operating system

The prime functions of an operating system can be broadly categorized as:

- Providing for communication between User and computer
- Resource management
  - Process management
  - File management
  - Memory management

Figure 1.8 presents the various functions of an operating system.
Communication Manager: Manages the communication needs of the system, be it communicating with the peripheral devices or the internet, are addressed by the operating system. Each of the peripheral devices like printer, mouse have unique characteristics and the computer needs to know these unique properties, to interact with them. For this, the operating system uses special programs called drivers which enable recognition of these devices and their properties.

Resource Management: The working of a computer system is predominantly dependent on how its resources are being managed. The resources that we talk of here; are the memory of the computer, the CPU time, files, secondary storage, input/output devices etc. The operating system handles the allocation of all such resources, the priority in which these are allotted to the various processes to get an optimum performance from the system. We discuss here the prime resource management.

Process Management: A process is a program currently executing in the memory or waiting for the CPU. In a computer there are multiple processes in the system. The OS manages, controls, schedules all the processes being executed in the computer. It decides which process gets the processor and for how long.

Memory Management: For a process to be executed, it has to be loaded in the working memory that is the RAM (Random Access Memory). The memory management component of an operating system allocates memory to the processes in a dynamic manner that is allocated on demand and released when not needed.

File Management: Operating system takes care of all the files and folders (directories) maintained on the computer disk. The basic tasks that a user needs to perform on files are creation, renaming, deletion, copying or moving of a file or folder. All the files stored in a computer system can be located through the file system. Two main types of file system are File Allocation table (FAT) or New Technology File system (NTFS).

1.5.2 Types of Operating system

Operating systems can be classified in different ways; depending on various parameters.

- Single-tasking and Multi-tasking

Single tasking such operating systems allow execution of only a single program at any given instant

Multi-tasking As the name suggests, multi-tasking operating system can execute more than one programs simultaneously. The processor time, in this case, is divided amongst various processes.
- **Single user and Multi-user**

  *Single-user* operating systems allow only one user to use the system. The desktop systems can be classified as typical single user systems.

  *Multi-user* operating systems allow many users to access the system by maintaining an account of all the registered users.

- **Real-time Operating System**

  Operating systems which ensure that the response time is fixed are categorized as real-time operating systems. They are intended for applications where data needs to be processed quickly, without any significant delays. For example, an antiaircraft missile system must fire as soon as it receives signal from the enemy aircraft, before it leaves the bomb and flies away.

- **Batch Processing Systems**

  In a batch processing systems, similar jobs are clubbed together and submitted as a block to the processor for execution. User intervention is minimal in such systems. The jobs are picked up one by one and executed.

### Exercises

**Fill in the blanks**

1. The unit used to measure the performance of a computer is ................... .
2. Two main types of File system are ...................... and ...................... .
3. 1 petabyte = ....................... bytes

**Short Answer questions**

1. List the various functions of an operating system.
2. Compare batch processing systems and multiprogramming systems.
3. Why do devices need device drivers?

**Hands-on Exercise**

Check up the configuration of your personal computer and find out the following

a) The processor type, make, speed
b) Amount of RAM
c) Hard disk capacity

d) Number of ports

Do this for few more machines and tabulate the data. Analyze how each of them influences the performance of the computer system.

Identify the operating system installed on your home computer. Classify it on the basis of operating systems studied in the chapter.

Identify two instances of hard real-time and soft real time systems.
UNIT - 2

Networking and Internet
In the beginning of civilization humans communicated via means such as oral, gestures, and touch. Knowledge transcended from one generation to another largely by way of oral traditions, and later on by inscriptions on stone and metal until early forms of paper were developed. However, education remained largely confined to the elite until the invention of printing press by Johannes Gutenberg, around 1440. It lead to dissemination of information through newspapers and books and provided a new and versatile method of communication of information. This was followed by the era of telegraph and telephone marking nineteenth century. Twentieth century saw the development of commercially viable radio and television which became instrumental in dissemination of information and entertainment. ARPANET that began with a network connecting computers in a few organizations in early sixties paved the way for Internet in early eighties that revolutionized not only the exchange of information amongst individuals and organizations, but also the way organizations do business, and the people educate, entertain, and organize themselves. Social networking, instant messaging, voice calls (through VOIP), media are influencing the definition of Internet being used.

2.1 Evolution of Networks and Internet

In 1876 Bell came forward with the concept of communication through telephone lines leading to development of Public Switched Telephone Network (PSTN) in 1877. It opened the new frontiers allowing several homes to connect through telephone lines. From that time, communication was mainly through telephone lines. In late 1950s, all the military communications started using telephone networks setting up dedicated connection between the two parties. This dedicated connection made use of technology called circuit switching. The connection comprised of several intermediary lines and switching offices enroute. They were vulnerable to danger of damage to the switching offices which may disrupt the entire network. At the peak of cold war, US Department of Defense (DoD) realized the need to establish fault-tolerant network that would not fail at the time of nuclear war and could survive a single point failure in the network. Paul Baran along with Donald Davies and
Len Kleinrock came forward with the idea of digital packet switching in which the message to be transmitted is divided into small chunks called packet. Unlike circuit switching in which resources are reserved along the dedicated path of communication, packet switching is based on link sharing.

US Department of Defense realized the need to connect geographically separated research computers together to form a network. This led to the development of Advanced Research Projects Agency Network (ARPANET) in 1969 (Figure 2.1). ARPANET made use of technology called digital packet switching. Initially its use was restricted to non-commercial purpose such as military and research. Subsequently, its use extended to education by supporting various educational institutes.

Need for communication between various heterogeneous networks led to the development of TCP/IP (Transmission Control Protocol/Internet Protocol) in 1970. Along with several smaller networks, another large network called NSFNET was developed in 1984 by NSF, U.S. National Science Foundation for research and education purpose. When ARPANET and NSFNET were interconnected, the network growth increased tremendously. TCP/IP protocol (rules for communication) acted as a glue to connect various heterogeneous networks together into a single network. This wide network is an Internet (network of networks).
With the advent of Internet, the whole world got connected on a global level. In mid 1990s, the number of nodes connected through Internet began to grow exponentially. Several government and private organizations, collectively called Internet Service Providers (ISPs) joined hands to provide connectivity for Internet. Internet made it possible to exchange information and communicate with remote nodes. There are several applications of Internet such as e-mail, file transfer, remote login, and World Wide Web (WWW).

### 2.2 Computer Networks

Nodes or stations are electronic devices such as computers, printers, Fax machines, and telephones which communicate with each other by sending and receiving data/message. Figure 2.2 depicts a one-way simple communication system that comprises the following components:

- **Sender**: The node that is responsible for sending the data.
- **Receiver**: The node that is responsible for receiving the data.
- **Message**: Message is the information or meaningful data that is being communicated in a structured form.
- **Channel**: Channel is the communication medium through which message is transmitted.

A collection of interconnected nodes which communicate by means of some channel form computer network. The communication taking place in a computer network can be categorized as simplex, half-duplex, and full-duplex. In simplex mode, information can be transferred only in one direction. This mode is termed unidirectional. In computer networks, the data transmitted using many fiber optics and satellites is simplex in nature. Half-duplex mode is a bidirectional communication between the two nodes, however, only one node at a time can transmit the data. This mode is generally used for transferring files between nodes in a low-bandwidth setting. In full-duplex mode, both communicating parties can send and
receive at the same time. The interactive applications use this mode of communication, thus speeding up the data transfer. NIC (Network Interface Card) on the systems for networking supports full-duplex mode.

Computer networks can be used as means of resource sharing and communication.

- **Resource Sharing**: Connecting computers through networking allows us to share hardware and software resources. Examples of hardware resources include peripherals (for example, printers and scanners), CPU, and memory. Examples of software resources include system and application software, and files that may include text, audio, and video content. Note that in the network shown in Figure 2.3, all the three computer systems are connected with each other and to the printer through the network facilitating sharing of printers.

```
Figure 2.3: Computer Network
```

- **Communication**: Connecting computers through network facilitates exchange of information amongst the nodes in the network. For example, any of the computer systems in Figure 3 may send data to any of the three computer systems or the printer, as it is connected to every node in the network.

Creation of a network requires various network devices such as modems, routers, switches, and bridges, each of which plays a specific role in the network. Networks differ on the basis of transmission media used, arrangement of nodes in the network, their geographical span, and their purpose.
2.2.1 Transmission Medium

A transmission medium refers to the channel of transmission through which data can be transmitted from one node to another in the form of signal. A signal encodes the data in a form suitable for transmission on the medium. A medium is characterized by its bandwidth defining the information carrying capacity of the medium. A transmission medium may belong to one of the following two categories:

- **Guided Medium**: The term refers to physical conductor such as twisted pair, coaxial cable, and fiber optics. In twisted pair and coaxial cable, the signal travels as voltage and current signal whereas in optical fibre, the signal is in the form of light.

- **Unguided Medium**: The unguided medium uses electro-magnetic waves that do not require a physical conductor. Examples of unguided medium include infrared, radio, and microwave.

2.2.2 Topology

The arrangement (also called layout) of nodes in a network is called network topology. There are broadly two types of topologies – broadcast and point to point. In broadcast topology, all nodes share the same physical link. When one node transmits, all nodes receive. Collision may occur when more than one node simultaneously transmits, and there is collision resolution mechanism for handling it. Broadcast topologies are mainly bus and ring. In point to point topology, every pair of nodes has a dedicated link. Popular point to point topologies are star and mesh.

- **Bus Topology**

In bus topology, there is a long cable, called backbone cable (or simply backbone), that connects various nodes through connector called tap as shown in Figure 2.4. In this, a message sent by one is received by all devices connected to backbone cable. This topology requires less cabling and is easy to install and extend the network laid using it. However, fault detection and isolation is difficult.

![Figure 2.4: Bus Topology](image)
**Ring Topology**

In ring topology, all the devices are attached through a cable in the form of ring as shown in Figure 2.5. The message to be communicated is transmitted in one direction, thereby, relaying the message to the intended recipient. Addition and deletion of devices, and fault detection and isolation is easy. However, the topology suffers from the limitation of single point failure leading to disruption of entire network. Sending a message from one node to another node may take more time (four steps while sending message from device A to E).

![Figure 2.5: Ring Topology](image)

**Star Topology**

In star topology, all the devices are connected to the central controller called hub as shown in Figure 2.6. Communication between any two devices takes place through the hub responsible for relaying messages. Star network can be easily installed and configured. Also, fault detection and isolation is easy. However, it requires more cabling as compared to bus and ring topology. Also, hub failure will lead to network failure.
Mesh Topology

In mesh topology, every node is connected with every other node in the network as shown in Figure 2.7. Because of dedicated point to point connection between every possible pair of nodes, the topology provides secure data transfer without any traffic problem. It requires a large number of connections establish the topology. This leads to difficulty in installation as the number of nodes grow as the network grows.

Tree Topology

Tree topology is a hybrid topology using combination of star and bus topology. Backbone cable in a bus topology acts like the stem of the tree, and star networks (and even individual
nodes) are connected to the main backbone cable like the branches of tree as shown in Figure 2.8. Damage to a segment of a network laid using tree topology will not affect other segments. Installation and configuration is difficult as compared to other topologies. Also, if the backbone cable is damaged, the entire network communication is disrupted.

![Tree Topology Diagram](image)

2.2.3 Network Types

On the basis of geographical span, network can be broadly categorized as LAN, MAN, and WAN.

- **LAN** stands for Local Area Network. Local Area networks are private networks and can span a radius of up to 1 Km. They are generally established within a building or campus shown in Figure 2.9. LANs operate at a speed in the range 10 Mbps to 1 Gbps.
**MAN** stands for Metropolitan Area Network. It may be owned by a single organization or by many individuals or organizations. These networks are used to establish link within a city, and span an area of radius up to 50 Km. MANs facilitate sharing of resources by connecting various local area networks (Figure 2.10). For example, a cable television network within a city.

**WAN** stands for Wide Area Network. Typically a WAN spans a segment of about 1000 Km. They are used for long distance communication and are well suited for connecting remote areas. They establish link within a country or continent. A WAN may be owned and managed by several organizations. It connects various local and metropolitan area networks as shown in Figure 2.11.
2.2.4 Internet Working Devices

Creation of a network requires various network devices, each of which plays a specific role in the network.

◆ Repeaters

With increase in distance, a signal may become weak and distorted. A repeater is used to restore the input signal to its original form, so that it can travel a larger distance. Thus, it is placed between two cable segments as shown in Figure 2.12. It is also known as digital regenerator which reshapes and amplifies the digital signal.
Hub

Unlike a repeater which connects two cables, a hub connects several lines, also called, cable segments. A hub comprises several input/output (I/O) ports, each of which connects to a single cable as shown in Figure 2.13. Data arriving on an incoming line is output to all lines except the line on which the hub receives the data.

Bridge

A bridge is a multiport device used for connecting two or more local area networks (LAN), possibly operating at different speeds as shown in Figure 2.14. Thus, a bridge may be used to produce bigger LAN by combining smaller LANs. A bridge enables devices on one LAN segment to communicate with the devices on another LAN segment. Unlike hubs, they are intelligent devices which exercise discretion while forwarding data to the outgoing line leading to destination.
**Switch**

Unlike bridges which connect two or more LAN segments, switches are used to connect individual nodes in the network with each other. Each node within network is connected to a unique port in the switch as shown in Figure 2.15. On receiving the incoming data frame, it forwards it to only single line connecting to the destination node. All the nodes connected through switch forms only one LAN.

![Figure 2.15: Switch](image)

**Router**

Routers are used for connecting various networks (LAN or WAN) with each other as shown in Figure 2.16. A router transmits data from incoming network to another network. A router maintains a routing table of various networks. Based on the destination address, the router determines to which network the incoming packet should be transmitted.

![Figure 2.16: Router](image)
◆ **Gateway**

A gateway connects networks based on different protocol technologies to communicate with each other. Data coming from one network operating on one protocol is converted according to the protocol of outgoing network, and then forwarded. Thus a gateway may be thought of as a router equipped with software for protocol conversion.

### 2.3 Internet

A wide network of networks i.e. interconnection of WANS form the global Internet. It is neither owned by any single individual nor by any single organization. It has made it possible to exchange information and communicate with remote nodes. One can access the Internet using several means such as leased line, dial-up access, and wireless connectivity. The machines on the Internet are known as hosts. The machine that initiates a request is called client and the machine that processes a client request is called server.

Communication between any two machines on the Internet is governed by the universal TCP/IP protocol – glue that holds entire Internet together. A network protocol defines the rules and conventions of communication that must be followed when two devices interact with each other. It specifies what should be communicated, and how and when communication should take place.

There are several applications of Internet such as e-mail, file transfer, remote login, and World Wide Web (WWW) listed below:

◆ **Electronic Mail (E-Mail)**

An email may be a written text and may include multimedia attachment consisting of text, audio, image, or video. Sender of the e-mail may send it to one or more intended recipients. Sending and receiving of mails can take place through web based e-mail application also called webmail application, (such as, Gmail, Windows Live Hotmail, and Yahoo), or a desktop based e-mail applications (such as, Microsoft outlook, Thunderbird, mail application on mobile phone). Transferring mail over the Internet is governed by a set of rules known as email protocols such as SMTP (Simple Mail Transfer Protocol) and POP3 (Post Office Protocol).

◆ **File Transfer**

Transferring files from one machine to another through a TCP based network is done using FTP (File Transfer Protocol). File Transfer Protocol is based on client server architecture. Using FTP, local host (client) can download or upload files to and from remote host (server).
Remote Login (TELNET)

TELNET stands for TElminaL NETwork. It is a client server based application that allows the user working on one system to access a remote system. For initiating remote login, the user (client) should specify the address of remote system, and should authenticate himself/herself using username and password mechanism. On successful login, the client can access the remote system. TELNET service is often used for accessing data on the remote host, or executing on the server the applications installed on it (server).

World Wide Web (WWW)

World Wide Web (WWW), commonly known as web, is a repository of information on machines spread all over the Internet and linked to each other. The information is organized in the form of documents called web pages. A web page may contain text, images, audio, videos, and information for linking the web pages in the form of hyperlinks. WWW uses distributed client server architecture based on HTTP (Hyper Text Transfer Protocol). The client request is relayed through Internet to the appropriate server, which sends back the reply through Internet to the host system. A simplified view of how a request for information on WWW may be handled on WWW is shown in Figure 2.17.

![Figure 2.17: WWW and Internet](image)

2.4 TCP/IP Model

The TCP/IP (Transmission Control Protocol/Internet Protocol) is often called the glue which holds Internet and WWW (collection of servers where information is stored) together. When we are dealing with the Internet, we are essentially dealing with the TCP/IP model. The simple task of sending the data from one place to another through network...
requires several sub-tasks such as specifying sender and receiver’s network and physical address, dividing the message into smaller fragments so that they can be easily transmitted over Internet, taking appropriate measures for error and flow control, and taking necessary action on receiving the message. These sub-tasks or functions are performed by different layers of TCP/IP model as shown in Figure 2.18.

<table>
<thead>
<tr>
<th>Application Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transport Layer</td>
</tr>
<tr>
<td>Internet Layer</td>
</tr>
<tr>
<td>Link Layer</td>
</tr>
</tbody>
</table>

*Figure 2.18: TCP/IP Model*

As shown above, TCP/IP model comprises of four layers, Application layer, Transport layer, Internet layer, and Link layer. On each layer, several protocols operate which define rules for transmission of data.

Data/message is created at the sender’s end at Application layer. At the receiving end it is examined and processed (possibly displayed) at Application layer. This layer is also responsible for enveloping the message to be sent with the header. Several protocols such as HTTP, SMTP, POP3, and TELNET (remote login) operate on this layer.

Application layer passes the message to the Transport layer which appends the information about the source and destination ports of the processes at two ends. At the ends, the ports process the message. Mainly two end-to-end protocols operate at this layer, namely TCP and UDP. TCP (Transmission Control Protocol) is a reliable connection-oriented protocol needed when timely and error free delivery of data is important. UDP (User Datagram Protocol) is an unreliable connectionless protocol needed in a scenario such as exchange of short messages and client server request-reply messages, where immediate response is more important rather than assured delivery. Also it may be used as a transport protocol for streaming video because the occasional loss of a packet is acceptable. Further, transport layer divides the message into a number of fragments, called segments, depending upon the maximum transmission size permitted. In TCP, each segment will carry the sequence number denoting its relative position in the message, so that, the message can be assembled at the receiver end by the transport layer at recipient’s end.

Transport layer hands over the segments to the Internet layer which adds source and destination machine network address (also termed IP address). Internet layer is mainly
responsible for packet routing and injects packets into the network that may take independent path to the destination, and thus may arrive out of order at the destination. At the receiving layer, message is reassembled in the correct order. In the Internet layer, Internet Protocol (IP) is used. IP defines the format of packets exchanged over the Internet. This protocol is usually accompanied by three other protocols, namely, Internet Control Message Protocol (ICMP), Address Resolution Protocol (ARP), and Dynamic Host Configuration Protocol (DHCP).

Link layer is also called Host to Internet layer. This layer is responsible for adding the header containing sender and receiver physical address to the packet received from Internet layer. The resulting message is called frame. It may be noted that recipient’s physical address corresponds to the physical address of the next host on the network to which message is to be relayed, and not (necessarily) the physical address of the destination machine.

Suppose host 1 wishes to send a message Hello to host 2. Diagram in Figure 2.19 illustrates how layer by layer message is processed at the host 1 and host 2.

![TCP/IP Model Diagram](image)

**Figure 2.19: Message transfer illustrated through TCP/IP Model**

### 2.5 Network Safety Concerns

With increase in use of network for accessing data and resource sharing, security is becoming a prime concern. Large amount of data placed on the Internet and substantially increasing
number of users are leading to security issues such as misuse of data, hacking, copyright issues and many more.

2.5.1 Malwares

The term malware refers to malicious software (programs) designed with the intention to affect the normal functionality by causing harm to the system, or with the intention of getting unauthorized access to the system, or denying access to legitimate users of computing resources. A malware may be virus, worm, Trojan horse, or spam.

◆ Virus

A virus is a software code that may harm your system by overwriting or corrupting the system files. A computer virus is similar in action to viruses in our body which replicate themselves and affect body cells. The affected part is called infected area. A computer virus may make several copies of it by inserting its code onto the system programs, files or boot sector of hard drives and thereby may corrupt them. This causes the system to slow down or even stop functioning. The viruses are mainly categorized as boot sector virus, file infector virus, and macro virus.

Boot sector viruses affect boot record of the disks. These are the memory resident viruses that embed themselves into the disk area and are activated when the drive is started (booted up), for example, Michelangelo virus. File Infectors are the viruses that attach themselves to executable files either by overwriting a part of their code or by appending their code to the files, for example, Romeo and Juliet virus. Macro viruses embed themselves into the documents. These viruses are executable files which are often received as email attachments. When attachment is opened, viruses starts functioning by affecting the system programs (by deleting, creating or overwriting other files), and may get forwarded to others whose email id appears in the address book. Melissa is an example of such a virus, which got spread through a Microsoft word document sent as an email attachment.

◆ Worm

A worm is often received via network, and it automatically keeps on creating several copies of itself on the hard disk thereby flooding the hard disk. When worm is received as an email attachment, it is automatically forwarded to the recipients leading to network congestion. Thus a worm may crash the system and entire network. No host application is required for worms to replicate themselves. For example, Code Red Worm which makes more than 2,50,000 copies of itself in approximately 9 hours.
**Trojan Horse**

Trojan Horse is a code that appears to be desirable and useful but ends up harming the system. Trojan horse can attach itself with a safe application. For example, it may be attached to any game downloaded over Internet. Such an application when executed creates a backdoor in the system through which a hacker can access the system. The hacker can also control the infected system by harming the data on the system. For example, in late 1990s, Trojan Horse named Sub7 was created which took advantage of security flaw of earlier version browsers such as Internet Explorer and Chrome to illegally access the host computer.

**Spam**

Spams are the unwanted electronic mails, generally sent in bulk over the Internet to recipients. Such undesirable mails are generally commercial mails sent for advertisement purpose. However, they may contain link to phishing sites that attempts to steal user information or link to sites that contain malware or infected files. Spam mail filters used by e-mail software can be used to prevent spam mails.

### 2.5.2 Phishing

Phishing refers to the act of stealing user’s personal information through fraud mails. These mails either entail personal information through embedded forms, or contain links to the web page that may prompt you to provide this information. Information attempted to be stolen may include bank account number, debit/credit card number, passwords or any other valuable data. Few main causes that make end users victims of phishing include:

**Lack of awareness**

Many a times we end up providing our account information in the mails received from our bank. Such mails though appear to be legitimate but are fraudulent. Lack of awareness that bank will never ask for account PIN and password either through mail or message make us prey of these targeted attacks.

**Misleading Mails**

Often fraud mails received contains tempting information such as bag a lottery prize, or a warning indicating closing of account in case of failure in proving account details.

**Lack of Security**

Lack of inadequate security measures on computers is also a main cause that makes us fall prey to phishing.
2.5.3 IPR Issues

The intellectual property is the work produced by a person or an organization using the mind and creativity. The intellectual property comprises of intangible assets such as literary work, artistic work, a work of music, and an engineering design. Intellectual Property Rights (IPR), are the rights of a person or an organization on intellectual property. Commonly defined Intellectual Property Rights include patents, copyright, industrial design rights, trademarks, trade dress like visual appearance of a product or its packaging, and trade secrets. There are various issues concerned with these rights such as piracy of software, plagiarism (presenting the literary work done by someone as own work), trademark violations, patent violations, and copyright violations.

2.5.4 Hacking

Hacking may be described as having unauthorized access to someone’s computer or computer network for stealing resources such as password or confidential files, or causing harm to network or system. A hacker identifies the vulnerabilities of the system in order to achieve this. A hacker may be driven by several reasons for doing so such as his/ her own personal interest, as a means of fun, or protest. Hackers are also categorized as good hacker and bad hacker. Bad hacker hacks the system with bad intensions whereas good hacker tries to hack system in order to identify its weaknesses so that they can be isolated. These bad (unethical) hackers are termed crackers, as opposed to good (ethical) hackers.

2.6 Network Security Tools and Services

Since Internet has emerged as a prime tool for sharing resources and accessing data, exponentially growing number of users are using it with both good and bad intentions. Everyone accessing the Internet needs to be aware of the security issues and take protective measures to address the same. Systems that are used as a tool for accessing Internet can be protected using anti-virus and firewall. Also, one needs to take into account several measures while accessing Internet.

2.6.1 Protection using Anti-Virus

Anti-virus is software that aims to protect your system against malicious and potentially unwanted programs. It is responsible for detecting these malicious programs by searching for them, and removing them to keep the system protected. The software operates by maintaining a database of malware definitions, which are automatically updated. It searches for any malicious program by scanning the files against the stored malware definitions for
a match. In case of a match, they are declared as potentially harmful, and are disabled and removed depending upon anti-virus software settings.

### 2.6.2 Protection using Firewall

A firewall aims at protecting the internal network of an organization, home, or individual from malicious traffic from external networks. A router or a computer (often dedicated to serve as a firewall) may be installed between external network and internal network for this purpose. Firewall inspects the network traffic, and allows only that data to pass through the network that does not violate the security constraint. Hardware firewall in form of router prevents malicious software from entering your network from outside network. However, software firewall installed on personal computer prevents unauthorized access or malwares from gaining access to personal computer. An example of a firewall is shown in Figure 2.20. Network firewalls may also encrypt the incoming data by converting it to non-readable format, thus, adding further protection.

![Figure 2.20: Firewall](image)

### 2.6.3 Protective Measures while accessing Internet

- Never click on a suspicious link specified on a web page or send through a mail for which you are not sure about its authenticity.
- Make sure that passwords are strong and are changed frequently. Passwords are the means for authenticating users, thereby allowing access to networked systems. Weak passwords have smaller length and uses small subset of possible characters, and thus, are subjected to be cracked easily. One should also avoid setting obvious passwords such as names, mobile numbers, or date of birth. Passwords should be strong having long length and including characters such as numbers and punctuation signs.
Never disclose personal information such as account details, passwords, credit and debit card details, and other valuable information. Also, report phishing issues to the concerned authorities. In case of unsolicited mails, mark them as spam mails.

Security of the communication made over the Internet can be indicated by the security of protocol being used. Secured Hyper Text Transfer Protocol (HTTPS) is a secure version used for communication between client and host on the Internet. So, ensure that all communications are secure, especially online transactions.

The security of website can be ensured if there is padlock on the left side of address bar. It indicates that website has a SSL (Secure Socket Layer) digital certificate issued by trusted party which ensures and proves identity of remote host.

Ensure that the web browser being used for accessing web is updated and is secure. For example, chrome browser is up to date, if the security patch indicated by three horizontal lines on top right corner is grey in color. Green, orange and red color security patch indicates that browser update is available for two, four and seven days respectively.

Make sure that the website address is properly spelled. Because there may be two websites with almost same name, one being a phishing website.

The anti-virus software should be up to date.

Delete cookies periodically. A cookie is small piece of information about the client browsing a website. On receiving a request from a client, the server records the client information such as domain name and registration id on the server site in the form of a file or a string. The server sends this cookie along with response requested by the client. At the client side, the browser stores this cookie received from the server in a directory called cookie directory. By obtaining access to these cookies, hacker may gain unauthorized access to these websites. Thus, cookies should be deleted occasionally along with the temporary files stored on our system during web browsing.

2.7 Cyber Security

Cybercrimes are the crimes related to the misuse of computer or Internet such as theft, fraud, and forgery. The IT act defines cybercrime as an unlawful act where in the computer is either a tool or a target or both. Some of these crimes are mentioned below

1. Sending spam mails to uninterested recipients.
2. Hacking someone’s account or system.
3. Stealing someone’s personal information through phishing
4. Hosting a site carrying lots of malwares or being a source for spreading them.
5. Harassing someone through mails, messages or social networking.
6. Posting offensive content on any site or sending it to anyone.
7. Defaming someone using Internet.
8. Forging someone’s digital signatures
9. Indulging in fraudulent financial transaction
10. Providing misleading information to clients/ general public through use of Internet resources
11. Intellectual Property theft

Cyber laws are the laws for systematic use of e-resources, for example, e-business, and serve as a measure against illegal cyber-crime. Various cyber laws have also been enacted to prevent cyber-crimes and take action against those involved in such crimes. These laws define the action that would be taken against people committing the offences. For cyber security, an amendment in IT Act 2000 named Information Technology Amendment Act, 2008 was also introduced. The act also defines offences and penalties for cyber-crime. Cyber police is responsible for detecting such crimes and taking the necessary measure against it in accordance with IT Act.

2.8 Safe Practices on Social Networking

Social network refers to the network of people interacting and sharing information such as their views, photographs, videos and any other information. Popular social networking sites include Facebook, LinkedIn, and Twitter. Facebook is social networking site with a purpose to connect with the world around you. LinkedIn is a business oriented social networking site that aims to connect people professionally. Twitter is a site where people share their views in form of short messages known as tweets limited to 140 characters.

Social networking has emerged as an important platform where people bounded geographically by distance can communicate and share their views. Often, people interacting with each other share similar interest. It is also an important means for raising awareness about an issue. However, since information spread so quickly, it may be misused for spreading a rumor. Moreover, many users with fake identities get involve in unethical use of the information
available on these sites. So, users need to be aware while posting or accessing any data as it may lead to data theft, data misuse or can be a source of malware.

Social networking can also take place in discussion forum and chat room setting. Discussion forums allow people to share their queries and views by posting on them. Anyone can initiate a discussion by placing a post on discussion board, and can also comment on the posts initiated by others. People participating in a discussion need not be online all the time. These forums are managed by a moderator, who control the content posted on it. Chat room setting is similar to discussion forums, where people can discuss their ideas and queries; however, they need to be present online in order to participate in the currently ongoing discussion.

Though social networking offers several benefits to the users, it also has various safety concerns. One need to follow below mentioned safe practices while getting involved in social networking:

- Do not post any personal information and photos on the social networking site as it may be misused against you by some unethical user. Personal information even includes details such as date of birth, home address, personal phone number, and work history details.

- Take accountability while posting anything on the social networking site as it will be permanent and can be used for making analysis about you.

- It is always better to set your own privacy settings, rather than going for default settings. You should limit the access to your profile only to selected group of people. Also, you can limit the people who can search you by your name.

- Be selective while making friends on the social networking site. Do not send or accept friendship request from any unknown user. Also, trust the authenticity of a message only if you are sure about its origin (sender).

- Do not post any offensive content on social networking site as it may lead to a criminal action against you.

- Beware before spreading any kind of a rumor as it may be treated as a cyber-crime.

- If someone is harassing or threatening you, take snapshot of it as a proof, and block the person. Also, report the incident to the site administrator.

- Also, take all protective measures while accessing Internet such as protecting the system using anti-virus and firewall, secure browsing, and password management.
2.9 Digital Literacy

Digital literacy refers to raising knowledge and awareness about technology such as desktop computers, smartphones, tablets, and other electronic gadgets. It also includes familiarity with software tools and Internet. This knowledge facilitates people to acquire, analyze, share, create, and deliver information in efficient and constructive way. Digital literacy also aids people in several arenas such as education, social networking, e-commerce, healthcare, and tourism. Especially in education, it provides learners with the digitally enhanced learning through use of technology. They can use technology to access Massive Open Online Courses (MOOCs) which are providing opportunities to study irrespective of the boundaries of time and space. Moreover, Prime Minister Narendra Modi has taken an initiative to make India, a Digital India to use technology proficiently and ethically. The campaign promotes building up of India-wide digital infrastructure to provide government services digitally to people even in remote areas.

Points to Remember

- A communication system comprise of four components: sender, receiver, messages, and channel.
- A collection of interconnected nodes (electronic devices such as computers, printers, fax machines, and telephones) which communicate by means of some channel form computer network. Computer networks can be used as means of resource sharing and communication.
- A transmission medium refers to the channel of transmission through which data can be transmitted from one node to another. A transmission medium can be categorized as guided and unguided medium.
- Guided medium refers to the physical conductor such as twisted pair, coaxial cable, and fiber optics. The unguided medium uses electro-magnetic waves that do not require a physical conductor, for example, infrared, radio, microwave, and satellite links.
- The arrangement (also called layout) of nodes in a network is called network topology.
- In bus topology, there is a long cable, called backbone cable (or simply backbone), that connects various nodes through connector called tap.
- In ring topology, all the devices are attached through a cable in the form of ring.
- In star topology, all the devices are connected to the central controller called hub.
In mesh topology, all nodes are connected with every other node in the network.

Tree topology is a combination of star and bus topology. Backbone cable in a bus topology acts like the stem of the tree, and star networks (and even individual nodes) are connected to the main backbone cable like the branches of tree.

LAN stands for Local Area Network. They are private networks and can span a radius of up to 1Km. They are generally established within a building or campus.

MAN stands for Metropolitan Area Network. It may be owned by a single organization or by many individuals or organizations. These networks are used to establish link within a city, and span an area of radius up to 50 Km.

WAN stands for Wide Area Network. Typically a WAN spans a segment of about 1000 Km. They establish link within a country or continent.

A repeater is used to restore the input signal to its original form, so that it can travel a larger distance. It is also known as digital regenerator.

A hub comprises several input/output (I/O) ports, each of which connects to a single cable segment.

A bridge is a multiport device used for connecting two or more local area networks (LAN), possibly operating at different speeds.

Switches are used to connect individual nodes in the network with each other.

Routers are used for connecting various networks with each other. A router transmits data from incoming network to another network.

A gateway connects networks based on different protocol technologies to communicate with each other.

A wide network of networks is known as Internet. It has made it possible to exchange information and communicate with remote nodes.

A network protocol defines the rules and conventions of communication that must be followed when two devices interact with each other. It specifies what should be communicated, and how and when communication should take place.

An email may be written text and may include multimedia attachment. Sender of the e-mail may send it to one or more intended recipients. Sending and receiving of mails can take place through web based e-mail application.
 FTP is a File Transfer Protocol used for transferring files from one machine to another through a TCP based network.

TELNET stands for TErminaL NETwork. It is a client server based application that allows the user working on one system to login and access a remote system.

World Wide Web (WWW), commonly known as web, is a repository of information on machines spread all over the Internet and linked to each other.

A web page may contain text, images, audio, videos, and information for linking the web pages in the form of hyperlinks.

The TCP/IP (Transmission Control Protocol/Internet Protocol) is the glue which holds Internet and WWW (collection of servers where information is stored) together.

The term malware refers to malicious software (programs) designed with the intention to affect the normal functionality by causing harm to the system, or with the intention of getting unauthorized access to the system, or denying access to legitimate users of computing resources.

A virus is a software code that may harm your system by overwriting or corrupting the system files. A computer virus may make several copies of it by inserting its code onto the system programs, files or boot sector of hard drives and thereby may corrupt them.

A worm is a malware often received via network, and it automatically keeps on creating several copies of itself on the hard disk thereby flooding the hard disk.

Trojan Horse is a code that appears to be desirable and useful but ends up harming the system. Trojan horse can attach itself with a safe application. Such an application when executed creates a backdoor in the system through which a hacker can access the system.

Spams are the unwanted electronic mails, generally sent in bulk over the Internet to recipients. Such undesirable mails are generally commercial mails sent for advertisement purpose. However, they may contain link to phishing sites that attempts to steal user information or link to sites that contain malware or infected files.

Phishing refers to the act of stealing user’s personal information through fraud mails. These mails either entail personal information through embedded forms, or contain links to the web page that may prompt you to provide this information.
The intellectual property is the work produced by a person or an organization using the mind and creativity. Intellectual Property Rights (IPR), are the rights of a person or an organization on intellectual property. Commonly defined Intellectual Property Rights include patents, copyright, industrial design rights, trademarks, trade dress like visual appearance of a product or its packaging, and trade secrets.

Hacking may be described as having unauthorized access to someone’s computer or computer network for stealing resources such as password or confidential files, or causing harm to network or system.

Anti-virus is software that aims to protect your system against malicious and potentially unwanted programs. It is responsible for detecting these malicious programs by searching for them, and removing them to keep the system protected.

A firewall aims at protecting the internal network of an organization, home, or individual from malicious traffic from external networks. A router or a computer (often dedicated to serve as a firewall) may be installed between external network and internal network for this purpose.

Cybercrimes are the crimes related to the misuse of computer or Internet such as theft, fraud, forgery. The IT act defines cybercrime as an unlawful act where in the computer is either a tool or a target or both.

Cyber laws are the laws for systematic use of e-resources, for example, e-business, and serve as a measure against illegal cyber-crime.

Social network refers to the network of people interacting and sharing information such as their views, photographs, videos and any other information.

Digital literacy refers to raising knowledge and awareness about technology such as desktop computers, smartphones, tablets, and other electronic gadgets. It also includes familiarity with software tools and Internet.

**Exercises**

1. Give the full form of following terms:
   (a) ARPA
   (b) LAN
   (c) MAN
2. Differentiate between the following:
   (a) Bus and Star Topology
   (b) Star and Tree Topology
   (c) Star and Mesh Topology
   (d) Ring and Bus Topology
   (e) LAN and WAN
   (f) LAN and MAN
   (g) MAN and WAN
   (h) Internet and WWW
   (i) Hacker and Cracker

3. What is the purpose of network devices? Explain following network devices.
   (a) Bridge
   (b) Router
   (c) Repeater
   (d) Switch

4. Which of the following listed acts are cyber-crimes?
   (a) Copying data from someone's computer without his permission.
   (b) Stealing someone's device.
   (c) Accessing one's bank account for carrying online transactions.
   (d) Modifying the official documents without permission.
(e) Creating a fake identity and posting on someone's behalf.
(f) Sending friend request to someone on social networking site.

5. What is the difference between Email and Chat?
6. What are cookies?
7. Differentiate between firewall and antivirus. How both contribute to the security of the system?
8. Define protocol.
9. Explain TCP/IP Model.
10. What is the significance of cyber law?
11. How TELNET is used for remote login?
12. List the various security issues concerned with using Internet. Explain each of them by giving proper examples.
13. List various protective measures that can be taken for network security.
15. Define social networking. List safe practices that should be followed on social networking.
UNIT - 3

Office Automation Tools
3.1 Introduction

A word processing software is required for the creation of documents that are text-based. It has tools that allow the user to edit, format, and print documents. A word document may also contain pictures and tables. It may be a report, letter, drawing, webpage, etc.

OpenOffice Writer is a popular open source software for word processing. It can be downloaded from the internet and installed for free, on Linux-based machines as well as Windows-based machines. In this chapter, we discuss the usage of OpenOffice Writer software in detail.

3.2 Start OpenOffice Writer

To start using the OpenOffice Writer software, any one of the following steps needs to be performed:

- <Start> <Programs> <OpenOffice>
- If the OpenOffice icon (Figure 3.1) is on the desktop, double click the icon shown in Figure 3.1.

Figure 3.1: OpenOffice icon
3.3 Openoffice Screen and its Components

The main screen of OpenOffice Writer is shown in Figure 3.2. It consists of different components like Tabs, Ruler bar, Status bar, Scroll bar and Work Area. The Writer layout and its general features are described as follows:

**Figure 3.2: OpenOffice Writer Screen**

- **Tabs**: (File, Edit, View, Insert, etc.) contain drop down menu which have commands provided by the tab.
- **Ruler Bar**: There are two rulers – Horizontal and Vertical. The Ruler Bar allows us to adjust the indentation and margins.
- **Status Bar**: It displays information about the current open document. It displays the current page number, total pages in the document, zoom slider etc.
- **Scroll Bar**: There are two scroll bars – horizontal and vertical. They help to scroll the content or the body of document.
- **Work area**: It is the working area where the text of the document is typed.
3.4 Writer Tabs

The OpenOffice Writer has the following tabs: File, Edit, View, Insert, Format, Tools, Modify and Window. There is also a help tab. On clicking any of the tabs, a drop down menu appears which has several commands and options. Select the command that you want to execute.

![Tabs](image)

The key tasks that can be performed using the tabs are as follows-

- **File**: To apply commands to current document, to open or close document
- **Edit**: For editing the current document, for example, cut, paste
- **View**: For controlling display of document on the screen
- **Insert**: For inserting new elements in document, like, comments, special characters, graphics, and objects
- **Format**: For formatting the layout and content of document
- **Tools**: For spelling check, gallery of object art to add to document, to configure menus
- **Table**: To insert, edit, delete a table in a text document
- **Windows**: For manipulating and displaying document windows

3.4.1 File Tab

The OpenOffice Writer is used to create a text document. The document is stored as a file in the computer with the extension .odt. For example, a document stored as a file Anita.odt.

The **File** tab consists of commands required to perform operations on a file (document). It contains several commands as shown in Figure 3.3 (a). The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to – **create**, **save**, **print**, **open** and **close** a text document. We use the words file and document interchangeably.
Figure 3.3(a): File tab

Figure 3.3(b): The New Option
Some operations performed using the commands of the File tab are described as follows -

- **Using New:** When you click `<File><New>`, a drop down menu appears Figure 3.3(b). To create a document, select `<Text Document>`.

- **Using Save As:** This is used when you want to
  
  (1) Save a file for the first time, or
  
  (2) Save an already saved file with a different name.

When you click `<File Tab> <Save As>`, a Save As dialog box appears Figure 3.4. You can –

- Select folder (directory) where the file is to be saved,
- Type the File name for the document,
- Select “save as type” of document (.odt etc.)
- Click “Save” button to save the file.

![Figure 3.4: SaveAs option](image)

- **To preview your document before printing:** `<File><Page Preview>`. You can see how the printed page will look like after printing. You can see multiple pages, full
To Make Printer Setting: <File Printer Setting>. Make settings for the printer.

To Print:<File><Print>: Print the document to the connected printer. You can select the size of the paper, print multiple pages on a single sheet etc.

3.4.2 Edit Tab

The Edit tab consists of commands required to perform editing on the current document. It contains several commands as shown in Figure 3.5. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to – cut, copy, paste, find & replace, undo and redo changes in the current document.

![Figure 3.5: The Edit Tab](image)

*Figure 3.5: The Edit Tab*
Some operations performed using the commands of the Edit tab are described as follows:

- **Move Text:** Remove the text to be moved by selecting the text and then applying `<File><Edit><Cut>`. Then take the cursor to the place in document where you want to move the text. Then do `<File><Edit><Paste>.

- **Copy Text:** Select the text to be copied and then apply `<File><Edit><Copy>`. Then take the cursor to the place in document where you want the copied text. Then do `<File><Edit><Paste>.

- **Find and Replace:** This is used to find words and then replace it with the new one (Figure 3.6). This option is useful to find word at multiple places in the document and replace all of them with the new one.

![Find & Replace dialog box](image)

**Figure 3.6: Find and Replace dialog box**

### 3.4.3 View Tab

The **View** tab consists of commands required for viewing the current document on the screen. It contains several commands as shown in Figure 3.7. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to view status bar, ruler, sidebar etc.
Figure 3.7: View Tab

- 3D Settings
- Align
- Bullets and Numbering
- Drawing
- Drawing Object Properties
- Find
- Fontwork
- Form Controls
- Form Design
- Form Navigation
- Formatting
- Framing
- Insert
- Media Playback
- OLE Object
- Picture
- Standard
- Standard (Viewing Mode)
- Table
- Text Object
- Tools
- Hyperlink Bar
- Formula
- Customize...
- Reset

Figure 3.8: View Toolbar Options
Some operations performed using the commands of the Edit tab are described as follows -

- **Toolbars**: Select `<View>` `<Toolbars>`. A drop down menu appears, as shown in Figure 3.8. Select the toolbars that you want to be displayed on the screen. A displayed toolbar shows the icons for the commands, as shown in Figure 3.8. Generally, **Standard and Formatting** options of toolbars are always selected.

![Figure 3.8: Toolbar on screen](image)

### 3.4.4 Insert Tab

The **Insert** tab consists of commands required for inserting different elements in a document. It contains several commands as shown in Figure 3.9. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to insert page number, date, header, footer, tables, hyperlinks etc. in the current document.

![Figure 3.9: Insert Tab](image)
When using an **Insert** tab to insert an element, the insertion of element in the document happens at the location where the cursor is present on the screen. So you must place the cursor at the right location on the screen before inserting the element. Also, when using insert, a dialog box may open for further settings and selection. Please choose the options in the dialog box and proceed further. The dialog box are self-explanatory. Some operations performed using the commands of the Insert tab are described as follows -

- **Insert Header: <Insert> <Header> <Default>:** A Header box opens in the upper part of the document. Enter the content you want to write in the header.

- **Insert Footer: <Insert> <Footer> <Default>:** A Footer box opens in the lower part of the document. Enter the content you want to write in the header.

- **Insert Fields: <Insert> <Fields>:** A pop-up menu appears (Figure 3.10). Select the element to be inserted. The selected element will insert at the location of the cursor. If you want to insert the field in the header or footer, then first select header/footer. Place the cursor in the correct position and then insert page number, time, date, author name, etc.

- **Insert Hyperlink: <Insert> <Hyperlink>:** A dialog box opens. On the left side of the dialog box, select where you want to link – a webpage, document, mail or to a new document. Then fill the details path, Form (text, button), etc. The Text is the name that appears in your document as hyperlink. Figure 3.11 shows an example.

- **Insert Table of Content: <Insert> <Indexes & Tables> <Indexes & Tables>:** A dialog box appears. In Type, select Table of Content. Click OK. A table of content will be inserted in your document.

- **Insert Table: <Insert> <Table>:** A dialog box appears. Enter the table name, number of rows and columns. Click OK. A table is inserted in the document. A table toolbar appears which allows you to format the table.

- **Insert Formula: <Insert> <Object> <Formula>:** A pop up menu of elements appears (Figure 1.12a). Select the element and write the formula. Figure 1.12b shows an example.
Figure 3.10: Insert Fields Option

Figure 3.11: Example of Insert Hyperlink
3.4.5 Format Tab

The **Format** tab consists of commands required for formatting the document. It contains several commands as shown in Figure 3.13. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to format a page, paragraph, insert bullets, styles, formatting, etc. in the current document.
When using the Format tab, the formatting happens on the text that has been selected. So you must select the text on which the formatting has to be applied and then use the relevant command from the **Format** tab. Some operations performed using commands of the **Format** tab are described as follows:

- **Format Character** : `<Format> <Character>`: A dialog box opens (Figure 3.14). Select the font type, typeface, and size. Select font effects, background etc. The changes happen to the text selected.

- **Format Paragraph** : `<Format> <Paragraph>`: A dialog box opens (Figure 3.15). You can change the indentation and spacing, borders, alignment, etc.

- **Format Bullets and Numbering** : `<Format> <Bullets and Numbering>`: A dialog box opens (Figure 3.16). You can select from bullets of different kinds or numbering. In the document the bullets are inserted at the location at which the cursor is present.

- **Format Page** : `<Format> <Page>`: A dialog box opens (Figure 3.17). This allows to format the whole page – borders, color, alignment, number of columns etc.

- **To Change case of Text** : `<Format> <Change Case>`: A dialog box opens (Figure 3.18a).

- **To Change Number of Columns** : `<Format> <Columns>`: A dialog box opens. You can select 2-column page, three column page etc.

- **To Change Alignment of Text** : `<Format> <Alignment>`: A dialog box opens (Figure 3.18b). Select from left, right, centered, and justified.

![Figure 3.14: Format Character](image)
Figure 3.15: Format Paragraph

Figure 3.16: Format Bullets and Numbering
3.4.6 Table Tab

The Table tab consists of commands that operate on a table. It contains several commands as shown in Figure 3.19. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to insert a table, insert or delete rows, or columns in a table, etc. in the current document.
When using the **Table** tab, a new table is inserted at the location of the cursor on the screen. For merge or split, select the cells on which the operation has to be applied. When a table is inserted, a table toolbar appears for the formatting of the table (Figure 3.20). Some operations performed using the commands of the **Table** tab are described as follows -

- **Convert Table to Text or Text to Table**: <Table> <Convert>: A pop up menu appears. If text is to be converted to table, the Text to Table option appears, Select it
to convert text to table. If a table is already present, then Table to Text option appears. Select it to convert table to text.

### 3.4.7 Tools Tab

The **Tools** tab consists of commands that can be used on the document for better results. It contains several commands as shown in Figure 3.21. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to check spelling and grammar of the content in the document, and count the number of words and characters in the document.

![Figure 3.21: Tools Tab](image)

Some operations performed using the commands of the Tools tab are described as follows -

- **Check Spellings and Grammar: <Tools> <Spelling and Grammar>:** The grammar and spelling of the document is checked. A window as shown in Figure 3.22 appears if there are no grammatical and spelling errors in the document. If errors are there,
then the errors are displayed with suggestions of correcting it. The user can decide to accept the suggestion or ignore it.

**Find Number of Words: <Tools> <Word Count>:** If the text is already selected, then word count displays the number of words and characters in the selected text. Otherwise the word count displays the number of words and character in the whole document (Figure 3.23).

![Figure 3.22: Tools Spelling and Grammar](image)

![Figure 3.23: Tools Word Count](image)
3.4.8 Window Tab

The **Window** tab consists of commands that work on a window, as shown in Figure 3.24. The commands in this tab allow the user to open a new window or close an existing window. Also, the name of all currently open windows is also displayed.

![Figure 3.24: Window Tab](image)

3.4.9 Help Tab

The **Help** tab consists of commands that provide help to the user of the OpenOffice Writer software. On clicking on the **help** tab, a screen as shown in Figure 3.25 appears. You can browse the **Help** for the command you want.

![Figure 3.25: Help Tab](image)

**Points to Remember**

- A word processing software has tools that allow creation of text-based documents.
- OpenOffice Writer is an open source software for word processing.
- OpenOffice Writer consists of different components like tabs, ruler bar, status bar, scrollbar and work area.
- File, Edit, View, Insert, Format, Tools, Modify and Window are the tabs in OpenOffice Writer.
- File tab consists of commands like, create, save, print, open and close.
- Save As option is used to save a file for the first time, or save an already saved file with a different name.
Edit tab consists of commands for editing a document, like, cut, copy, paste, find & replace, undo and redo changes.

Move Text moves the text from the current location to the target location.

Copy Text copies the text from the current location to the target location.

View tab consists of commands like, view status bar, ruler, sidebar, that help during viewing a document on the screen.

Insert tab allows insertion of page number, date, header, footer, tables, hyperlinks in a document.

Format tab consists of commands to format a page, paragraph, insert bullets, styles, formatting in a document.

Table tab commands operate on a table - insert table, insert/delete rows/columns in a table, in a document.

Tools tab consists of commands to check spelling and grammar of content in the document and count words/characters.

Window tab allow the user to open a new window or close an existing window.

The user can use Help tab to understand the working of any command of the OpenOffice Writer.

Exercises
1. What is the need of a word processing software?
2. What is the task of a word processing software?
3. Name an open source word processing software.
4. List the steps to start an OpenOffice Writer.
5. List the components of the main screen of OpenOffice Writer.
6. Define the following:
   a. Tabs
   b. Ruler Bar
   c. Status Bar
d. Scroll Bar

7. List the tabs in the OpenOffice Writer. What are the key tasks performed by the tabs.

e. Work Area

8. What is the extension of the file created in OpenOffice Writer?

9. What is the purpose of the following tabs?

a. File
b. Edit
c. View
d. Insert
e. Format
f. Table
g. Tools

10. What is the difference between Save command and Save As command?

11. What is the difference between Move text and Copy text?

12. How is Find and Replace option useful.

13. List the steps for inserting a hyperlink to a web page in a document.

14. What is the difference between toggle case and sentence case when using change case?

15. Name the tabs in which the following commands are present:

a. Header
b. Find&Replace
c. Status Bar
d. Ruler
e. Hyperlink
f. Formula
g. Paragraph
h. Alignment
i. Word and Count
16. Use OpenOffice Writer to create the following documents:
   a. A Birthday invitation card.
   b. A farewell invitation card.
   c. A one page article that lists the steps that you take to clean the environment (use bullets). Format the page. Insert header and footer in the document.
   d. Write the quadratic equation using formula symbols.
   e. A grocery bill using tables. Then convert this table to text.
   f. A 2-page 2-column article having pictures and text. Create a hyperlink to a web page. Also state the number paragraphs, lines, words and characters in the document. Perform spell check on the document.
   g. Create a document with text and then use find and replace option to replace a word in the document.
4.1 Introduction

A spreadsheet stores data in the form of a table comprising of rows and columns. It is used to store, arrange, and sort data, and perform calculations on numeric data. It is similar to the ruled paper accounting worksheets traditionally used for bookkeeping. The computerized version of a worksheet is called a Spreadsheet application that lets you quickly perform calculations on numerical data, represent data with charts, analyze, and print. Spreadsheets are used in various fields such as banking, finance, accounting, and education. Following are some of the popular uses of spreadsheets:

1. Managing financial data such as bank account information, budgets, transactions, billing, and receipts.
2. Handling inventory, reviews, employee information, surveys, etc., using data entry forms.
3. Tracking student performance by calculating grades and other relevant information such as attendance, highest score, and lowest score.
4. Creating lists of items which may not be numeric such as student list, grocery list.
5. Managing company information such as profit and sales by creating graphs from the data.

There are various spreadsheet applications available that can be used to create and manipulate a spreadsheet. The most commonly used are – Microsoft Office Excel, Apache OpenOffice Calc, LibreOffice Calc, Google Sheets etc. Microsoft Excel is a proprietary software from Microsoft for Windows. Both OpenOffice and Libre Calc are free and open-source alternatives to Excel. Google sheets is a web-based spreadsheet application which allows you to store and edit the spreadsheets online and access them from any computer. In this chapter we’ll study spreadsheets using Apache OpenOffice Calc. Figure 4.1 shows how an OpenOffice Calc spreadsheet looks like.
4.2 Installing Calc

Calc is offered free of charge and can be downloaded from HYPERLINK ‘http://www.openoffice.org’ www.openoffice.org calc is the spreadsheet component of Apache OpenOffice an open source office software suite. We will install the complete Apache OpenOffice which include calc

2. Select the operating system and language.
3. Click on – Download full Installation
4. Installing OpenOffice on Windows
   a. Double click on the downloaded exe file and then click Next on the following screen:
b. Click on Unpack

c. After unpacking, click on Next
d. Enter User information and then click on Next

![Customer Information]

e. Choose the setup type and then click on Next. It is recommended that the beginners should choose typical.

![Setup Type]
f. Click on Install

![Installation Wizard](image)

After installation, click on Finish

![Installation Wizard Completed](image)
h. Run OpenOffice to check if it has been installed successfully.

i. Click on the Spreadsheet to open OpenOffice Calc.

4.3 Main Features of OpenOffice Calc

Calc offers the several features. In this section, we shall describe several features. If you do not understand everything, do not worry about it. Things will become clear as we move on.

4.3.1 Starting Calc

To start OpenOffice Calc, there are various ways in which you can start it:

- As a Windows application, you can click Start -> Programs -> OpenOffice
- If the OpenOffice icon as shown in Figure 4.2 is on the desktop, double click the icon.

Figure 4.2: OpenOffice Icon
Calc's default file format is the Open Document Format (ODF), an ISO/IEC standard, which originated with OpenOffice.org.

4.3.2 Calc Main Window

Before using Calc to create spreadsheets, let us study the various menus and toolbars available in the main window of Calc as shown in Figure 4.3.

- **Title Bar:** The title bar at the top displays the information about the spreadsheet such as name of the current spreadsheet (ExampleSheet), extension of the spreadsheet (.ods), and name of the software (OpenOffice Calc). If the spreadsheet is new then its name is Untitled N where N is a number. The ellipsis (three dots ...) in front of an option implies that a dialog box will open when this option is selected. For example, on selecting the Open option, a dialog box will appear which is meant for the user to enter the location of the file to be opened.

- **Menu Bar:** Just below the title bar is the menu bar. It contains various menu options. On selecting a menu option, a submenu appears which contains other options related to the main menu option. The menu options and few of their submenu options are discussed below:
- **File:** It contains commands to create a new file (New), open an existing file (Open), save a file (Save, Save As), print a file (Print), preview a page (Preview Page), close a file (Close), exit the software (Exit) etc.

- **Edit:** It contains commands to edit a file such as Cut, Copy, Paste, Paste Special, Select All, Find & Replace, Delete Contents, Delete Cells, Headers & Footers.

- **View:** It contains commands to modify the view of the Calc such as Toolbars, Full Screen, Zoom. A small in front of the Toolbars options means on selecting it, another submenu appears as shown in Figure 4.4 which shows the list of all the toolbars which can be selected or deselected based on the user’s choice of toolbars to be displayed on the Calc main window.

- **Insert:** It contains commands for inserting Cells, Rows, Columns, Sheet, Sheet From File, Function, Function List, Picture, Chart etc.

- **Format:** It contains commands to alter the layout of the spreadsheet such as formatting Cells, altering Rows, Columns, Sheet.

- **Tools:** It contains options to o spellcheck (Spelling), insert macros (Macros) etc.

- **Data:** It contains commands to manipulate data such as Sort, Filter, Validity.

- **Window:** It contains commands to modify the window such as New Window, Close Window.
Help: It contains the options getting help related to OpenOffice Calc such as OpenOffice Help, What’s This?, Check for Updates etc. Placing the mouse pointer on any of the icons on the Calc window displays a small box which is called a tooltip which gives a brief explanation of the icon’s function. For a more detailed explanation of any icon or function, select Help > What’s This? and hover the mouse pointer over the icon or function. To turn this feature off again, click once or press the Esc key twice.

Standard Bar: It lies below the Menu bar. It contains icons which perform similar operations as contained in the Menu bar options such as New, Open, Save, Print, Page Preview, Cut, Copy, Paste, Sort, Chart, Find & Replace, Spelling.

Find Bar: It contains a text box which can be used to enter text which is meant to be searched in the spreadsheet. It highlights the cell which contains the text to be searched. Multiple search results can be traversed by clicking on the up and down arrows or by pressing the Enter key on the keyboard.

Formatting Bar: In the Formatting toolbar, the leftmost icon is for the Style & Formatting and the following two boxes are the Font Name and Font Size lists. They show the current settings for the selected cell or area. Click the down-arrow to the right of each box to open the list.

Following the boxes, we have the three icons for changing the appearance of the text such as making the text bold (B), italics (/), and underlining (U).

Next we have the icons which are used to align the text within a cell as left ( ), center ( ), right ( ), or justify ( ).

Merge cells icon ( ) is used to merge multiple cells and form a single cell. It becomes active when multiple cells are selected.

Format of numbers can be changed by using the Number format icons –

Currency ( ), Percent (%), Standard ( ), Add Decimal Place ( ), Delete Decimal Place ( ).

Indentation of text can be increased ( ) or decreased ( ) within a cell using the indent arrows.
Borders of cells can be modified by using the border styles available by clicking on the drop-down of the Border icon ( □ •).

Background Color of cells can be changed by clicking the Background Color icon ( □ •). Click on the drop-down for more options of colors.

Text color can also be changed by clicking the Font Color icon ( □ •). Click on the drop-down for more options of colors.

Formula Bar: On the left side of the Formula bar is the Name box which contains a letter and name combination such as C4, whenever you select a cell on the spreadsheet. This combination is called as a cell reference. The cell reference is the address of a cell. The letter is meant for the column and the number for the row.

To the right of the Name box, one can see the Function Wizard ( ‽ ), Sum ( ‽ ), Function ( = ) icons. Function Wizard opens a dialog box from which you can search through a list of available functions. Sum icon inserts a formula into the current cell that totals the numbers in the cells above the current cell. If there are no numbers above the current cell, then the cells to the left are placed in the Sum formula. Function icon inserts an equals (=) sign into the selected cell and the Input line, thereby enabling the cell to accept a formula. When new data is entered into a cell, the Sum and Function icons change to Cancel ( ✗ ) and Accept ( ✓ ) icons.

The contents of the current cell (data, formula, or function) are displayed in the Input line, which is the remainder of the Formula Bar. You can either edit the cell contents of the current cell here, or you can do that in the current cell. To edit inside the Input line area, click in the area, then type your changes. To edit within the current cell, just double-click the cell.

Sheet Tabs: A single spreadsheet Calc file can contain multiple sheets. You can traverse individual sheets by using the Sheet tabs. The current active sheet has a white tab. Clicking on another sheet tab displays that sheet, and its tab turns white. Right click on the Sheet tabs will display various options such as inserting, deleting, renaming, moving sheets, as shown in Figure 4.5.
Figure 4.5: Menu displayed when you right-click any Sheet tab

- **Status Bar:** Status bar at the bottom provides information about the spreadsheet and convenient ways to quickly change some of its features. Sheet Sequence number shows the number of the current sheet / total number of sheets in the spreadsheet as shown in Figure 4.6.

Selected cell (or cells) information is also displayed on the Status bar. When a group of cells is selected, the sum of the contents is displayed by default. You can right-click on this field and select other functions, such as the average value, maximum value, minimum value, or count (number of items selected) as shown in Figure 4.6.

![Figure 4.6: Displaying Information of Selected Cells in Status Bar](image)
When the cursor is on an object such as a picture or chart, the information displayed includes the size of the object and its location as shown in Figure 4.7. To change the view magnification, drag the Zoom slider (bottom left corner) or click on the + and – signs.

Figure 4.7: Information of Chart Displayed in the Status Bar

- **Sidebar:** Located on the right side of the edit views of Calc, sidebar contains frequently used tools grouped in decks such as Properties, Styles and Formatting, Gallery, Navigator. Clicking on any of the vertical tabs opens the deck for that tab.

- **Active Cell:** When you select a cell, you will notice a heavy black border around the selected cell as shown in Figure 4.3. The heavy black border indicates that selected cell is the active cell.

- **Row Headers:** Row headers are in the form of numbers -1,2,3,... which are present at the left of each row.

- **Column Headers:** Column headers are in the form of alphabets – A,B,C,...shown at the top of each column.
4.3.3 Working with Spreadsheets

A Spreadsheet consists of a number of individual sheets, each containing cells arranged in rows and columns. A particular cell is identified by its column letter and row number. These cells hold the individual elements—text, numbers, formulas, and so on—that make up the data to display and manipulate. Each spreadsheet can have many sheets and each sheet can have many individual cells.

◆ Create a New Blank Worksheet: There are many ways to create a new blank worksheet as discussed below:

  > On the menu bar, click File-> New->Spreadsheet as shown in Figure 4.8.

  ![Figure 4.8](image)

  *Figure 4.8: Creating New Blank Spreadsheet Using File Menu*

  > On the Standard bar, click on drop-down of the New icon ( ) -> Spreadsheet as shown in Figure 4.9.
On the keyboard type – Ctrl + N. The keyboard shortcuts are also displayed next to the menu options as shown in Figure 4.8 and Figure 4.9.

- **Open an existing Spreadsheet:**
  - On the menu bar, click File->Open as shown in Figure 4.8 and then a dialog box opens up which is used to locate the spreadsheet to be opened as shown in Figure 4.10.
On the Standard bar, click on the Open icon ( ). Click on the drop-down to open a list of recently opened OpenOffice files.

**Navigating within Spreadsheets:** There are many ways to navigate within a spreadsheet from cell to cell and sheet to sheet.

- Accessing a particular cell – Place the mouse pointer over the cell and click to access that cell. Another way is to type the cell reference or address in the Name box in the Formula bar and press Enter. For example, if you want to access cell D5, then type D5 in the Name box and press Enter. You can see cell D5 is highlighted as shown in Figure 4.11.

![Figure 4.11: Accessing a Cell using Name Box](image)

You can also use the Calc Navigator ( ) on the Standard bar or Press F5 which opens the following Navigator dialog box in which you can enter the row number and column letter which you want to access.
Cell to Cell Navigation: You can use the Mouse and various keys on the keyboard such as Tab, Enter keys, and Arrow keys to navigate from one cell to another.

Sheet to Sheet Navigation: Using sheet tabs at the bottom of the spreadsheet, you can navigate between sheets. If you have a number of sheets, then some of the sheet tabs may be hidden behind the horizontal scroll bar at the bottom of the screen. If this is the case, then the four buttons at the left of the sheet tabs as shown in Figure 4.13 can move the tabs into view.

Saving Worksheet:
- On the menu bar, click File->Save as shown in Figure 4.8.
- On the Standard bar, click on Save icon ().
While saving a new spreadsheet for the first time, a dialog box will open to enter a name and select the location for saving the spreadsheet. For example, in Figure 4.14 a spreadsheet file is saved on the Desktop with the name ExampleSheet and type .odf.

![Figure 4.14: Saving a Spreadsheet](image)

**Closing Worksheet:**

- On the menu bar, click File->Close (Figure 4.8). A dialog box opens up if the spreadsheet has not been saved as shown in Figure 4.15. The dialog box gives options to the user to Save the file, Discard the changes or Cancel the close operation.

![Figure 4.15: Save Dialog Box on Closing a File](image)

- You can also directly close the OpenOffice Calc main window.

4.3.4 Working with Data:

- Data – There are various types of data that can be entered in a cell:
Labels – These are alphabetic or alphanumerical entries without numeric value. They can be a combination of letters, numbers, space, special characters etc. Labels are left justified by default.

Numbers or Values – These are numeric data which may be integers or can contain decimals or fractions. Values are right-justified by default.

Formulas – Used to perform calculations such as addition, subtraction, multiplication, division, average. Formulas must begin with an = sign.

**Entering Data:** Data can be entered in an active cell. Following are the steps to enter data in say cell A1 (Figure 4.16):

i) Click on the A1 cell which is at the top left of the spreadsheet. The heavy black border around the A1 cell indicates that it is the active cell.

![Figure 4.16: Entering Data in Cell A1](image)

**Moving Data within a Spreadsheet:** For moving data from one cell to another we have the cut-copy-paste functions. There are various ways to use these functions as described below:

**Using the Edit Menu:** The Cut, Copy, and Paste functions are available in the Edit menu. Following example illustrates the steps to do cut/copy-paste using Edit Menu:

i) Select the cell whose contents you want to cut or copy (say cell D5).

ii) Go to the Edit menu on the menu bar and click on Cut/Copy.

iii) Select the cell where you want to paste the contents of cell D5 (say cell F5).

iv) Go to the Edit menu and click on Paste. If you have selected Cut option then the contents of D5 will be removed from D5 and pasted in F5. But if you have selected the Copy option, then the contents of cell D5 will remain in intact and the same will be copied in F5.

**Using the Standard bar:** The icons are Cut (.cut), Copy (copy), and Paste (paste). Following example illustrates the steps to do cut/copy-paste using Standard bar:
i) Select the cell whose contents you want to cut or copy (say cell D5).
ii) Click on the Cut / Copy icon in the Standard bar.
iii) Select the cell where you want to paste the contents of cell D5 (say cell F5).
iv) Click on the Paste icon in the Standard bar.

> By Right -Click: Following example illustrates the steps to do cut/copy-paste by right clicking on the cell:

i) Right-Click on the cell whose contents you want to cut or copy (say cell D5). The following menu is displayed:

![Right-Click Menu](image)

Figure 4.17: Right-Click Menu

ii) Select the option Cut/Copy.
iii) Right-Click on the cell where you want to paste the contents of cell D5 (say cell F5).
iv) Select the Paste option.
Using AutoFill: This feature in Calc is used to automatically generate data based on a defined series. A very common example is to enter numbers in the serial number (S.No) column of a table. This is a very frequently used column which usually contains consecutive numbers. Instead of manually typing the serial numbers (say 1 to 100), you can use the AutoFill command in Calc. The procedure to generate the series of numbers from 1 to 5 is as follows (Figure 4.18):

i) Click on the first cell of the serial number column and type 1.
ii) Now drag the fill handle in the bottom right corner of the cell (a solid white + sign) across the cells that you want to fill (in the given example till 5) and release the mouse button. The cells will be filled with ascending numbers 2, 3, 4, 5.

![Figure 4.18: Using AutoFill](image)

Try doing the same exercise with “Monday” typed a cell and you’ll observe that the subsequent cells will be filled with the days – Tuesday, Wednesday, etc.

The AutoFill command also recognizes customized sort lists that are defined under menu Tools -> Options -> OpenOffice Calc -> Sort Lists. You can also define your own sort list.

In case you want to enter the same value, say, 1 in 10 consecutive cells simply press the Ctrl key while dragging the fill handle.

Suppose you want to enter even numbers in a column. For example entering 2, 4, 6, 8…20. Then follow the procedure:

i) Type the first two values (2 and 4) in the first two cells.
ii) Then select both the cells and drag the fill handle of the cell containing value 4. You will observe that now the values filled by Calc will be 6, 8, 10…20.
Thus if you want to generate your own series, then you have to specify two values so that Calc can determine how to generate the subsequent values.

4.3.5 Formatting Data

Formatting a document means adding elements of style and presentation to documents to improve the readability and make them more attractive. To enhance the appearance of spreadsheets various formatting options are available in the Formatting Bar and Format Menu such as alignment, font, size, and style. Various formats for numbers are also available such as percentage and decimals. Following are the various formatting options available on the Formatting Bar as shown in Figure 4.19.

**Figure 4.19: Formatting Bar**

- **Numbers as Text:** Calc evaluates each cell and determines whether the entry is a Value or Label. Cells containing a combination of values and text is automatically treated as a label such as code of a product - COMP123. Such entries cannot be used for calculations. However there might be a requirement that a cell containing numbers be treated like a label. For example telephone numbers, aadhar card number, ZIP codes etc. should be treated as labels and not values. Whenever such a requirement arises, prefix each such entry with a single quotation mark (‘). The quotation mark will be invisible and the numbers in the cell will be treated as labels.

- **Font:** Font refers to the design for a set of characters. It is the combination of typeface and other qualities, such as size, pitch, and spacing. The font can be changed from the Formatting bar.
Let us discuss various Font changing options on the Formatting bar:

- **Font Name:** Various font types are there in Calc such as Arial, Arimo, and Century Schoolbook L. The font type can be selected from the Font Name box in the Formatting bar as shown in Figure 4.19. Using the drop down, you can select from the list of font types available in Calc. The appearance of the font types listed in the drop down is how the text will look when a font type setting is applied as shown in Figure 4.20.

  ![Figure 4.20: Font Names](image)

- **Font Size:** Click on the drop down arrow of the font size which is next to the Font Name box and then select the size you want to use.

- **Font Style:** You can also make the text bold, italics or underlined by clicking on the **B**, **I** or **U** icons available on the formatting bar respectively.

  - **Horizontal Alignment:** Alignment of data in cell with respect to the border of the cells can be done by using the Alignment options:
    - **Left Align**: The left edge of the text is along the left cell border.
    - **Center Align**: Both the left and right edges are equally distant from the left and right cell borders respectively.
    - **Right Align**: The right edge of the text is along the right cell border.
**Justify**: Aligns the text to the left and the right cell borders.

**Changing Color**: You can easily change the color of the background of the cells as well as the text color as shown in Figure 4.21. On the left the background color is changed and on the right the text color is changed.

![Figure 4.21: Background and Text Color Change](image)

Steps to change the background color of cells:

i) Select the cells.

ii) Click on the Background color icon

iii) Select the color from the palette as shown in Figure 4.22.

![Figure 4.22: Background Color Palette](image)

Steps to change the text or font color:

i) Select the text or you can select the complete cells.
ii) Click on the Text color icon.

iii) Select the color from the palette as shown in Figure 4.23.

![Font Color Palette](image)

**Gridlines and Borders:** The gray gridlines (vertical and horizontal lines) that you can see in a Calc spreadsheet help you while you’re working in a spreadsheet. Gridlines appear automatically showing you how the data is organized into rows and columns. Borders are different from gridlines because they help you highlight important information for people to see as shown in Figure 4.24.

![Gridlines and Borders](image)

*Figure 4.23: Font Color Palette*

*Figure 4.24: Gridlines and Borders*
Borders need to be added if you want to highlight certain cells. One more difference is that gridlines aren't automatically printed, while borders are. Thus, to draw borders around a cell or multiple cells, you can use the Border icon on the Formatting bar. A drop down (Figure 4.25) in the same icon provides various options to draw the left or right or top or bottom border, all borders, outer border etc. In order to create borders, select the cells around which you want borders and then click on the required border option.

![Borders](image)

**Figure 4.25: Borders**

- **Flow of Text:** In order to control the flow of text within cells, Calc provides various ways:

  1) **Merging / Splitting Cells:** In order to merge cells, select the cells and click on the Merge Cells icon in the Standard Bar. To split the merged cells, select the cell and click on the Merge Cells icon.

  2) **Wrap Text:** It means to break the text into multiple lines i.e., adjusting the row height to fit the text within the cell but keeping the column width of the cell same. Steps to wrap text:

     i) Right-click on the cell.

     ii) Select the option – Format Cells.

     iii) A dialog box opens up. Open the Alignment Tab and check the option – Wrap text automatically as shown in Figure 4.26.
3. **Shrink to Fit**: This option shrinks the text to fit in the size of the existing cell. In this case neither the row height nor the column width is changed. The text size is decreased according to the cell. Steps to shrink the text size to fit the cell:

   i) Right-click on the cell.
   ii) Select the option – Format Cells.
   iii) A dialog box opens up. Open the Alignment Tab and check the option – Shrink to fit cell size as shown in Figure 4.26.

Following example illustrates the difference between Wrap text and Shrink to fit. Given the text “OpenOffice Calc” which cannot fit in a single cell as shown in Figure 4.27, we have two options – either to wrap the text or to shrink it to fit the cell.

**Figure 4.26: Wrap Text**

**Figure 4.27: Difference between Wrap Text and Shrink to Fit**
Numeric Data Formatting

In Calc, there are many ways in which numerical data can be formatted i.e., changing the appearance of numbers. Some of the number formats are available on the Standard Toolbar (Currency, Percent, Standard, Add/Delete Decimal place). For more options, right-click on the cell and click on Format Cells to open a dialog box as shown in Figure 4.28. Click on the Numbers tab and then you can select the category of the format as per requirement.

![Number Formatting Dialog Box](image)

Figure 4.28: Number Formatting Dialog Box

Some of the commonly used number formats are discussed below:

1. **Currency**: In the currency format, you can prefix or suffix currency symbols to the numeric data. The default currency is Rs, which is prefixed to the number, commas are inserted at the thousand, million, billion positions, and two decimal places are added to the number.
2. **Percent:** It displays the number as a percentage. Two decimal places are added to the number and the percent symbol (%) is suffixed at the end.

3. **Standard:** It sets the number in the cell to the default format by removing any other numeric formatting applied.

4. **Decimals:** Decimal places can be inserted or removed by using the Add Decimal place or Delete Decimal place icon respectively.

If you want to remove fractional part of a cell or group of cells then you can either use the Delete Decimal place icon on the Standard toolbar or another option is to right-click on the cell(s) and then click on Format Cells to open the dialog box. On the Number tab, you can see the Decimals spin box in the Option section. You can increase or decrease the number of decimal places by using the up and down arrows. Zeros can also be prefixed to the numbers by setting the number of zeros to be prefixed in the Leading Zeros spin box. Figure 4.29 shows an example of how the number – 23456.78 changes when different formatting options are applied on it.

<table>
<thead>
<tr>
<th>Original Number</th>
<th>Currency</th>
<th>Percent</th>
<th>Add Decimal Place</th>
<th>Delete Decimal Place</th>
</tr>
</thead>
<tbody>
<tr>
<td>23456.78</td>
<td>23,456.78</td>
<td>2345678.00%</td>
<td>23456.78</td>
<td>23456.78</td>
</tr>
</tbody>
</table>

*Figure 4.29: Number Formats*

5. **Date:** By default the date format in Calc is dd/mm/yy. But in case you want to change the format, you can find various date formats in the Format Cells dialog box.

### 4.3.6 Finding and Replacing Data

Data can be searched by using the Find toolbar. If you want to find and replace the data then perform the following steps:

i) Click on the Edit menu and select the Find & Replace option.

ii) A dialog box opens (Figure 4.30) in which you can type the text to be searched in the “Search for” text box and the replaced text in the “Replace with” text box. You can find or replace the results individually (Find or Replace) or all of them at one go by clicking on the Find All or Replace All button.
Figure 4.30: Find & Replace Dialog Box

iii) The Match case check box when checked implies that the searching is sensitive to the case of the text i.e., uppercase and lowercase letters are treated differently. Otherwise uppercase and lowercase letters are treated as equal.

iv) Entire cells check box when checked implies that Calc will search for the whole words that are identical to the text to be searched and if the text to be searched is part of some other text then it will not highlight that in its results. If this check box is not checked then the text to be searched is highlighted even if it is part of cell contents.

4.3.7 Deleting

◆ **Delete Data:** For removing data from a cell, click inside the cell (double-click) and then press the Backspace key according to the text you want to delete. However, if you only select the cell (single-click) and then press the Backspace key then this will result in the deletion of all the text within the cell, though the formatting of the cell remains.

◆ **Deleting Data and Formatting:** Delete key (or Right-click the cell and select Delete All option) can be used to remove data as well as the formatting from a cell. Selecting the cell and pressing the Delete key opens a dialog box (Figure 4.31) which can be
used to delete different aspects of the cell. To delete everything in a cell (contents and format), check Delete all.

![Delete Contents Dialog Box](image)

**Figure 4.31: Delete Contents Dialog Box**

- **Deleting Cell(s):** Single or multiple cells can be deleted by selecting them and then right-click and select the Delete option. On doing so, a dialog box (Figure 4.32) opens which asks the user to shift cells up or left or delete an entire row or column after deleting the cell(s).

![Delete Cells Dialog Box](image)

**Figure 4.32: Delete Cells Dialog Box**

### 4.3.8 Inserting/Deleting Rows and Columns

Sometimes when you have finished entering data in a spreadsheet you may need to add or remove rows and columns. One way is to select the row or column by clicking on the row header (number) on the left or column header (alphabet) on the top and then right-click. A
menu appears (Figure 4.33) which can be used to insert and delete rows or columns and also adjust the height or width of a row or column.

![Row and Column Menus](image)

*Figure 4.33: Row and Column Menus*

Insertion of row and columns can also be performed by using the Insert menu on the Menu bar as shown in Figure 4.34.

![Insert Menu](image)

*Figure 4.34: Insert Menu*
4.3.9 Using Formulas and Functions

Formulas can be used for basic operations such as addition, subtraction, as well as more complex calculations such as income tax calculations, averaging. The advantage of using formulas is that even if the data is changed, Calc will automatically recalculate the answer without the need to rewrite the formula again. Another advantage of using formulas is that they can be easily copied to a number of cells.

Let us study some examples of creating basic formulas in Calc.

Example 1: Adding data in two numbers and storing the result in cell D6.

Step 1: In cell D6, type the equal sign (=). This informs Calc that D6 will contain a formula.

Step 2: Now type 4+5

Step 3: Press Enter

Cell D6 will contain 9. You can see the formula (=4+5) in the Input line in the formula toolbar as shown in Figure 4.35.

![Figure 4.35: Example of Adding Two Numbers](image)

In the above example, we have used numbers for addition. What if we were supposed to add the contents of cell D4 and D5 and then store the result in cell D6? This can be achieved using cell reference or address of a cell.
In Calc, a cell reference identifies the location of a cell or group of cells in the worksheet. The cell reference is also called address of a cell. Cell references are used in formulas, functions, and other commands.

- **Individual cell reference:** Each cell is identified by its column letter and row number in this order. For example, the cell reference of the topmost and leftmost cell is A1 (Column=A, Row=1).

- **Range of cells –** You can use cell referencing for a consecutive range of cells also using a colon (:). For example, cell reference for the range of first five cells in column D is D1:D5 (i.e., D1, D2, D3, D4, and D5). Cell reference for the range of first five cells in row 5 is A5:E5 (i.e., A5, B5, C5, D5, and E5). Cell reference for a group of four cells spanning first 2 columns and first 2 rows of the spreadsheet is A1:B2 (i.e., A1, A2, B1, and B2).

- When you wish to add a reference to a cell in some other cell then there are two ways. First is to type the cell reference using the keyboard. Second is using the mouse. The steps to insert cell reference using the mouse is as follows:
  
  Step 1: Double-Click on the cell in which you want to insert cell reference.
  Step 2: Type equal sign (=)
  Step 3: Now click on the cell whose reference you want to add. On clicking you will notice that the address of the cell which you have clicked is inserted.

For example, steps to add data in two cells D4 and D5 and store the result in cell D6.

1. **Step 1:** Enter numbers in cell D4 and D5.
2. **Step 2:** Double-click on the cell D6 and type =.
3. **Step 3:** Click on cell D4. The address D4 will be inserted in cell D6 after the = sign. Alternatively you can type D4.
4. **Step 4:** Type plus sign (+) in cell D6.
5. **Step 5:** Click on cell D5, The address D5 will be inserted in cell D6 after the + sign. Alternatively you can type D5.

Formula in cell D6 =D4+D5
After you press Enter, D6 will contain the sum of the numbers stored in cells D4 and D5.

You can view the formula of cell D6 in the Input line of Formula toolbar as shown in . If you double-click on cell D6, then also you can see the formula in cell D6.

![Figure 4.36: Example of Adding Contents of Two Cells](image)

Try changing the values in cell D4 and D5 and you will observe that the result in cell D6 will be automatically recalculated and updated. This is one of the most important use of Calc.

Just like the plus (+) operator, you can use various other operators in Calc as shown in Table 1.

<table>
<thead>
<tr>
<th>Type of Operators</th>
<th>Operator</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic Operators</td>
<td>+</td>
<td>Addition</td>
<td>=D4 + D5 =5+3</td>
</tr>
<tr>
<td></td>
<td>-</td>
<td>Subtraction</td>
<td>=A2-A3+B1 =3+4+5</td>
</tr>
<tr>
<td></td>
<td>*</td>
<td>Multiplication</td>
<td>=D4 * E4 =56*100</td>
</tr>
<tr>
<td></td>
<td>/</td>
<td>Division</td>
<td>=E3/E2 =34/4 =5/0 will result in an error</td>
</tr>
<tr>
<td></td>
<td>^</td>
<td>Exponentiation</td>
<td>=D4^D5 =5^2</td>
</tr>
</tbody>
</table>

*Try changing the values in cell D4 and D5 and you will observe that the result in cell D6 will be automatically recalculated and updated. This is one of the most important use of Calc.*

*Just like the plus (+) operator, you can use various other operators in Calc as shown in Table 1.*
<table>
<thead>
<tr>
<th>Type of Operators</th>
<th>Operator</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparison Operators</td>
<td>=</td>
<td>Equal to</td>
<td>=4=5</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=D2=D3</td>
</tr>
<tr>
<td></td>
<td>&lt;</td>
<td>Less than</td>
<td>=4&lt;9</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=D4&lt;D5</td>
</tr>
<tr>
<td></td>
<td>&gt;</td>
<td>Greater than</td>
<td>=4&gt;9</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=F1&gt;D3</td>
</tr>
<tr>
<td></td>
<td>&lt;=</td>
<td>Less than or equal</td>
<td>=2&lt;=3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=D2&lt;=A1</td>
</tr>
<tr>
<td></td>
<td>&gt;=</td>
<td>Greater than or equal</td>
<td>=2&gt;=3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=D2&gt;=C2</td>
</tr>
<tr>
<td></td>
<td>&lt;&gt;</td>
<td>Not equal to</td>
<td>=2&lt;&gt;5</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>=A1&lt;&gt;A2</td>
</tr>
</tbody>
</table>

Table 1: Operations in Calc

Precedence of Operations:

If multiple operators occur in a formula then the calculation is performed by using the following order:

1. Operations enclosed in parentheses.
2. Exponentiation.
3. Multiplication and division. (If both multiplication and division occurs in a formula then the calculation is performed from left to right.)
4. Addition and Subtraction. (If both addition and subtraction occurs in a formula then the calculation is performed from left to right.)

For example, consider the following formula:

\[ =1000+3000\times500 \]

In the above formula, multiplication will be performed first and then addition will be performed. If you want to perform addition first then you have to enclose the addition operation in parentheses as shown below:

\[ = (1000+3000)\times500 \]
Functions

Calc has a set of predefined formulas called functions. They differ from formulas in the sense that in a formula we provide both the operands and the operator, however in functions we only provide operands (or arguments) as functions have predefined operation to be performed on the arguments. Just like a formula, the function also begins with an equal (=) sign. We specify the arguments enclosed in parenthesis () and separated by a comma (,). For example, SUM function is used to add as shown below:

- \(= \text{SUM}(3, 4)\) – This will add numbers 3 and 4.
- \(= \text{SUM}(A3, A4)\) – This will add numbers in cell A3 and A4.
- \(= \text{SUM}(3, 4, A3, A4)\) – This will add number 3, 4, contents of cell A3 and A4.

Apart from SUM () there are various commonly used mathematical functions in Calc which are discussed as follows:

1. PRODUCT (n1; n2…) – To calculate the product of arguments n1, n2…
2. SQRT (n) – To calculate the square root of a number n.
3. POWER (n; p) – To calculate power p of a number n.
4. LOG (n; b) – To calculate log a number n to base b.
5. ROUND (n; d) – To round a number n to digits d.
6. SIN (n), COS (n), TAN (n) – To calculate sine, cosine and tangent of n.
7. RANDBETWEEN (f; l) – Returns a random number between f and l.
8. QUOTIENT (a; b) – To calculate integer quotient of division a/b.
9. ABS (n) – To calculate the absolute value of a number n.
10. AVERAGE (n1; n2….) – To calculate average of arguments n1, n2….

For the function which contains multiple arguments such as SUM (), PRODUCT (), AVERAGE (), if the arguments are consecutive then you can use a range of cells such as A1:A5 which means cells A1, A2, A3, A4, and A5.

For example, addition of the numbers in cells A1:A5 in cell A6 is shown in Figure 4.37.
4.3.10 Absolute and Relative Addressing:

Relative Addressing: All cell references are by default relative i.e., they adjust and change when copied or when using AutoFill. When you enter an address A in a cell B then Calc does not store the actual address of A but instead it stores the number of rows and columns relative to the cell containing the address B or in other words how to reach A from B. For example, cell A4 contains the address A3 (=A3). Now, if you will copy the contents of A4 to B4 then it will contain the address B3 (=B3) because the relative address is used. That means when A4 contains the address A3, it stores the value of the cell above it (A4-one row) and hence, when it is copied in cell B4, the address of cell one above B4 (B4-one row) i.e., B3 is actually stored in B4.

Consider the following worksheet as shown in Figure 4.38 which the formula in cell A6 = SUM (A1:A5) is copied into cell B6. As you can observe that now B6 contains the formula SUM (B1:B5) and not SUM (A1:A5) due to relative addressing.
The same example can also be performed by using AutoFill. Instead of copying and then pasting the formula from cell A6 to B6, you can use AutoFill. Select cell A6 and move the mouse pointer to the bottom-right corner of the cell A6 until you see a hollow “+” sign. Then drag this sign towards cell B6. The formula in cell A6 will be copied relatively into cell B6.

**Absolute Addressing:** In some cases the requirement is to retain the cell address even if it is copied to some other cell or when using AutoFill. In such cases, absolute addressing is used. Dollar signs ($) are used to hold a column and/or row address constant. When you enter an address in a cell that is prefixed with a $ sign, then Calc stores the absolute address of the cell.

For example, cell A4 contains the absolute address of A3 ($A$3). Now if you will copy the contents of A4 to B4 then it will contain the same address A3 ($A$3) because absolute address is used as shown in Figure 4.38.
Mixed Addressing: Sometimes a combination of absolute and relative addressing is used such as $A3, B$5, A5+$B4, $A1+B$1. In such cases, whichever part (row or column) is prefixed with $ remains unchanged and the ones not prefixed with $ are calculated in a relative manner.

For example, cell A4 contains =A3+$B$3. Now if you will copy the contents of A4 to B4 then it will contain =B3+$B$3. Relative address A3 will be converted to B3 and absolute address $B$3 will remain same as shown in Figure 4.40.
4.3.11 Sorting and Filtering Data

Sorting: Data can be easily sorted in Calc by using the sort command available on the Standard toolbar (Sort Ascending, Sort Descending) and also in the Data menu which opens a dialog box for more options as shown in Figure 4.41.

![Sort Dialog Box](image)

*Figure 4.41: Sort Dialog Box*

Steps to sort data in ascending order using the Standard Toolbar:

1. Select the cells you want to sort.
2. Click on the Sort Ascending icon on the Standard Toolbar.

Data will be sorted according to the first column of the selected cells.

Steps to sort data in ascending order using the Sort command:

1. Select the cells you want to sort.
2. Click on the Sort option in the Data menu which opens a dialog box.
3. You can change the select the column based on which you want to sort the data. Also you can select the Ascending or Descending option.
4. Click on OK
**Sorting using Multiple Columns:**

You can also select multiple criteria (up to 3) to sort with each criterion applied one after the other. For example, you have the following data as given in Table 2 and you want to sort it in ascending order according to the price per item and then if two items have the same price then in descending order of the number of items and if two items have the same price and the number then according to their code sorted alphabetically in increasing order.

<table>
<thead>
<tr>
<th>Item Code</th>
<th>Number of Items</th>
<th>Price per Item (in Rs.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>B45</td>
<td>34</td>
<td>234</td>
</tr>
<tr>
<td>A23</td>
<td>22</td>
<td>234</td>
</tr>
<tr>
<td>A43</td>
<td>12</td>
<td>65</td>
</tr>
<tr>
<td>S12</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>S13</td>
<td>22</td>
<td>234</td>
</tr>
</tbody>
</table>

*Table 2: Example of Sort*

Step 1: Select the cells you want to sort including the headings

Step 2: Since the data you have selected contains headers (Price per Item and Number of Items) which you don’t want to be included in sorting then open the Options tab in the same dialog box and check the option Range contains column headers.

Step 3: Click on the Sort option in the Data menu which opens a dialog box.

Step 4: In the Sort by section select the Price per Item column and ascending radio button.

Step 5: In the Then by section select the Number of Items column and descending radio button.

Step 6: Lastly in the next Then by section select the Item Code and ascending radio button as shown in Figure 4.42.
Figure 4.42: Sort Criteria

Step 6: Click on OK

The result after sorting is shown in Figure 4.43.

<table>
<thead>
<tr>
<th>Item Code</th>
<th>Number of Items</th>
<th>Price per Item (in Rs.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>S12</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>A43</td>
<td>12</td>
<td>65</td>
</tr>
<tr>
<td>B45</td>
<td>34</td>
<td>234</td>
</tr>
<tr>
<td>A23</td>
<td>22</td>
<td>234</td>
</tr>
<tr>
<td>S13</td>
<td>22</td>
<td>234</td>
</tr>
</tbody>
</table>

Figure 4.43: After sorting Table 2

In the Options tab, you can see various other options for sorting as shown below:

Case Sensitive – If the cells to be sorted contain the same letter in the same position but different in case then the one in uppercase is placed after the one in lowercase if the sort is ascending and vice versa if the sort is descending.

Direction (sorting rows or columns) – It selects whether sorting is to be performed row wise (vertically) or column wise (horizontally).
Filtering Data: Applying a filter means displaying data based on some conditions or filters. Filters can be applied by using the Filter option in the Data menu.

Three types of filters can be applied – AutoFilter, Standard Filter and Advance Filter. Let us study AutoFilter and Standard filter in detail.

AutoFilter – This filter is added on the topmost row of the selected data in the form of a drop down list from which you can select data to be displayed or in other words apply filters.

Example:

Given the following data in Table 3, the following are the steps to apply AutoFilter to display all the Female candidates.

<table>
<thead>
<tr>
<th>Name of the Student</th>
<th>Gender</th>
<th>Marks (out of 100)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aditi</td>
<td>Female</td>
<td>89</td>
</tr>
<tr>
<td>Piyush</td>
<td>Male</td>
<td>75</td>
</tr>
<tr>
<td>Bharti</td>
<td>Female</td>
<td>98</td>
</tr>
<tr>
<td>Suman</td>
<td>Female</td>
<td>59</td>
</tr>
<tr>
<td>Gaurav</td>
<td>Male</td>
<td>98</td>
</tr>
</tbody>
</table>

Table 3: Example of Filter

Step 1: Select the data

Step 2: Select Data menu and click on Filter->AutoFilter

Step 3: On the topmost cell of each column you will observe drop-down boxes. Click on the drop down in the gender column and you will see all the unique values in that column.

Step 4: Select the Female entry in the drop-down as shown in Figure 4.44.
The resulting sheet will contain all the female entries and the drop-down in the column in which filter is applied (Gender) will be colored in blue as shown in Figure 4.45.

You can apply filters to other columns also. Suppose in the above example, data was to be filtered for all the females students having 98 marks. Then click on the drop-down of the Marks column and select the 98 entry in the drop-down. The output will be as shown in Figure 4.46.

2. Standard Filter

Standard filter is used to provide more options for filtering such as combining multiple filters by using AND and OR operator. AND operator implies that all the filters must be satisfied for displaying the data. OR operator implies that at least one filter should be satisfied for displaying the data.
AND Operator Example - Suppose in Table 3, you have to select the male students having more than 75 marks. Following are the steps to filter data based on this criterion:

Step 1: Select the data
Step 2: Select Data menu and click on Filter->Standard Filter. A dialog box will open.
Step 3: Add the criteria for Gender = Male AND Marks > 75 as shown in Figure 4.47.

![Standard Filter using AND](image)

Figure 4.47: Standard Filter using AND

The AND operator ensures that all the criterion are satisfied.

Step 4: Click on Ok. The output will be as shown in Figure 4.48.

<table>
<thead>
<tr>
<th>Name of the Student</th>
<th>Gender</th>
<th>Marks (Out of 100)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gaurav</td>
<td>Male</td>
<td>98</td>
</tr>
</tbody>
</table>

Figure 4.48: Output of Standard Filter (AND)

OR Operator Example – Suppose in Table 3, you have to select the female students or students having more than 75 marks. Following are the steps to filter data based on these criterion:

Step 1: Select the data
Step 2: Select Data menu and click on Filter->Standard Filter. A dialog box will open.
Step 3: Add the criteria for Gender = Female OR Marks > 75 as shown in Figure 2.49.
Figure 4.49: Standard Filter using OR

Step 4: Click on Ok. The output will be as shown in Figure 4.50.

Figure 4.50: Output of Standard Filter (OR)

AND-OR Operators Example - Suppose in Table 3, you have to select the female students whose name begins with the letter “S” or male students whose name begins with letter “G”. Following are the steps to filter data based on this criterion:

Step 1: Select the data

Step 2: Select Data menu and click on Filter->Standard Filter. A dialog box will open.

Step 3: Add the criteria for Gender = Female AND Name of the Students Begins with “S” OR

Gender = Male AND Name of the Students Begins with “G” as shown in Figure 2.51.
Step 4: Click on Ok. The output will be as shown in Figure 4.52.

Removing AutoFilter – Select the cells as selected while adding the filter. From the Data menu, select Filter->Remove Filter as shown in Figure 4.53. The filters will be removed.
5.3.12 Creating Charts and Graphs

In Calc, you can create graphs and charts to represent the data graphically. Sometimes, it is very difficult to analyze spreadsheets containing huge amounts of data. For example, analyzing the academic performance of students of a school over the past 10 years. Such analysis can be done effectively by using charts which provide a visual presentation of data.

Various types of charts can be created in Calc. It offers a choice of 10 chart types such as Column chart, Bar chart, Pie chart, Area chart. Each of the chart types has several sub-types.

Creating Charts: Following are the steps required to insert a chart:

Step 1: Select the data which is to be included in the chart.

Step 2: Go to the Insert menu and select the Chart option as shown in Figure 4.54 or another way is to click on the Chart icon in the Standard toolbar.

Step 3: Chart wizard dialog box is displayed as shown in Figure 4.55 which is used to insert various options related to the chart such as the type of chart, data range, data series and elements of the chart.
Step 4: Select the chart type (Column chart, Bar chart, Pie chart etc.) and click on the Finish button.

Let us create different types of charts for the following data as shown in Table 4.

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenditure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>200</td>
</tr>
<tr>
<td>Feb</td>
<td>300</td>
</tr>
<tr>
<td>Mar</td>
<td>150</td>
</tr>
<tr>
<td>Apr</td>
<td>223</td>
</tr>
<tr>
<td>May</td>
<td>34</td>
</tr>
<tr>
<td>Jun</td>
<td>12</td>
</tr>
<tr>
<td>Jul</td>
<td>70</td>
</tr>
<tr>
<td>Aug</td>
<td>133</td>
</tr>
<tr>
<td>Sep</td>
<td>245</td>
</tr>
<tr>
<td>Oct</td>
<td>354</td>
</tr>
<tr>
<td>Nov</td>
<td>221</td>
</tr>
<tr>
<td>Dec</td>
<td>567</td>
</tr>
</tbody>
</table>

*Table 4: Monthly Expenditure of a Firm for the Year 2015*
**Column Chart:** A Column chart is used to compare values across categories by using vertical bars. The Column chart can be inserted by selecting the Column option in the Chart type of the Chart Wizard. You can also select from the various subtypes of Column chart from the Wizard. The Normal Column chart for the data in Table 4 is shown in Figure 4.56.

![Figure 4.56: Normal Column Chart](image)

**Bar Chart:** A Bar chart is the horizontal version of a column chart. It is used if you have large text labels. Select the Bar chart option in Step 3 above to create a Normal Bar chart for the Table 4 is shown in Figure 4.57.

![Figure 4.57: Normal Bar Chart](image)
**Pie Chart**: A Pie chart is used to display the contribution of each value (slice) to a total (pie) i.e., it can be used to plot various pieces of a single entity. The Normal Pie chart for Table 4 is shown in Figure 4.58.

![Figure 4.58: Normal Pie Chart](image)

**Line Chart**: A Line chart is used to compare trends and changes in values over time. The line chart (lines only) for the data in Table 4 is shown in Figure 4.59.

![Figure 4.59: Lines Only Line Chart](image)
Scatter Chart: A Scatter chart is used to display relationships between variables. The scatter chart for the data in Table 4 is shown in Figure 4.60. Note that the X axis labels are not the month names as in the case of line chart but numbers.

![Figure 4.60: Scatter Chart](image)

Apart from changing the chart type, chart wizard is also used to set various other options of the chart as discussed below:

- **Inserting Title**: You can insert title and subtitle of the graph and titles of X-axis and Y-axis in the Chart Elements of the Chart Wizard as shown in Figure 4.61.

![Figure 4.61: Chart Elements of the Chart Wizard](image)
After inserting the chart elements, the Points and Lines chart for the Table 4 is shown in Figure 4.62.

![Monthly Expenditure for the Year 2015](image)

**Figure 4.62: Points and Lines Chart with Chart Elements**

- **Legends**: Most commonly located on the right of the chart, legends help the readers of the chart to decode the charted data by associating descriptive text with the colors or patterns of data in the chart.

  You can modify the placement of legends or even remove them in the chart by using the Chart Wizard->Chart Elements as shown in the right panel of Figure 4.61.

- **Grids**: To make the data in a chart that displays axes easier to read, you can display horizontal and vertical chart gridlines. By default the horizontal gridlines are displayed. You can turn on and off the gridlines by using the Chart Wizard->Chart Elements as shown in Figure 4.61.

**Resizing and Moving Charts**

After the chart has been inserted, you can easily move and resize it. Click anywhere in the chart area and drag it to another position in the spreadsheet for moving the chart. For resizing it, click on the chart and then click and drag any of the chart resizing handle (Eight green small squares on the border of the chart as shown in Figure 4.63).
Deleting Charts

Select the chart and then press the Delete key on the keyboard for deleting a chart.

Modifying Charts

After the chart has been inserted you easily modify the chart. Double-click on the chart and then right-click. You can see various options such as Chart type, legends, titles, as shown in Figure 4.64 which can be changed.

4.3.13 Macros

A macro is a recording of each and every command and action you perform to complete a task. A macro records your mouse clicks and keystrokes while you work and play them back.
later. When you run the macro, it plays those actions back in the exact same order. Thus, if you want to repeat the actions multiple times you just need to run the macro.

Create/Record Macros:

Following are the steps to record/create a macro:

1. Go to the Tools tab on the Menu bar->Macros->Record Macro as shown in Figure 4.65.

![Figure 4.65: Macro](image)

Observe a small dialog box (Figure 4.66) has appeared on the worksheet displaying Stop Recording.

![Figure 4.66: Stop Recording Dialog Box](image)

2. Calc has started recording the Macro. Until you stop the recording, every Calc command and keystroke will be recorded in the macro, in the order in which they are entered. Suppose the following tasks were performed:

   a) We created all borders in the cells A1:C3.
   b) Then we changed the background color of cells A1:C3 to green.

3. After we have done all the required tasks, we will stop recording the macro by clicking on the Stop recording option on the dialog box (Figure 4.66). A new
dialog box will open (OpenOffice Basic Macros) in which you have to specify the name of the macro and the location for saving it (We have named the macro as ColorChange and saved it in My Macros folder) as shown in Figure 4.67.

Now we have a macro that can perform in a single operation all the tasks we have performed during recording of the macro.

Run/Use Macros created:

Following are the steps to run/use a macro that we have already created:

1. Go to the Tools tab on the Menu bar->Macros->Run Macros (Figure 4.65).
2. A dialog box will open as shown in Figure 4.68 showing all the macros created. We will select the one to run and then click on Run button.
3. The tasks performed during recording of the macro will be repeated in the same order in which they were performed. (Running ColorChange Macro will create borders around the cells A1:C3 and set their background color to green.)

By default, recorded macros use absolute cell referencing, which means that exact cell locations are recorded into the macro.

**Delete Macros:**

Following are the steps to delete a macro that we have already created:

1. Go to the Tools tab on the Menu bar->Macros->Organize Macros and select the OpenOffice Basic option.

2. A dialog box listing the macros created will open as shown in Figure 4.69. Select the macro you want to delete and then click on the Delete button.

![Figure 4.69: Deleting a Macro](image)

**4.3.14 Printing Spreadsheets**

Calc offers various options for printing spreadsheets. Many details can be selected for what is to be printed and what not.

For printing, open the File tab on the Menu bar and select the Print option. A dialog box will open (Figure 4.70) in which you can select various options such as:

1. All Sheets, Selected Sheets or Selected Cells.
2. All pages or specific pages. Specific page numbers separated by comma or range of pages (such as 1:10) can be entered in the Pages box.

3. Number of Copies

![Print Dialog Box](image-url)

Figure 4.70: Print Dialog Box

After selecting the options, click on Print to print the spreadsheet(s).

**Points to Remember**

- A spreadsheet stores data in the form of a table comprising of rows and columns.
- Spreadsheets are used to store, arrange, and sort data, and perform calculations on numeric data.
- OpenOffice Calc is a free and open-source spreadsheet application available that can be used to create and manipulate a spreadsheet.
- Calc Main Window contains various toolbars such as – Title Bar, Menu Bar, Standard Bar, Formatting Bar, Status Bar, Find Bar, Side Bar, etc.
- A Spreadsheet consists of a number of individual sheets, each containing cells arranged in rows and columns.
- A particular cell is identified by its column letter and row number.
- The selected cell is called as an Active Cell.
- Various types of data can be entered in a cell such as labels, numbers or values, formulas.
- AutoFill feature in Calc is used to automatically generate data based on a defined series.
To enhance the appearance of spreadsheets various formatting options are available in the Formatting Bar and Format Menu such as alignment, font, size, color, and style.

Data can be searched and even replaced by using the Find toolbar.

Formulas in Calc can be used for basic operations such as addition, subtraction, as well as more complex calculations such as income tax calculations, averaging.

The advantage of using formulas in the cell is that even if the data in the cell is changed, Calc will automatically recalculate the answer without the need to rewrite the formula again. Another advantage of using formulas is that they can be easily copied to a number of cells.

A cell reference identifies the location of a cell or group of cells in the worksheet. The cell reference is also called address of a cell.

Calc has a set of predefined formulas called functions.

Functions differ from formulas in the sense that in a formula we provide both the operands and the operator, however in functions, we only provide operands (or arguments) as functions have predefined operation to be performed on the arguments.

Some of the commonly used functions in Calc are: SUM(), PRODUCT(), SQRT(), POWER(), ROUND(), AVERAGE(), etc.

All cell references are by default relative i.e., they adjust and change when copied or when using AutoFill.

Absolute addressing is used when the requirement is to retain the cell address even if it is copied to some other cell or when using AutoFill. Dollar signs ($) are used to hold a column and/or row address constant.

Mixed addressing is a combination of absolute and relative cell addressing. Whichever part (row or column) is prefixed with $ remains unchanged and the ones not prefixed with $ are calculated in a relative manner.

Data can be easily sorted (increasing or decreasing order) in Calc by using the sort command available on the Standard toolbar and also in the Data menu.

Data can be filtered in Calc for displaying it based on some conditions or filters. Filters can be applied by using the Filter option in the Data menu.

Three types of filters can be applied – AutoFilter, Standard Filter, and Advance Filter.
In Calc, you can create graphs and charts to represent the data graphically which help in analyzing spreadsheets containing a huge amount of data.

Various types of charts can be created in Calc. It offers a choice of 10 chart types such as Column chart, Bar chart, Pie chart, Area chart, Line chart, Scatter chart, etc. Each of the chart types has several sub-types.

A macro is a recording of each and every command and action you perform to complete a task.

Calc offers various options for printing spreadsheets such as a number of copies, selected sheets, selected cells etc.

**Exercise**

1. Open a new spreadsheet in Open Office Calc and save it as InternetHours

The following table records the number of hours each student uses Internet in a week:

<table>
<thead>
<tr>
<th>Name</th>
<th>Monday</th>
<th>Tuesday</th>
<th>Wednesday</th>
<th>Thursday</th>
<th>Friday</th>
<th>Saturday</th>
<th>Sunday</th>
</tr>
</thead>
</table>

   a) Copy this data into your spreadsheet.

   b) Add another column titled “Total hours per user”. Using an appropriate formula, calculate the total hours each student used in the week.

   c) Add another column titled “Daily average hours used”. Using an appropriate formula, calculate the average hours each student used per day. The hours should be rounded to 1 decimal place.

   d) Below the last student, add a row titled “Total hours per day”. Using an appropriate formula, calculate the total hours used each day of the week.

   e) Add another row titled “Minimum hours used”. Using an appropriate formula, find the minimum number of hours used for each of the days.

   f) Add another row titled “Maximum hours used”. Using an appropriate formula, find the maximum number of hours used for each of the days.
2. ABC Sports expects its sales figures for 2015 to exceed the sales in 2014 by 10%. Create the following spreadsheet:

**ABC Sports**  
**Yearly Sales Report**

<table>
<thead>
<tr>
<th></th>
<th>2014</th>
<th>2015</th>
<th>2015 Sales Increase</th>
<th>10%</th>
</tr>
</thead>
<tbody>
<tr>
<td>Football</td>
<td>102,078</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Basketball</td>
<td>202,090</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tennis</td>
<td>20,034</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Netball</td>
<td>50,234</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Golf</td>
<td>12,211</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

a) Enter a formula in C54 that will calculate the amount of the sales for 2015. Use an absolute reference in order that the manager can change the rate of the expected increase to be able to view likely sales figures for 2015.

b) Change the rate of the sales increase to 20% and then 25% and see what happens to the 2015 figures.

c) Total the sales for the year 2014 and 2015.

3. Create the following worksheet which contains information about the subscribers of a newspaper “Daily News” during the period 21st – 25th August 2015

**Daily News**  
**New Subscribers**  
**August 2015**

<table>
<thead>
<tr>
<th>Date</th>
<th>Name</th>
<th>Number of years</th>
<th>Sunday Special</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>21-Aug-15</td>
<td>Ayesha Verma</td>
<td>2</td>
<td>Yes</td>
<td>Delhi</td>
</tr>
<tr>
<td>21-Aug-15</td>
<td>NipunSachdeva</td>
<td>3</td>
<td>Yes</td>
<td>Mumbai</td>
</tr>
<tr>
<td>21-Aug-15</td>
<td>Ram Kapoor</td>
<td>2</td>
<td>No</td>
<td>Kanpur</td>
</tr>
<tr>
<td>21-Aug-15</td>
<td>Divya Sharma</td>
<td>2</td>
<td>Yes</td>
<td>Delhi</td>
</tr>
</tbody>
</table>
### Date | Name | Number of years | Sunday Special | State
--- | --- | --- | --- | ---
22-Aug-15 | Neha Mehra | 3 | No | Madras
22-Aug-15 | Varun Dhingra | 1 | No | Madras
22-Aug-15 | MeghaNangia | 1 | Yes | Delhi
22-Aug-15 | SnehaBahl | 1 | No | Delhi
22-Aug-15 | Drishti Khanna | 2 | Yes | Mumbai
23-Aug-15 | Gauri Yadav | 1 | Yes | Kanpur
23-Aug-15 | Jasjit Singh | 2 | Yes | Madras
23-Aug-15 | Tarun Mehta | 3 | No | Kanpur

a) Extract records of subscribers who need Sunday special copy also.

b) Sort the table on state and Name of the subscribers.

### Create the following worksheet:

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>0</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>7</td>
</tr>
<tr>
<td>5</td>
<td>7</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
</tr>
</tbody>
</table>

a) Create a bar graph for the above data.

b) Create a pie chart for column Y.

c) Create a line chart between X and Y.

5. Create a macro which will set all borders of the cells D3:J15, set the color of cells as blue and set the first row to have font style as bold and center aligned text.
5.1 Introduction

Presentation software is required for the creation of the presentations for a larger audience. The presentation software has tools that allow the user to create presentations with sound, text, movies, pictures, and tables.

OpenOffice Impress is a popular open source software for presentation. The OpenOffice Impress software can be downloaded from Internet for free, and can be installed on Linux-based machines and also on Windows-based machines.

This chapter discusses the usage of OpenOffice Impress software in detail.

5.2 Start Openoffice Impress

To start using the OpenOffice Impress software, any one of the following steps needs to be performed:

- <Start> <Programs> <OpenOffice> <Presentation>, OR,
- If the OpenOffice Icon (Figure 5.1) is on the desktop, double click the icon

![OpenOffice Icon](image)
5.3 Openoffice Screen and its Components

The main screen of OpenOffice Impress is shown in Figure 5.2. It consists of different components like Tabs, Ruler bar, Status bar, Scroll bar, and Slide Pane. The Impress layout and its general features are described as follows:

- **Tabs** (File, Edit, View, Insert etc.) contain drop down menu which have commands provided by the tab.
- **Status Bar**: It displays information about the current open presentation. It displays the current slide number, total slides in the presentation, zoom slider, etc.
- **Scroll Bar**: There are two scroll bars – horizontal and vertical. They help to scroll the content or the body of the slide.
- **Work Area**: It is the working area where the text of the slide is typed.
- **View Options**: The slides can be viewed in different views – Normal, Outline, Notes, Handout, and Slide Sorter. Normal is the main view. Notes shows the Notes pane where notes can be viewed and edited. Outline gives the outline of the slides, Handout allows the user to print two or more slides on a single page, and Slide Sorter view presents miniature slides where the user can change the order of the slides, delete the slide, etc.
Slide Pane: It displays the slides as thumbnails. The user can view all slides in the presentation, rearrange them or hide slides.

5.4 Impress Tabs

The OpenOffice Impress has eight tabs – File, Edit, View, Insert, Format, Tools, Slide Show, and Window. There is also a help tab. On clicking any of the tabs, a drop down menu appears which have several commands and options. Select the command that you want to execute.

The key tasks that can be performed using the tabs are as follows:
- **File**: To apply commands to current presentation, to open or close presentation
- **Edit**: For editing the current presentation, like cut, paste etc.
- **View**: For controlling display of slides on the screen
- **Insert**: For inserting new elements in the presentation, like slide, page number, hyperlink etc.
- **Format**: For formatting the layout and content of slides
- **Tools**: For spelling check, gallery of object art to add to slides, to configure menus
- **Slide Show**: To make settings for slide show, animation and transition in a presentation
- **Window**: For manipulating and displaying presentation windows

5.4.1 File Tab

The OpenOffice Impress is used to create a presentation. The presentation is stored as a file in the computer with the extension .odp. For example, a document stored as a file Anita.odp.

The File tab consist of commands required to perform operations on a file (presentation). It contains several commands as shown in Figure 5.3. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to – create, save, print, open, and close a presentation file.
Some operations performed using the commands of the File tab are described as follows -

- **Using New**: When you click `<File>` `<New>`, a drop down menu appears. To create a presentation, select `<Presentation>`.

- **Using Save As**: This is used when you want to
  1. Save a file for the first time, or
  2. Save an already saved file with a different name.

When you click `<File Tab>` `<Save As>`, a Save As dialog box appears. You can –
- Select folder (directory) where the file is to be saved,
- Type the File name for the presentation,
- Select “save as type” of presentation (.odp etc.)
- Click “Save: button to save the file.

**To Print:<File><Print>:** Print the presentation to the connected printer. You can select the size of the paper, the slides to be printed, the number of slides on a single sheet to be printed etc.

### 5.4.2 Edit Tab

The Edit tab consist of commands required to perform editing on the current presentation. It contains several commands as shown in Figure 5.4. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to – cut, copy, paste, find & replace, undo, and redo changes in the current presentation.

![Figure 5.4: The Edit Tab](image-url)
Some operations performed using the commands of the Edit tab are described as follows -

- **Move Text:** Remove the text to be moved by selecting the text and then applying `<File><Edit><Cut>`. Then take the cursor to the place in the slide where you want to move the text. Then do `<File><Edit><Paste>`.

- **Copy Text:** Select the text to be copied and then apply `<File><Edit><Copy>`. Then take the cursor to the place in the slide where you want the copied text. Then do `<File><Edit><Paste>`.

- **Find and Replace:** This is used to find words then replace it with the new one. This option is useful to find the word at multiple places in the presentation and replace all of them with the new one.

### 5.4.3 View Tab

The View tab consist of commands required for viewing the current presentation on the screen. It contains several commands as shown in Figure 5.5. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to view slides in different layouts, status bar, ruler, sidebar, etc.

*Figure 5.5: View Tab*
Some operations performed using the commands of the View tab are described as follows -

- **Different ways in which presentation slides can be viewed:**
  - `<View><Normal>`: This is the main editing view for writing and creating slides.
  - `<View> <Outline>`: This displays an outline of the text in the slides.
  - `<View> <Slide Sorter>`: This presents all slides of the presentation in a miniature form. It helps in viewing all slides together and allows easy moving of slides.
  - `<View> <Slide Show>`: It shows slides as they will be actually presented. No editing can take place in this view.
  - `<View> <Notes Page>`: Allows user to make notes for the selected slide. The notes can be seen only by the presenter while making a presentation. The note page is not visible to the audience of the slide show presentation.
  - `<View> <Handout Page>`: It displays slides on a page as seen when printed. The user can vary the number of slides to be visible in a handout.

![Figure 5.6: Different views (a) Normal (b) Outline (c) Notes (d) Slide Sorter](image-url)
- **Use Slide Master**: Select **<View> <Slide Master>**: This allows changing the background color, text color, bullet type, bullet color, etc. The change in the slide master is visible in all slides of the presentation.

- **Insert Header and Footer in slides**: Select **<View> <Header and Footer>** Figure 5.7.

![Header and Footer Window](image)

**Figure 5.7: Header and Footer Window**

Tip: First make the Slide Master and then start making the presentation. Formatting of slide master gets applied to all slides.

### 5.4.4 Insert Tab

The Insert tab consist of commands required for inserting different elements in the slides or inserting slides itself. It contains several commands as shown in Figure 5.8. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to insert slide, page number, date and time, pictures, sound, hyperlinks, etc. in the current presentation.
When using an Insert tab to insert an element, the insertion of an element in the presentation happens at the location where the cursor is present on the slide. So you must place the cursor at the right location on the screen before inserting the element. Also, when using insert, a dialog box may open for further settings and selection. Please choose the options in the dialog box and proceed further. The dialog box is self-explanatory. Some operations performed using the commands of the Insert tab are described as follows -

- **Insert Page Number, Date and Time: **<Insert> <Page Number> : A Header and Footer Window opens. Make settings here for date, time and page number.

- **Insert Fields: **<Insert> <Fields> : A pop-up menu appears (Figure 5.9). Select the element to be inserted. The selected element will insert at the location of the cursor.
4.4.5 Format Tab

The Format tab consist of commands required for formatting the presentation slides. It contains several commands as shown in Figure 5.10. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to format a character, paragraph, slide design and slide layout, etc. in the current presentation.
When using the Format tab, the formatting happens on the text or the figure that has been selected. So you must select the text or the figure on which the formatting has to be applied and then use the relevant command from the Format tab. Some operations performed using the commands of the Format tab are described as follows -

- **Format Character**: `<Format> <Character>`. A dialog box opens. Select the font type, typeface and size. Select font effects, background etc.

- **Format Paragraph**: `<Format> <Paragraph>`. A dialog box opens. You can change the indentation and spacing, borders, alignment etc.

- **Format Line**: `<Format> <Line>`. A dialog box opens (Figure 5.11). You can select from line style, width, color etc. In the slide, formatting applies to the selected line.

- **Format Slide Layout**: `<Format> <Slide Layout>`. You can select a slide layout for the slide from the different slide layouts presented to you. (Figure 5.12).

![Figure 5.11: Format Line](image)
4.4.6 Tools Tab

The Tools tab consists of commands that can be used on the presentation for better results. It contains several commands as shown in Figure 5.13. The commands which are required to be known at this stage are described in the figure. The commonly used commands allow the user to check the spelling of content in the presentation.

Figure 5.13: Tools Tab
Some operations performed using the commands of the Tools tab are described as follows -

- **Check Spellings**: `<Tools> <Spelling>`. The spelling of the presentation is checked. A window appears if there are no spelling errors in the document. If errors are there, then the errors are displayed with suggestions of correcting it.

### 5.4.7 Slide Show Tab

The Slide Show tab consists of commands that can be used on the presentation for better results. It contains several commands as shown in Figure 5.14. The commands which are required to be known at this stage are described in the figure.

![Figure 5.14: Slide Show Tab](image)

When using the Slide Show tab, it contains commands that are required during the presentation of the slide show. Some operations performed using the commands of the Slide Show tab are described as follows:

- **Slide Show Settings**: `<Slide Show> <Slide Show Settings>`. A dialog box opens (Figure 5.15). Select the slide to start from, animation allowed etc.

- **Custom Animation**: `<Slide Show> <Custom Animation>`. A dialog box opens on the right side of the screen. Select the element on the slide on which the animation has to be applied. Click `<Add>`. Select the animation to be applied.

- **Slide Transition**: `<Slide Show> <Slide Transition>`. A dialog box opens on the right side. Select the transition you want to apply to the slide.
There is a difference between animation and transition. Slide transition applies to the pattern that will show up when one slide goes to the next (for example, wheel, diamond etc.). Slide animation applies to elements of a single slide, i.e., how the different elements in a slide will appear on the screen, their order, etc.

5.4.8 Window Tab

The Windows tab consists of commands that work on a window, as shown in Figure 5.15. The commands in this tab allow the user to open a new window or close an existing window. Also, the name of all currently open windows is also displayed.
5.4.9 Help Tab

The Help tab consists of commands that provide help to the user of the OpenOffice Impress software. On clicking on the help tab, a screen as shown in Figure 5.17 appears. You can browse the Help for the command you want.

![Help Tab](image)

Figure 5.17: Help Tab

**Points to Remember**

- Presentation software allows creation of presentations having text, audio, video and pictures.
- OpenOffice Impress is an open source software for presentation.
- Tabs, Ruler bar, Status bar, Scrollbar and Slide Pane are the different components of OpenOffice Impress.
- OpenOffice Impress has eight tabs – File, Edit, View, Insert, Format, Tools, Slide Show, and Window.
- The slides can be viewed in different views – Normal, Outline, Notes, Handout, and Slide Sorter.
- Normal view is the main editing view for creating slides.
- Notes allows the user to make notes for the selected slides.
- Slide Sorter view presents slides in a miniature form.
- Slide Master allows making changes in appearance of the slides, applying changes to all slides in the presentation.
- File tab allows operations on a presentation, like, create, save, print, open and close.
Edit tab is required to perform editing on the presentation, like, cut, copy, paste, find & replace, undo and redo changes.

View tab consist of commands required for viewing the current presentation on the screen to view slides in different layouts, status bar, ruler and sidebar.

Insert tab is required for inserting slide, page number, date and time, pictures, sound and hyperlinks in a presentation.

Format tab allows formatting the slides - character, paragraph, slide design and slide layout.

Tools tab contains commands to check spelling of content in the presentation.

Slide Show tab consists of commands used on the presentation for better results.

Slide transition is the pattern that applies when a slide goes from one to next.

Slide animation is the pattern that applies to elements of a single slide.

Windows tab consists of commands that work on a window, like, open and close a window.

Help tab provides help to the user of OpenOffice Impress software.

Exercises
1. What is the need of a presentation software?
2. What is the task of a presentation software
3. Name an open source presentation software
4. List the steps to start an OpenOffice Impress.
5. List the components of the main screen of OpenOffice Impress.
6. Define the following-
   a. Tabs
   b. Ruler Bar
   c. Status Bar
   d. Scroll Bar
   e. Slide Pane
f. Work Area
7. List the different view options in OpenOffice Impress.
8. List the tabs in the OpenOffice Impress. What are the key tasks performed by the tabs
9. What is the extension of the file created in OpenOffice Impress.
10. What is the purpose of the following tabs-
   a. File
   b. Edit
   c. View
   d. Insert
   e. Format
   f. Tools
   g. Slide Show
11. What is the difference between Save command and Save As command.
12. What is the difference between Move text and Copy text.
13. How is Find and Replace option useful.
14. What is the purpose of the following views -
   a. Normal
   b. Outline
   c. Slide Sorter
   d. Slide Show
   e. Notes Page
   f. Handout Page
15. What is the need to use the Slide Master.
16. List the steps for inserting a hyperlink to a video in a presentation.
17. What is the difference between slide transition and slide animation.
18. Name the tabs in which the following commands are present-
   a. Header and Footer
b. Find&Replace
c. Status Bar
d. Ruler
e. Hyperlink
f. Animation
g. Transition
h. Normal view
i. Copy

19. Use OpenOffice Writer to create the following presentations-
   a. A five slide presentation showing five years of your life
   b. A presentation about the farewell party
   c. A five slide presentation showing the importance of saving the environment
   d. A presentation having hyperlink on each slide to a web resource (audio, page, video) around the theme of beautiful nature.
   e. A presentation that tells about you as in your resume.
   f. Use Animation, Transition and Notes Page in all presentations.
6.1 Background

6.1.1 Multimedia Design Tools

The term multimedia is a combination of two terms multi (meaning more than one) and media (meaning a mode of transmitting information). Thus, multimedia deals with using more than one concurrent medium, in an integrated manner. It may include the following forms of media:

- Text
- Graphics and Images
- Audio
- Video
- Animation

Multimedia design is an art that integrates multiple forms of media for designing various applications such as video games, educational software, navigation systems, entertainment, hospital information systems. Multimedia Systems encompass computer and software systems which could easily be used in an interactive manner. Multimedia development incorporates rendering the input to multimedia design tools for processing to achieve the final product.

Figure 6.1: Multimedia Development
**Attractions in using Multimedia Technology:**

- Yielding Simplicity and Ease of use
- Interactive Interface
- Better Understanding of the Content
- Cost Effectiveness
- Having Fun element

In this chapter, our focus will be on learning open source multimedia design software for manipulating and enhancing multimedia features of images.

Open source multimedia design tools are gaining importance in today's world as not only open source software is freely available, its source code is also freely available, and we can develop new features to enhance its capability.

Adobe Photoshop software has been used predominantly over the years for image editing. But now various open source tools for image editing are available. We list below a few of them and mention the operating environments that support them against their names in parentheses:

- GIMP (Windows, Linux, OSX)
- Fotor (Windows, OSX, Android, Online)
- Fooflexer (Online)
- Snapseed (Android, iOS)
- Paint.net (Windows)
- Autodesk Pixlr (Windows, OSX, iOS, Android, Online)
- Picasa (Google's photo manager: Windows, OSX)

GIMP is multimedia software having a variety of powerful tools for image editing and manipulation. We will take a tour of GIMP and discuss its important features in the following sections.

**GIMP as a Multimedia Tool for Image Manipulation**

GIMP is an acronym for GNU Image Manipulation Program. It is an open source software suite to create, edit, enhance and manipulate images. GIMP is a full software suite consisting of a variety of painting tools (like brushes, pencil and cloning), image manipulators, built-
in filters for rendering effects (like blur, distort, colorize, and transform), layers dialogue to work in layers, etc. It is designed to support various plugins for extensions and compatibility. By default, the image is stored in .xcf image format.

*The first version of the GIMP (x0.54) was written by Peter Mattis and Spencer Kimball, students at Berkeley, back in 1996. Gimp 1.0, an enhanced version, was released in 1998 and an official website was established for the tool usage. It had extensive functionality for image manipulation from its earlier versions itself.*

Gimp is extensible. Nowadays, prevailing Gimp 2 series (version 2.8) is under use for image manipulation, with enhanced interfaces and design tools. The software suite is available for download at http://www.gimp.org/. It is supported on operating systems such as UNIX/LINUX, Windows, and MacOSX.

**Few attractive features of GIMP**

- Software suite of painting and drawing tools with various brushes, a pencil, an airbrush, cloning, etc.
- Paint tools supporting high-quality anti-aliasing.
- Multiple tools and channels for image manipulations.
- Transformation tools including rotate, scale, shear and flip.
- A procedural database for calling internal GIMP functions from external programs such as Script-Fu and Python-Fu.
- Advanced scripting capabilities.
- Multiple undo or redo effects on images if sufficient disk space available.
- Support for various file formats, including GIF, JPEG, PNG, TIFF, TGA, PS, PDF, PCX, BMP, XPM, and MPEG etc.
- A variety of Selection tools, including rectangle, ellipse, intelligent scissors etc.
- Plug-ins supporting easy addition of new file formats and filters.

**Installing GIMP**

Installing GIMP is similar to installing any other software package. In the case of Windows, we download the installer and execute it. In Linux environment (platforms like Ubuntu or Debian), it could simply be installed by running the following commands in the terminal window:
sudo apt-get update
sudo apt-get install gimp

Alternatively, GIMP is also available in Ubuntu software center in Ubuntu Unity.

Installation on Windows

1. **Download the Installer:** It is downloadable from http://www.gimp.org/downloads/.

   ![Download Installer](image)

   *Figure 6.2: Download Installer*

2. **Execute the Installer:** The installer is usually saved in the Downloads folder. Run the installer.
3 **Select the Language for Installation:** The “Language” is selected as “English” by default.
4. **Start Installation:** Click on install button to initiate the process.

![Figure 6.5: Download Installer](image1)

5. **Follow the Trailing pPrompts for Installation:** The sequences of prompts are executed.

![Figure 6.6: Installation Progress](image2)
6. **Finish Installation:** GIMP will be launched just after the click on Finish button.

![Figure 6.7: Finishing the Installation](image)

**Installation on Linux**

1. **Run the command `apt-get` on the terminal.**

![Figure 6.8: Running `apt-get` Install GIMP](image)
2. **Continue with installation**

![Continue with Installation](image)

**Figure 6.9: Continue with Installation**

3. **The desired packages are unpacked.**

![Installed GIMP](image)

**Figure 6.10: Installed GIMP**
The GIMP is also available in UBUNTU Software Center and is directly accessible.

Starting with GIMP

GIMP may be launched in two ways: i) clicking on a GIMP icon (GUI) or ii) by typing `gimp` command on command line interface. It detects and uses the system language by default and configures various directories and options on start-up. The configuration information is stored in .gimp-version directory for initialization, recovery or backup. It supports a variety of image file formats. GIMP startup screen appears as follows with Wilber as screen mascot:
1. **Basic Image/File Handling: Opening, Creation, Cropping, Resizing and Saving Images**

The first thing we are going to do is to open an image file in GIMP. For opening a file we need to go to:

**File Menu → Open** or press **Ctrl + O** (Figure 6.13).

Then a dialogue box with **Open Image** will be displayed. The folders are displayed on the left hand side of the dialogue box and image file to be opened, is selected. A preview will appear on the right-hand side of the dialogue box (Figure 6.14).

*Figure 6.13: Opening a File*
To search an image file manually, “Pencil” icon in the “Open Image” box is clicked and a user may type the location of a file in the “Location” column and then opens the image file (Figure 6.15).

If an image is too big, such that it does not fit to file window, then window may be resized by dragging the mouse. After resizing the window, “Zoom to Fit Window” may be chosen from the “View” menu, and the image will be resized to fit the window (Figure 6.16).
Figure 6.16: Resizing Images
Image could also be resized using “**Scale Image**” in **Image** menu (Figure 6.17).

![Figure 6.17: Scaling Image](image)

The image may be cropped using “**crop**” tool in Toolbar (Transform tools) or by going to the “**Image**” menu and choosing “**Autocrop.**”

The creation of the new file is also one of the initial steps in GIMP which helps users to create a new image file by setting up height and width properties.

The new image file could be created as follows:

**File Menu → New** or by pressing **Ctrl+N** (Figure 6.18 a).

A dialogue box named “**Create a New Image**” gets popped up.
The dialogue “Create a New Image” displays the default image size (Figure 6.18 b). A user can alter the size either manually or through the up and down arrow keys. A user can also set the type/nature of picture file size by clicking pixels.

“Template” could be used to pre-define the picture size and the “Advanced Options” which supports additional features like “Resolution, Color space, Fill with and Comment”.

After setting these features and finally we can click the Ok button to create a new image box.
Now the new file has been created. A sample new file created has been shown below (Figure 6.18 c).
Finally, the file is saved by choosing “Save” or “Save as” in “File” menu. On clicking the “Save” button, modifications are done on the current image will be saved whereas on clicking “Save as”, a dialogue box pops up to indicate where a user wants to save file, maybe with a different extension or on a different path (Figure 6.19).

Figure 6.19: Saving an Image

2. **GIMP Interface and Drawing Tools**

GIMP is a powerful tool for image processing and its interface has the following main panels docked with variety of functionalities or dialogue boxes (Figure 6.20):

i) **The Toolbox:** A comprehensive set of icons/buttons for selecting tools for image manipulation.

ii) **Tool Options:** The docked window renders options or features available for currently selected tool.

iii) **An Image Manipulating Window:** An image to be modified in GIMP; is opened in the image manipulating window. Many images could be opened in parallel for processing.

iv) **Layers Dialog:** This allows multiple images to be stacked over each other in layers for manipulations. Layers can be decomposed into sub-layers known as Channels. Mostly layers consist of RGB (Red, Green, and Blue) channels. Paths are arcs or curves, and the path tool is powerful for performing the selection or to paint on an image in the desired area with the help of arc curves.
v) **Brushes/Patterns/Gradients:** The docked dialogue for selecting brushes, patterns, or gradients allows us to colorize an image or fill it with some pattern. Brushes are pixmaps used for painting, erasing, copying, smudging, lightening or darkening etc. Patterns are small images used for filling regions of original images or for changing the background of an image. Gradients are set of colors arranged in linear ordering and control the way colors could be filled or modified within the image.

![Figure 6.20: GIMP Interface](image-url)
GIMP is flexible in arranging dialogues which are actually the windows containing options for a tool or are dedicated to special purpose tasks. The persistent dialogues (Tool Options, Layers/Channels, Brushes/Patterns/Gradients) are dockable. The docks are thus containers for persistent dialogues. The non-persistent dialogues such as an Image-Window, Preferences dialogues, etc. are not the part of docks.

** If docks are trashed or closed for some reason; the interface arrangement could be recovered from

| Windows → Recently closed Docks. | Windows → Dockable Dialogues |

6.2 Tool Box

GIMP has an encircling tool suite, to perform a variety of image manipulations, selection and enhancement operations.
The tool presets are shown in Figure 6.22.

The tools are organized into following main categories in GIMP:

a. Selection Tools  
b. Paint Tools  
c. Transform Tools  
d. Color Tools  
e. Others

The above-mentioned tools are described as follows:

6.2.1 Selection Tool

i) Introduction

Selection tools form an essential part of GIMP. Often a user wants to operate on a portion of an image instead of using the whole image. Selection tools (Figure 6.23), support the functionality of selecting portions/regions from the current layer of an image, for manipulation. Once a selection is made, anything the user does will apply only to the area that the selection covers. The selection tools may be accessed in different ways via:

- Clicking tool icon in the Toolbox
- Tool Menu Bar (Tools ➔ Selection Tools ➔ Rectangle Select/or any other select)
- Shortcut keyboard key
The selection area is drawn with left click mouse button, stretching downwards. The selection could be deleted by clicking anywhere outside the selection area.

![Figure 6.23: GIMP Selection Tool](image)

The selection tools are listed in Table 6.2.1.1.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name of the Feature</th>
<th>Shortcut key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td>Rectangle</td>
<td>R</td>
<td>It selects square or rectangular regions.</td>
</tr>
<tr>
<td><img src="image" alt="Ellipse" /></td>
<td>Ellipse</td>
<td>E</td>
<td>It selects circular or elliptical regions.</td>
</tr>
<tr>
<td><img src="image" alt="Free Lasso" /></td>
<td>Free (Lasso)</td>
<td>F</td>
<td>It draws hand drawn region with free-form (polygon) selections.</td>
</tr>
<tr>
<td><img src="image" alt="Foreground" /></td>
<td>Foreground</td>
<td>(none)</td>
<td>It selects a region containing foreground objects.</td>
</tr>
<tr>
<td><img src="image" alt="Fuzzy" /></td>
<td>Fuzzy (Magic Wand)</td>
<td>U</td>
<td>It selects continuous regions on the basis of colors.</td>
</tr>
<tr>
<td><img src="image" alt="By Color" /></td>
<td>By Color</td>
<td>Shift + O</td>
<td>It selects all regions of similar color in an image.</td>
</tr>
<tr>
<td><img src="image" alt="Scissors" /></td>
<td>Scissors</td>
<td>I</td>
<td>It selects regions using shapes with intelligent edge fitting.</td>
</tr>
</tbody>
</table>

*Table 6.2.1.1: Selection Tools in GIMP*
Amongst the above-listed tools in Table 6.2.1.1, “Rectangle”, “Ellipse”, “Free Select”, “Foreground and Scissors” are area selection tools whereas “Fuzzy Select” and “By Color Select” are color selection tools.

ii) Tool Options

The most commonly associated features with selection tools are modes, antialiasing and feather edges (Figure 6.24).

Figure 6.24: Tool Options

Mode governs the interaction of new selection with the already existing selection. Various modes available with Selection tools are Replace, Add, Subtract, and Intersection (Figure 6.25 a).

Figure 6.25(a): Selection Modes
- **Replace mode** will cause existing selection is replaced by new selection.
- **Add mode** will cause new selection to be added to existing selection
- **Subtract mode** will remove the new selection from existing selection.
- **Intersection mode** will overlap the new selection with existing selection i.e. final selection contains the area common to both the selections.

The behavior of selection tools could be altered, if a user presses and holds down the Ctrl, Shift, and/or Alt keys. These keys and/or combinations of these keys are known as key modifiers that could be associated with a mode (Table 6.2.1.2).

<table>
<thead>
<tr>
<th>Key Modifiers</th>
<th>Purpose</th>
</tr>
</thead>
</table>
| Ctrl          | Before drawing a selection: Subtract Mode (Removes from selection).  
While drawing the Selection: Expand From Center. |
| Alt           | Moves frame of current Selection. |
| Shift         | Switch to Addition Mode to add to a selection. |
| Ctrl + Shift  | Switch to intersection mode. |
| Ctrl + Alt + Drag | Move Selections. |
| Space Bar     | Transforms the tool to navigate across by pressing the space bar instead of scrolling. |
| Ctrl + I      | Reverses the selection |

*Table 6.2.1.2: Key Modifiers with Modes in Selection Tools*

**Antialiasing** makes the edge boundaries of the selected image smoother. Various selection tools create sharp selections with selected pixels inside the boundary and unselected pixels outside the boundary.

An option on **Feather Edges** makes the boundary of selection blur, faded or fuzzy. It also smoothen the sharp image selections with outside graduated ones like antialiasing. But it works by setting the radial distance from the selection edge (Figure 6.25 b).
Feathering edges of an image helps to integrate the image into the background or to tone down a harsh outline of the image for merging it with the background. This feature is also useful in cutting and pasting operations.

iii) **How to use Selection Tools?**

The steps to execute selection tools on images are listed below:

- **Step 1**: Click “File” then “Open” to open an image from the computer drive.
- **Step 2**: Click on the selection tool icon in GIMP’s toolbox. Alternatively, the selection tool could be chosen by selecting “Tools” from the program’s menu, and then clicking the desired “Selection tools”. The chosen tool is dragged over the current image to select the desired area.
- **Step 3**: Once the area has been selected, a boundary (rectangle/ellipse/marquee/etc.) is visible around the selected portion.
- **Step 4**: Selected portion is used for further image manipulations and other operations.
6.2.2 Rectangle Select

The rectangle is the most commonly used tool that creates a rectangular or square selection frames with small squares in each corner around the image to select rectangular regions of the active layer.

The steps for rectangular selection are listed below:

1. Select the tool, click on its tool icon or use the Keyboard shortcut “R”.
2. Draw the rectangle/square selection by placing the Rectangle Selection tool icon at the top left corner of where you want to initiate your selection and then dragging over the area to be covered.
3. When the tool is released the rectangular outline is replaced by a marquee i.e. the little dash lines moves around the active selection.
4. Once drawn, the Target icon changes to the “Move” icon indicated by the four directional arrows. The Move icon allows the selection to be moved anywhere.
5. If we click outside the marquee area, the selection will disappear.

![Figure 6.26: Initiating the Rectangle Selection](image)

The selection will be constrained to a “square” if a user holds down the Shift key while drawing the selection. It will draw from the center outwards if Alt Key is pressed while selection.

The selection boundary can be expanded or contracted through the corner areas indicated by small rectangles/squares. Dragging the corner area upwards or outwards (diagonally) expands the selection and dragging down or inwards (diagonally) contracts the selection.

An illustration of rectangle selection is shown in Figure 6.27. As the house in the image has been selected, any action like manipulation/enhancement on the image will only apply to the selected portion of the house.
For example, if we use a Brush tool or adjust colors, it would only affect the selected part. The selected image could also be copied and pasted into another image.

![Figure 6.27: Illustration of Rectangle Selection on an Image](image)

A few of the other options available with this tool are listed below:

- **Rounded Corners**: It is used to make the corners of the current selection, round. A slider appears for adjusting the radius of the selection on enabling this option.

- **Expand from Center**: The point where the selection is started by clicking the mouse button is used as the center of the image.

- **Fixed**: This enables the option for constraining the shape of image selection.

- **Aspect Ratio**: This enables a user to resize the selection by changing or inverting the default aspect ratio of 1:1(square).

- **Width**: It fixes the width of the selected image.

- **Height**: It fixes the height of the selected image.

- **Size**: It fixes both width and height.

- **Position**: It adjusts selected position by setting the horizontal and vertical coordinates.

- **Highlight**: It enables the selected area to be emphasized. If the Highlight box is checked, the image will darken except for the selection area. This enables us to see exactly what is selected.
6.2.3 Ellipse Select

The Ellipse Selection tool is used to select circular or elliptical regions by rendering circular or elliptical boundary on an image.

It functions majorly like Rectangle Select but only the shape of selection is different. To select the tool, we click either on its icon or press the keyboard shortcut “E”. We draw out the elliptical/circular selection by placing the Ellipse Selection Tool icon at the top left corner of where we need to begin (can be any corner) and drag over the area to be covered as shown in Figure 6.28. When the tool is released the elliptical/circular outline is replaced by the marquee.

![Figure 6.28: Illustration of Ellipse Selection](image)

It has mainly the same options as those in Rectangle select discussed above in section 6.2.2.
6.2.4 Free Select

The **Free Select (Lasso)** tool uses mouse clicking and dragging in the image window to trace the selection shape. The action is completed with the release of the mouse button and the selection is shown by Marching Ants ((Figure 6.29).

It works by choosing tool icon for **Free Select**, or by using the **Keyboard shortcut “F”**.

It functions in two modes: **Straight Line** mode or **Free Drawing** mode as listed in Table 6.2.1.3.

<table>
<thead>
<tr>
<th>Straight Line</th>
<th>Free Drawing</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click to create a starting control point (represented by a yellow circle) and release the mouse button.</td>
<td>1. Click to create a starting point, but keep the mouse click (left) button pressed to start drawing the line. A yellow circle will appear indicating the first starting control point.</td>
</tr>
<tr>
<td>2. Move the mouse downward along the image to be selected and the line follows the mouse movement (Don't press the mouse click button down as by doing this we will go into the Free Drawing mode).</td>
<td>2. Keep the mouse button pressed and trace the path of selecting the portion of an image.</td>
</tr>
<tr>
<td>3. Click to set another point indicated by the yellow circle to change direction and move further around the selection.</td>
<td>3. Click back on the first initial point.</td>
</tr>
<tr>
<td>4. The process is continued until we return to the first point.</td>
<td>4. The line will turn into the selection boundary.</td>
</tr>
<tr>
<td>5. Click back on the first point.</td>
<td>5. Press ENTER key to complete the selection at any time.</td>
</tr>
<tr>
<td>6. The line segments will turn into the selection boundary.</td>
<td></td>
</tr>
<tr>
<td>7. Press ENTER key to complete the selection at any time.</td>
<td></td>
</tr>
</tbody>
</table>

*Table 6.2.1.3: Steps for Free Selection*
The main advantage of Lasso is that it can be used to select arbitrarily number of complex objects. The disadvantage is that it is difficult to use this tool for precision work as it is dependent on mouse clicks (which cannot be released in between of any selection). The predominant options available with this tool are antialiasing and feather edges.

### 6.2.5 Intelligent Scissors

Intelligent Scissors selects a part of an image automatically by high contrast or differences in colors, with constant-valued color contours. It is inspired by the features of Lasso and path tools. The region to be selected is surrounded by boundary created by joining the nodes or anchor points clicked by mouse at the edges.

This tool works in the following manner.

1. Click and select **Intelligent Scissors** tool icon or use the Keyboard shortcut “I”.
2. Point and click at various points around the edge of the input image.
3. As the anchor points are marked on the edges with this point and click technique, the tool automatically draws the selection line around the edges that it detects.
4. Press **Enter** outside the boundary.
5. The selection marquee is created.
The **Scissor Select Tool** consists of five different icons during its functioning (Table 6.2.1.4):

<table>
<thead>
<tr>
<th>Icon</th>
<th>Default icon that appears when the <strong>Scissor Select</strong> tool is activated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>It contains a small “+” to indicate that <strong>new anchor points can be added</strong>, over existing selection line.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Indicates Move allowing selected control point to be moved to another location.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Appears when we click back on the first anchor point to complete the selection boundary.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Appears when the selection boundary is complete &amp; clicking within the boundary of the selection makes the selection marquee.</td>
</tr>
</tbody>
</table>

*Table 6.2.1.4: Various Icons and their roles in using Intelligent Scissors*

The advantage that this tool has for detecting edges is that as we point and click, it automatically redraws the selection line around the edges for tracing. Hence, we can edit the current selection line by just adding or repositioning the control points.

Also, keeping the anchor points close will aid in more accurate boundary detection for an image.

This tool also supports the option **Interactive boundary**, besides **antialiasing** and **feather edges**.
6.2.6 Foreground Select

It works on selection by extracting foreground from the current image. This tool works better when the foreground and background are highly contrasting in color saturation. It is basically a combination of two different tools:

- **Lasso tool:** used to select a foreground area (similar to the Free Select tool)
- **Paintbrush tool:** used to paint over selection to indicate the foreground color

The tool works as follows (Figure 6.31):

1. The lasso tool is used to draw around an area that user wants to select.
2. After selection, the image goes dark.
3. Then the paintbrush tool is used to paint a brushstroke over the foreground area so that the tool can differentiate the foreground colors from the background colors.
4. Once it determines the boundary difference between foreground and background colors, a “mask” i.e. a bluish marker is placed over the foreground area to mark it.
5. Pressing ENTER key converts the mask to a selection marquee.

The steps are indicative in Figure 6.31.

Besides mode, antialiasing and feather edges, it has the following tool option settings:
- **Contiguous**: To select a contiguous area of color strokes.
- **Interactive refinement**: To handle settings for the brush.
- **Smoothing**: To control the smoothness of selection.
- **Preview color**: To do the background color selection.
- **Color Sensitivity**: To set the color sensitivity of the selected region.

*Figure 6.31: Foreground Select Tool*
6.2.7 Fuzzy Select

Fuzzy Select is a color based tool. Fuzzy selection (also called ‘magic wand’) is used for selecting areas in an image with the similar color component (Figure 6.32). The functionality of this tool is based on examining the RGB color components of the pixels that it clicks on. It is very important to pick the starting point correctly.

To make a selection with the Fuzzy Select tool,

1. We first have to click on an image at a point that is the color you want to select.
2. The pixels immediately surrounding the selected pixel and falling within the threshold of similarity will be included in the selection.
3. The size of the selection could be adjusted by holding the mouse click button down and dragging downwards or to the right-hand side to increase the size or dragging upwards or to the left-hand side to decrease it.

This tool has the following additional option-suite:

- **Select transparent areas**: To select transparent pixels within the set threshold.
- **Threshold**: It determines the basic range of colors. Increasing the threshold (either by clicking on the number in a box or by dragging the blue slider), increases the range of colors to be selected. Most of the color variations in the image will be selected if a threshold is too high. The maximum value is 255.
- **Select by**: To select the color component for calculating the similarity. It has following available basic options:
  - Composite: the default setting
  - Red: focuses on the selection of red color.
  - Green: focuses on the selection of green color.
  - Blue: focuses on the selection of blue color.
  - Hue: focuses on a specific color
  - Saturation: focuses on the purity of colors
  - Value: focuses on the light/dark values of colors
6.2.8 By Color Select

The selection by color also considers all the pixels with similar color component, but regardless of where they are located in the image. The similar pixels automatically get selected, even if they are trapped by other colors, unlike fuzzy tool. As illustrated in Figure 6.33, the blue pixels are selected in the whole image. It has the same tool options as that of fuzzy select.
6.2.9 Paint Tools

i) Introduction

A paint tool is a comprehensive suite consisting of 13 basic paint features as shown in Figure 6.34.

The paint tools could also be selected by clicking an icon in the toolbox or by selecting a tool from the Paint Tool tab. Shortcut keys may also be used. The functionalities of these tools are listed in Table 6.2.1.5. The Paint tools share the same basic brushes, and the same options for choosing colors, either from the basic palette or from a gradient. The Paint tools support a variety of modes for painting.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bucket Fill</td>
<td>Shift + B</td>
<td>It fills an area with a selected color or pattern.</td>
</tr>
<tr>
<td>Blend</td>
<td>L</td>
<td>It fills an area with a gradient.</td>
</tr>
<tr>
<td>Pencil</td>
<td>N</td>
<td>It paints lines with hard-edges; that is, the pixels are not anti-aliased.</td>
</tr>
<tr>
<td>Paintbrush</td>
<td>P</td>
<td>It paints lines with soft- or fuzzy edges; that is, the pixels are anti-aliased and/or feathered.</td>
</tr>
<tr>
<td>Eraser</td>
<td>Shift + E</td>
<td>It erases pixels of an image from the current layer.</td>
</tr>
<tr>
<td>Airbrush</td>
<td>A</td>
<td>It is a paint tool with variable pressure.</td>
</tr>
<tr>
<td>Ink</td>
<td>K</td>
<td>It paints anti-aliased lines with a simulation of a nib.</td>
</tr>
<tr>
<td>Clone</td>
<td>C</td>
<td>It copies patterns from one part of an image to another to make a clone.</td>
</tr>
<tr>
<td>Heal</td>
<td>H</td>
<td>It hides image irregularities and corrects the defects.</td>
</tr>
<tr>
<td>Perspective Clone</td>
<td>(none)</td>
<td>It clones from an image source after applying the perspective transformation.</td>
</tr>
<tr>
<td>Convolve (Blur/Sharpen)</td>
<td>Shift + U</td>
<td>It blurs or sharpens an image.</td>
</tr>
<tr>
<td>Smudge</td>
<td>S</td>
<td>It smears and sprays pixels in the direction of a “push”.</td>
</tr>
<tr>
<td>Dodge/Burn</td>
<td>Shift + D</td>
<td>It lightens or darkens an image’s shadows, mid tones, or highlights.</td>
</tr>
</tbody>
</table>

Table 6.2.1.5: Paint Tools in GIMP

i) Tool Options

The most common tool options available in paint tools are as follows:

- **Mode**: The Mode drop-down list provides various application modes such as Dissolve, Hue, Behind, Soft Light, and Hard Light, supporting a variety of special effects. The Mode option is suitable for tools that aid in adding color to the image: the
Pencil, Paintbrush, Airbrush, Ink, and Clone tools. The option is usually grayed out for rest of the paint tools.

- **Opacity**: The **Opacity** option is responsible for setting the opacity of the brush stroke to be applied and hence controls the strength for brush operations in paint tools. The tool creates a transparent layer above the active layer and acts on that layer for operations.

- **Brush**: GIMP allows a user to use various kinds of brushes for all brush tools except the Ink tool. The Pencil, Paintbrush, and Airbrush tools support the use of colors in brushes and rest of the tools see intensity distribution by brushes.

- **Scale**: The **Scale** option is used to modify precisely the size of the brush.

- **Brush Dynamics**: It majorly considers three dynamics: pressure, velocity, and random to map brush parameters.

- **Rate**: This option is applicable to the Airbrush, Convolve tool, and Smudge tool, for rendering time-based effects.

- **Size**: If enabled, it increases the size of an area affected by the brush.

- **Color**: It supports higher gradient colors and is applicable to painting tools such as pencil, paint brush, air brush.

- **Fade Out**: It causes a fade out over the specified distance of a stroke and behaves equivalently to gradually reduce the opacity along the trajectory of the stroke.

- **Apply Jitter**: It controls the spacing in brush stroking to make lines continual or jittery on shaking of brush strokes.

- **Incremental**: This is selected if a user does not want to enhance color strokes while reducing opacity settings.

- **Color from Gradient**: This allows the usage of gradient color in brush strokes.

- **Hard Edge**: This places colors in a rough manner when it is applied to a selected portion of an image.

- **Source**: This determines the source of the image which needs to be copied for cloning.

- **Alignment**: This determines the relation between brush position and the source image that needs to be cloned.
The varieties of brushes (for paint tool), with following setting attributes, are available in GIMP.

◆ **Brush Size and Shape**: Selecting brush shape and size.
◆ **Spacing**: By default, it is set to 20.0.
◆ **Brush Editor**: Editing the properties of customized brushes (Aspect Ratio, Angel, Radius etc.)
◆ **New Brush**: Creates a new customized brush.
◆ **Duplicate Brush**: Create a duplicate of selected brush.
◆ **Delete Brush**: Deletes the selected brush.
◆ **Refresh Brushes**: Refreshes the view in brushes dialogue.

iii) **Key Modifiers**

The Key Modifiers associated with Paint tools are:

◆ **Ctrl**: The `ctrl` key has a special effect on every brush tool. It acts as “color picker” mode and sets the foreground to the active layer’s color for the Pencil, Paintbrush, Airbrush, Ink Tool, and Eraser tools. It switches between the reference point of copy and the actual image in the clone painting tool. For the Convolve tool, the `ctrl` key toggles blur and sharpen mode and it toggles between dodging and burning for the Dodge/Burn tool.

◆ **Shift**: Shift key renders an effect of placing the tool into straight line mode especially with brush tools. First the starting point is chosen and clicked, and then Shift key is pressed continuously to create line segments.

◆ **Ctrl + shift**: It renders the tool into constrained straight line mode to create perfect horizontal, vertical or diagonal lines over the image objects. It can be used to constrain the angle between two successive lines.

iv) **How to use paint tools?**

The steps to execute paint tools on images are listed below:

◆ **Step 1**: Click on the paint tool icon in GIMP’s toolbox. Alternatively, the paint tool could be chosen by selecting “Tools” from the program’s menu, and then clicking the desired “Paint tool”.
Step 2: To create a canvas, choose “File” and then “New” from the GIMP menu. One can also paint over an existing image. Click “File” then “Open” to open an image from the computer drive. Hold the left mouse button and drag the paint tool icon on the GIMP canvas. A small circle will occur above your mouse cursor over the GIMP canvas to create strokes of tools like pencil, brush, eraser, etc.

Step 3: The color for your paint tool could be chosen by clicking on the color box, which is located just under the tool icons on GIMP’s toolbox. The color is black by default but can be changed by clicking any of the square color samples or by adjusting the gradient sliders.

Step 4: The paint tool options could be adjusted to customize pencil, brush, eraser, etc. These options appear on the lower half of the GIMP toolbox when the paint tool is selected. Slide the “Opacity” slider to determine the translucency of the painting brush. One can adjust parameters like size, aspect ratio and angle for various paint tools. Click on the icon next to “Brush” and choose a brush shape and size that alters the shape of the stroke of paint tools on the canvas. Several other options could be set according to the chosen paint tool. For example; “Apply Jitter” is used to change the stroke of brushes from a continuous line to a broken-up, scattered line.

![Figure 6.35: Setting up canvas for using Paint Tools in GIMP](image)

A sample image is pictured in Figure 6.35. We will apply few of the paint tools on sample image and the results are demonstrated in Figure 6.35 (a-d).
Figure 6.35(a): Sample Image for applying Paint tools

Figure 6.35 (b): Illustration of Bucket Tool
1. Click and choose Pencil tool
2. Choose the color
3. Set up the brush properties like size and shapes
4. Use Pencil to write and modify the image

Figure 6.35(c): Illustration of Pencil Tool

1. Erase Image as OUTPUT
2. Set the tool options and select the brush parameters
3. Click and choose Eraser tool
4. Set the color for the eraser

Figure 6.35(d): Illustration of Eraser Tool
6.2.10 Smudging and Stamping for images

6.2.10.1 Smudge Tool

i) Introduction

Smudge tool (Figure 6.36 a), is used for smearing color pixels on a selected layer. Smudging is used to soften color transitions, make the image blurry, hide objects, and to create textures. When a smudge tool is applied on an image, it selects the available color and merges it with the other colors present on the image.

Figure 6.35(e): Illustration of Dodge Tool

Figure 6.36(a): Smudge Tool
ii) **Tool Options**

The options available with Smudge tools are (Figure 6.36 b):

Mode *(disabled)*, Opacity, Brush, Scale, Brush Dynamics, Rate, Fade out, Apply Jitter and Hard Edge

iii) **How to use the Tool**

To use smudge tool, firstly a brush type is chosen from the toolbox options and then the mouse cursor is clicked and dragged over the selected image portion (Figure 6.36c).
6.2.10.2 Stamp Tool

Stamping tool (Figure 6.37 a) is used for copying the pixels from selected portions of an image to a destination area, the user wants to cover, or for reproducing the selected portions of an image. It uses the current brush to copy from a source image. It has a variety of applications and the famous one is to repair digital pictures or images by painting them with cloned pixels from the selected area.
Tool Options

The options available with Smudge tools are (6.37 b):

- Mode (disabled), Opacity, Brush, Scale, Brush Dynamics, Rate, Fade out, Apply Jitter, Hard Edge, Source and Alignment

How to use the Tool

Stamping is done via following steps:

i) “Clone” tool from the toolbox menu is selected. Its icon is shaped like a traditional stamp.
ii) One of the brush types is selected from brush Menus in GIMP.

iii) **Ctrl** key is pressed while using mouse to click and select the area of the source image for pixel extraction.

iv) The selected pixels are applied by left click of a mouse in the destination areas.

v) The process is repeated if necessary.

In Figure 6.37 c, star brush is selected; the ctrl key is pressed over a green region of the parrot appearing in the image. The selected green pixels are stamped in the background by left clicking of the mouse.

Stamping may occur across the layers as shown in Figure 6.37 d. The image of parrot could also be cloned onto an image having a tree with the house. The brush size is set according to the size of a selection of parrot. **Ctrl** key is pressed over the image of parrot and it is released with a left click of the mouse, on the image having a tree (to clone parrot on the tree).

An interesting feature here is to explore and set up different opacity or transparency levels while cloning. If we change the opacity level, the clone stamp also changes the brush stroke intensity over the image. One cannot clone from a fully transparent source. If a user tries to clone from a partially transparent source, the effect is weighted by the opacity of the source as shown in Figure 6.37 e.

Assuming 100 % opacity and hard brush, as tool options:

1. Cloning translucent black onto white produces gray
2. Cloning translucent white onto black produces gray
3. Cloning translucent black onto black produces black
4. Cloning translucent white onto white produces white
1. Select Stamp tool

2. Select Brush Type

3. Select Pixels from parrot picture by clicking over mouse; Press Ctrl Key while clicking stamp tool

4. Release the mouse by left click and stamping the background

Figure 6.37 (c): Illustration of Stamp Tool
1. Select suitable brush type after the clone tool

2. Select Parrot picture and press Ctrl Key.

3. Release the held Ctrl Key with Left mouse click on the picture having house and a tree.

---

6.2.11 Transform Tools

Transform tools tend to modify the presentation of an image or a particular element in an image. There are 9 such tools (Figure 6.38), each having a variety of features and tool options.
The various transform tools in GIMP and their functionalities are listed in Table 6.2.1.6.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align</td>
<td>Q</td>
<td>It is used to align or arrange layers and/or other image objects.</td>
</tr>
<tr>
<td>Move</td>
<td>M</td>
<td>It is used to move layers and selections.</td>
</tr>
<tr>
<td>Crop</td>
<td>Shift + C</td>
<td>It is used to crop the image.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Shift + R</td>
<td>It rotates the selected image.</td>
</tr>
<tr>
<td>Scale</td>
<td>Shift + T</td>
<td>It scales or adjusts the size of the selected image or portion of the image.</td>
</tr>
<tr>
<td>Shear</td>
<td>Shift + S</td>
<td>It shifts part of the image in some direction.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Shift + P</td>
<td>Changes the perspective view of the current image.</td>
</tr>
<tr>
<td>Flip</td>
<td>Shift + F</td>
<td>It flips between layers and image selections.</td>
</tr>
<tr>
<td>Cage Transform</td>
<td>Shift + G</td>
<td>It deforms a selection with a cage.</td>
</tr>
</tbody>
</table>

Table 6.2.1.6: Transform Tools in GIMP

Figure 6.38: GIMP Transform Tool
GIMP offers three buttons which let the user select portion of an image on which transform tool will be applied.

- If the first button is activated, then the tool works on the active layer. If no selection exists in this layer, the whole layer will be transformed.
- If the second button is activated, then the tool works on the selection contour only (the whole layer contour if no selection).
- If the third button is activated, the tool works on the path only.

The commonly used options available in transform tools are as follows in Table 6.2.1.7.

<table>
<thead>
<tr>
<th>Align</th>
<th>Relative To: It allows modification of the edges w.r.t. the left, right, center, top, bottom and middle of the selected target by applying Selection option. The rest of the options are used to align the layer, path, and channel. Distribute: It distributes the left, right, center edges, top, bottom and middle edges of the chosen target. Offset: It sets the desired value to align the image.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td>Move: It allows the image to be transformed or moved. Tool Toggle: It allows switching from one option to another.</td>
</tr>
<tr>
<td>Crop</td>
<td>Current layer only: It is utilized only for the current layer. Allow Growing: It enables to expand beyond borders. Expand from center: It makes the picked portion bigger. Fixed: It may alter the predefined shape of the rectangle. Position: It acts as the placement of the selection. Size: It lists the length/size of the selection. Highlight: It highlights the marked selection, by darkening everything that lies in the background of the image. Guides: It chooses the types of guides available within the marked portion. Auto Shrink: It minimizes the size of the selection.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Direction: It enables turning an image either in the Normal or Corrective manner. 1) Normal → Rotates the image in the forward position. 2) Corrective → Rotates the image in the opposite direction i.e. towards backward, against the option set in the box. Interpolation: It aids in curving the image and choosing the quality of transformation. It takes samples from a grid of pixels from known image areas, and then fits the curve. Clipping: It clips the transformed image to the original image.</td>
</tr>
</tbody>
</table>
**Preview**: It helps a user to see the preview of an image. The subsidiary options available are Outline, Image, and Grid. The Image and Grid can be used together in an image and viewed or else just the outline/image option can be seen separately.

**Opacity**: It makes the background of an image to be unclear or vague when the image is filled with color.

**A number of grid lines**: We set the Grid option in the preview to enable this option. This option lists the Grids which are placed on the image while making changes.

**15 degrees**: This is a default option to turn an image by 15 degrees.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale</td>
<td>Same as options in “Rotate” except “15 degrees” option is not available in Scale.</td>
</tr>
<tr>
<td></td>
<td><strong>Keep Aspect</strong>: This option can be made as default using the Ctrl button.</td>
</tr>
<tr>
<td>Shear</td>
<td>Same as options in “Rotate” except “15 degrees” option is not available in “Shear”.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Same as options in “Rotate” except “15 degrees” option is not available in “Perspective”.</td>
</tr>
<tr>
<td>Flip</td>
<td><strong>Horizontal</strong>: It turns the image to horizontal position.</td>
</tr>
<tr>
<td></td>
<td><strong>Vertical</strong>: It turns the image to a vertical position.</td>
</tr>
<tr>
<td></td>
<td>* Shift button is used to switch between the tools available under the Flip.</td>
</tr>
<tr>
<td>Cage</td>
<td>Create or adjust the cage.</td>
</tr>
<tr>
<td>Transform</td>
<td>Deform the cage to deform the image.</td>
</tr>
<tr>
<td></td>
<td>Fill the original position of the cage with plain color.</td>
</tr>
</tbody>
</table>

*Table 6.2.17: Options available with Transform Tools in GIMP*

### 6.2.11.1 How to Use Crop Transformation?

The steps for using “Crop” transformation are listed as follows.

1. Go to Transform Tools ➔ Crop
2. To simply crop an image, just select the required portion in the image.
3. Click the left mouse button on the image, the cursor turns into plus symbol and now select the portion.
4. Press “Enter”
5. The image gets cropped.
“Rotate” transformation is shown in Figure 6.40.
An example of applying transformation with “Scale”, “Shear” etc. options is illustrated in Figure 6.41 a-b.
6.2.12 How to change the perspective/View of an image?

The Perspective of an image can be modified to either forward or backward direction. By default, the direction is set to be the forward direction.

1. Go to Transform Tools → Perspective and the following Perspective box gets displayed.

2. On clicking any portion of the image, the selection outline is displayed. A plus sign appears. Click it and drag the outline to change the borders of the outline.
3. After altering the outline, just click the Transform button in the “Perspective” box.
4. Image is transformed and new Perspective matrix is displayed.

![Image of Perspective Transformation on an Image]

**Figure 6.43: The Perspective Transformation on an Image**

### 6.2.13 The Cage Transformation Tool

It allows selecting an area of an image, just like a **Free Select Lasso tool** with the help of anchor points. The anchor points create a cage-like structure around the image and when it is closed, one can use it to transform/deform an image by dragging the points in the desired shape of deformation. The image appears in a deformed manner after pressing “**Enter**” key.

![Image of Cage Transformation on an Image]

**Figure 6.44 (a): Applying Cage Transformation on an Image**
The Align, Move and Flip options in transformation tools could be explored by students in GIMP Editor.

6.2.14 Color Tools

The color tools are used to manipulate colors of images in several ways. They are listed in Table 6.2.1.8.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Color Balance" /></td>
<td>Color Balance</td>
<td>It modifies and maintains the color balance of the current image by adjusting color levels of cyan, magenta, yellow and ranges of red, green and blue.</td>
</tr>
<tr>
<td><img src="image" alt="Hue-Saturation" /></td>
<td>Hue-Saturation</td>
<td>It adjusts hue, saturation, and lightness of the current image.</td>
</tr>
<tr>
<td><img src="image" alt="Colorize" /></td>
<td>Colorize</td>
<td>It renders an image into a greyscale image seen through the colored glass.</td>
</tr>
</tbody>
</table>
Brightness-Contrast | It adjusts brightness and contrast.
---|---
Threshold | It transforms the image into a black and white image.
Levels | It adjusts the intensity range w.r.t. the image in every channel.
Curves | It modifies the color, brightness, contrast or transparency of the image.
Posterize | It tends to reduce the number of colors.
Desaturate | It converts all color pixels to gray shades.

| **Table 6.2.1.8: Color tools in GIMP** |

These are accessible through Color Menu also.
The color tools except “Desaturate” and “Posterize” have preset. The presets are saved tool settings which can be retrieved later (Figure 6.47). The features of Hue, Saturation, and Lightness w.r.t color adjustments could be set with the help of sliders in colorizing the image.

Some color tools are demonstrated in following Figure 6.48 a-d.
Figure 6.48 (a): Color Adjustment with Curves

Figure 6.48 (b): Adjustment with color levels
Colors of images could also be manipulated from Colors pallet. Some more options like Color to Alpha that converts specific color to transparency, Maximize RGB (Reduces image to Red, Green and Blue composition), Info, Map, and Filer Pack are also available in Colors Menu for changing color composition.
6.2.15 Path tool for Drawing

It is used to create paths which can be edited and may be shifted anywhere in the file. The tool options with path tool are listed in Figure 6.49.

A step by step procedure to create a polygon using the path tool is as follows (Figure 6.50):

i) Set **Design** and **Polygonal** options in the toolbox.

ii) Draw the path lines for polygon shape with the rider.

iii) Use any of the two options available to create a path: Selection from path or Stroke path.

iv) Save the file.
Figure 6.50: Using Path Tool in GIMP
### 6.2.16 Other tools

The other miscellaneous tools in GIMP are listed in Table 6.2.1.9.

<table>
<thead>
<tr>
<th>Color Picker</th>
<th>Zoom</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Color Picker Tool is used to select a color from an image opened on the screen, by clicking on the particular color of the image. Both the foreground and background color can be selected by this tool.</td>
<td>The Zoom Tool enables the user to expand or compress the entire portion or the selected part of an image. A user can simply click the Plus &amp; Minus button to increase and decrease the image.</td>
</tr>
</tbody>
</table>

**Tool Options:**

- **Color Picker**
  - Sample average
  - Sample merged
  - Pick Mode (Ctrl)
  - Pick only
  - Set foreground color
  - Set background color
  - Add to palette
  - Use info window (Shift)

- **Zoom**
  - Auto-resize window
  - Tool Toggle (Ctrl)
  - Zoom in
  - Zoom out

<table>
<thead>
<tr>
<th>Measure</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>It calculates the distance, angle, height, and width of the selected portion of the image. It is used to see the measurement information of the selected part of the image.</td>
<td>It is used to create or edit text layer over images.</td>
</tr>
</tbody>
</table>
These tools may further be explored practically.

### 6.3 Creating and Editing Images

Now that, we have studied the basics of the Tool Box, let’s take a tour of Image Menu that forms part of GIMP interface.
Image menu supports various operations for image manipulations as listed in Figure 6.51. We may create a new image or open an existing image for manipulation which was described in section 1.

### 6.3.1 Creating Images in GIMP

Let's explore how to create an image in GIMP. We create a sample image of the rectangular window giving a view of moon and stars. For creating images, we need to use File Menu and Edit Menu. A step by step procedure for creating a sample image is illustrated below (Figure 6.52 a-j).

1. **Open-File Tab.**

![GIMP File Menus](image-url)
ii) Choose and click on “New” option.

![Create a New Image dialog box](image1)

Figure 6.52(b): Opening New File in GIMP

iii) A new image window will open.

A user can click on “Create” tab if the source of image creation is known, for example, clipboard, webpage, camera, buttons, and logos.

![Create New Image in GIMP](image2)

Figure 6.52 (c): Creating New Image in GIMP
iv) Let’s create an image by applying rectangular selection manually.

![Figure 6.52 (d): Creating Rectangular Selection in GIMP](image)

v) Draw a thick line around the selection using Edit → Stroke Selection.

![Figure 6.52 (e): Making Black Line in the Shape of Selection](image)
vi) Use paint tool brushes to draw stars and moon effect.
Figure 6.52 (h): Drawing Moon in Selected Window with Paint tool in GIMP

Figure 6.52 (i): Saving the created image in GIMP
vii) Save the created image.

viii) The image so created is saved in the desired folder and may be opened for further processing.

![Figure 6.52 (j): Final version of the Image created in GIMP](image)

The above-discussed procedure is one only of different ways in which an image could be created in GIMP. File Menu plays an important role for handling images such as opening an image file, exporting images, setting page, saving a file, printing, and closing files. Another sample for creating clouds in the sky is demonstrated below.

i) Open a new File to create an image

![Figure 6.53 (a): Opening a New File](image)
ii) Select a gradient to fill the background.

![Figure 6.53 (b): Selecting a gradient](image)

iii) Use Dodge tool to draw the clouds and smudge tool may be used to give the little hazy appearance.

![Figure 6.53 (c): Creating Clouds](image)
Let’s now create a sample smiley face in GIMP (Figure 6.54 a-f).

i) Create a new File.

ii) Create a face outline by using “Eclipse” as a selection tool.
iii) Stroke the eclipse boundary (Edit → Stroke Selection).

![Figure 6.54 (c): Face outline after Stroke Selection]

iv) Make eyes and nose of smiley with a paint brush.

![Figure 6.54 (d): Completing the face of smiley with paint brush]
v) Let’s make mouth with path tool (Tools → Path)

Figure 6.54 (e): Completing the face of smiley with path tool

vi) Stroke the made path (Edit → Stroke Path)

Figure 6.54 (f): Output Image after path stroke
An image dialogue window supports various functionalities for image editing (Table 6.2.1.10).

<table>
<thead>
<tr>
<th>Name of the Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate</td>
<td>It creates a duplicate image.</td>
</tr>
<tr>
<td>Mode</td>
<td>It sets an image mode to RGB, Grayscale, Indexed, Assign Color Profile, and Convert to color profile.</td>
</tr>
<tr>
<td>Transform</td>
<td>It transforms an image by either flipping horizontally or vertically or by rotating 90 degrees (clockwise/counterclockwise) or by 180 degrees.</td>
</tr>
<tr>
<td>Canvas size</td>
<td>It adjusts the size of the image by setting image dimensions.</td>
</tr>
<tr>
<td>Fit Canvas to layers</td>
<td>It sets image size to enclose all layers.</td>
</tr>
<tr>
<td>Fit Canvas to Selection</td>
<td>It resizes an image to the extents of selection.</td>
</tr>
<tr>
<td>Print Size</td>
<td>It sets print resolution.</td>
</tr>
<tr>
<td>Scale Image</td>
<td>It changes the size of image content</td>
</tr>
<tr>
<td>Crop Image</td>
<td>It crops an image with the help of extents of a selection.</td>
</tr>
<tr>
<td>Auto-Crop Image</td>
<td>It removes empty borders from an image.</td>
</tr>
<tr>
<td>Zealous Crop</td>
<td>It removes unused space from an image.</td>
</tr>
<tr>
<td>Merge visible layers, Flatten image, Align Visible layers</td>
<td>These options are used for merging and aligning multiple layers of images.</td>
</tr>
</tbody>
</table>
Table 6.2.1.10: Image tool features in GIMP

The use of various image menu features is demonstrated in Figure 6.55.

Figure 6.55 (a): Duplicating an image in GIMP by Image → Duplicate or pressing Ctrl+D
Figure 6.55 (b): Transforming an image in GIMP by rotating by 180 degrees

Figure 6.55 (c): Cropping an image in GIMP by Selection
6.3.2 Editing Images

The commonly used functionalities related to image editing are cut, copy, paste, foreground, background color, pattern, and stroke selection as shown in Figure 6.56.

![Image Editing features in GIMP](image.png)

Figure 6.55 (c): Viewing Image Properties in GIMP
6.3.2.1 Cut, Copy & Paste

- Open Gimp Image Window
- Select a portion in the image using rectangle/eclipse/free select
- Choose “Cut or Copy” option, to cut or copy the image
- Click Edit ➔ Paste [Paste simply pastes the image. The Paste Into option pastes the image over the existing image and pasted image may be moved later. The Paste as option renders four more options (New Image, New Layer, New Brush, and New Pattern), to paste the image in various styles.]

6.3.2.2 Foreground Color

It fills the image with the default foreground color. A user may select any part of an image and fill it with the foreground color by following the steps given below:

- Open Gimp Image Window
- Select a portion in the image using rectangle/eclipse/free select
- Edit ➔ Fill with FG color
- File ➔ save

6.3.2.3 Background Color

It fills the image with the default background color. A user may select any part of an image and fill it with the background color.

- Open Gimp Image Window
- Select a portion in the image using rectangle/eclipse/free select
- Edit ➔ Fill with BG color
- File ➔ save

6.3.2.4 Fill with Pattern

It fills the image with any of the patterns available in GIMP (Figure 6.57).
A user may select any part of an image and fill it with the desired pattern by following the steps given below:

- Open Gimp Image Window
- Select a portion in the image using rectangle/eclipse/free select
- Edit ➞ Fill with pattern
- File ➞ save

**6.3.2.5 Stroke Selection**

It aids in striking the selected portion of the image. The steps are as follows:

- Open Gimp Image Window
- Select a portion in the image using rectangle/eclipse/free select
- Edit ➞ Stroke selection
- File ➞ save
The Antialiasing option softens the curved strokes drawn over an image and makes it smoother.

**6.3.2.6 Stroke with Paint Tool**

It aids in striking the selected portion of the image using the available paint tools (Figure 6.58, discussed in section 6.2.1) in GIMP. The steps are as follows:
Open Gimp Image Window
Select a portion in the image using rectangle/eclipse/free select
Edit ➔ Stroke with Paint tool
File ➔ save

Figure 6.59: Available Paint Tools

6.3.2.7 Preferences

Preferences tab in GIMP allows adjustment features like configuring keyboard shortcuts, enabling previews, maintaining interfaces, calibrating monitors, editing window appearances, and doing color management. It supports the following options:

i) Customize Environment: It enables a user to modify and set the amount of system memory allocated for various purposes.

ii) User Interface: It enables a user to set the layer or channel previews and keyboard shortcuts in GIMP.

iii) Change theme: It enables a user to select a theme which determines the appearance of GIMP.

iv) Modify Help System: It helps a user to modify help feature of GIMP.

v) Customize Tool Options: It lets a user change the way the tools function in GIMP.
vi) Customize toolbox appearance: It enables a user to modify the appearance of the Toolbox.

vii) Customize Default Image size: It enables a user to customize the default image size. The user can alter the default screen size in the “Default New Image” dialog box.

viii) Configure Default Image Grid: It allows altering the default properties of GIMP grid. This feature is enabled using View ➔ Show Grid from the image menu.

ix) Change Image Window: It enables a user to change and set features related to Mouse Pointer, Space Bar, Zoom, and Resize effects of an image.

x) Set Display Mode: It enables a user to set the display modes for customizing the visible/transparent portion of an image.

xi) Color Management: It enables a user to modify the features of GIMP’s Color Profile.

xii) Configure Input Devices: It enables a user to manage and control the input devices connected to your computer system.

xiii) Configure Window Management: It allows a user to customize the appearance of various windows in GIMP.

xiv) Folder Options: It enables a user to change and set new location/path for two main folders utilized by GIMP to store the temporary files.

![Figure 6.60: Preferences in GIMP](image)
6.4 Applying Filters

Gimp has various powerful graphical features and may render diversified effects or textures to images. A filter tool (Filters) in GIMP is one such special plug-in feature that may modify the image appearance on the current layer by running algorithms. These algorithms support activities like inserting lightening effects on the image, distorting an image etc. and generate a modified image. There is a variety of effects within filters tool as shown in Figure 6.61.

![Figure 6.61: The Filters available in GIMP](image)

6.4.1 A Step by Step Procedure for applying Filters

The steps for filter application are as follows:

i) Open GIMP and load/create an image with objects on which you want to apply a filter.

ii) Select a portion of the image (if we want to apply the filter on a portion of the image).

iii) Click on Filters tab and choose any filter tool.

iv) Adjust settings.

v) See the preview and Click OK when satisfied.

vi) Export or save the image.
6.4.2 Various Filter Tools

A set of various filters that provide special effects for active images is illustrated as follows.

6.4.2.1 Blur Filter

It provides a set of filters (Table 6.2.1.11, Figure 6.62 a) to make a whole image or a part of an image blurry with various parameter settings like defining magnitude or type of blurring.

Figure 6.62 (a): Blur Effects

<table>
<thead>
<tr>
<th>Blur Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blur</td>
<td>It softens the primary focus of an image and blurs the image a little. The stronger blur effect could be achieved by repeatedly applying blur effect on an image or by using Gaussian Blur.</td>
</tr>
<tr>
<td>Gaussian Blur</td>
<td>It is an effective blur tool that performs in relatively short span of time by allowing a user to vary the dimensions and magnitude of blurring. It considers the average of all pixel values occurring in defined area of interest in an image. It supports two methods: IIR (infinite impulsive response for photographic/scanned images), suitable for images having a large radius or for non-computer generated images like photographs and RLE (Run-length coding for computer generated images), suitable for computer-generated images or those with large areas of constant intensity, such as logos.</td>
</tr>
</tbody>
</table>
Blur Effect | Purpose
--- | ---
Motion Blur | It creates motion effects in a particular direction with Linear, Radial or Zoom movements which could be enhanced with length (1-256) and angle (0-360) settings.

Pixelize | It is known as Abraham Lincoln Effect and converts an image into an array of solid squares. The similar concept is used many times in identity masking. Pixel width and height of the color blocks of an image could be set by the user.

Selective Gaussian Blur | It is used to enhance the depth of an image. It doesn't consider all the pixel values of an image rather it applies blur effect only if the difference between current value and value of surrounding pixels is less than some threshold delta i.e. it sets up a threshold to blur all the pixels similar to each other.

A good example of this kind of filter is to highlight the foreground and making background blur so that the foreground is enhanced and highlighted.

It sets Blur radius (Blur intensity) and Max Delta (the difference between the pixel value and the surrounding ones in the range [0-255]).

Tileable Gaussian Blur | It merges, blurs, and wraps the borders of an image making it appear like a tiling concept. It reduces edge effects. Blur vertically or horizontally options could be set, besides radius and type of blur regions.

Table 6.2.1.11: BLUR Effects/Filters in GIMP

The three most commonly used Blur filters are illustrated in Figure 6.62 (b-d).

![Blurred Image](image-url)

Figure 6.62 (b): Applying Gaussian Blur filter
Radial Motion Blurred Image

Figure 6.62 (c): Applying Radial Motion Blur filter

Figure 6.62 (d): Applying Pixelize filter
The rest of the blur filters could be experimented with various options to see the blurriness effects.

### 6.4.2.2 Enhance Filter

It is used to remove image imperfections such as noise distortion (possibly caused due to dust particles), inappropriate sharpness, and intermixed frames.

<table>
<thead>
<tr>
<th>Enhance Filters</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Antialias</strong></td>
<td>It smoothes the edges by removing artifacts from an image while converting it to a comparatively lower resolution.</td>
</tr>
<tr>
<td><strong>Deinterlace</strong></td>
<td>It removes extra and undesired image information from interlaced image frames. It does have an option for keeping odd and even fields of image interlacing.</td>
</tr>
<tr>
<td><strong>Despeckle</strong></td>
<td>It removes small defects such as noise particles from the current image area. Median could be set to <em>Adaptive</em> which works by analyzing the histogram of the surrounding region of selected image or <em>Recursive</em> which renders repeated actions for an image enhancement. Radius size could be set to remove imperfections. There also exists an option to set Black level and White level for brighter and darker pixels of the image. A user can select and drag the “Black Level” or “White Level” slider left and right until he/she reaches the point at which GIMP removes unwanted pixels without affecting the rest of the image.</td>
</tr>
<tr>
<td><strong>Destripe</strong></td>
<td>It removes the vertical stripes in an image, caused by poor quality scanners. It works by adding a pattern which interferes with the image to remove strips. The strength of the filter is set using “Width” option, available with this filter.</td>
</tr>
<tr>
<td><strong>NL (Non-Linear) Filter</strong></td>
<td>It combines <em>Despeckle, Sharpen,</em> and <em>Smooth enhancement</em> functions to improve the appearance of focus on the entire image, not on any particular selection.</td>
</tr>
<tr>
<td><strong>Red Eye Removal</strong></td>
<td>It performs red-eye corrections. It may set threshold parameter to eliminate the amount of red eye color.</td>
</tr>
<tr>
<td>Enhance Filters</td>
<td>Purpose</td>
</tr>
<tr>
<td>----------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>Sharpen</strong></td>
<td>It is useful for correction of sharpness in digitized images by accentuating edges and any kind of noise. It allows a user to set sharpness for the image and preview it.</td>
</tr>
<tr>
<td><strong>UnSharp Mask</strong></td>
<td>It sharpens the image without increasing noise. It allows a user to select where sharpening is required and with what strength via <strong>Radius, Amount, and Threshold parameters</strong>.</td>
</tr>
</tbody>
</table>

*Table 6.2.1.12: Enhance Effects/Filters in GIMP*

*Figure 6.63 (a): Enhance Effects*
6.4.2.3 Distorts Filter

These filters may transform the shape of an image in several ways (Table 6.2.1.13, Figure 6.64):

<table>
<thead>
<tr>
<th>Enhance Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Apply Lens</strong></td>
<td>It renders an elliptical lens over the image.</td>
</tr>
<tr>
<td><strong>Blinds</strong></td>
<td>It skews the input image to sections by generating a blind effect with horizontal or vertical line battens. These battens may be closed or open. It is supplemented by an option of setting displacement (for angle settings) and a number of segments.</td>
</tr>
<tr>
<td><strong>Curve bend</strong></td>
<td>It is useful for changing the shape of any layer and usually simulates by setting up the bending curve to distort an image. The distortion is applied gradually from an image or selection border to the other in layers. Curve bending may be controlled by available option settings. One can adjust the top of the layer by setting upper and bottom by clicking on lower. Mirror will give a lower curve as the mirror image of the upper curve and Swap will exchange lower and upper curves. Reset will flatten to the original image.</td>
</tr>
<tr>
<td><strong>Emboss</strong></td>
<td>It simulates embossing on the image. It sets azimuth (lighting component), elevation and depth of an image using option settings.</td>
</tr>
<tr>
<td>Enhance Effect</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Engrave</strong></td>
<td>It produces an engraving effect, like one found on coins. The image is simulated with black and white horizontal lines of varying height based on the value of underlying pixels.</td>
</tr>
<tr>
<td><strong>Erase Every Other row</strong></td>
<td>It erases row and columns by changing them to the background color.</td>
</tr>
<tr>
<td><strong>IWarp</strong></td>
<td>It is useful for deforming some parts of the image interactively with mouse control.</td>
</tr>
<tr>
<td><strong>Lens Distortion</strong></td>
<td>It allows correcting distortion effect occurred due to the camera lens.</td>
</tr>
<tr>
<td><strong>Mosaic</strong></td>
<td>It cuts the image into various squares or polygons tiles which are slightly raised and are joined with each other, thus giving an appearance of mosaic. It allows option setting like Tile size, Height, Direction, Color Variation etc.</td>
</tr>
<tr>
<td><strong>News Print</strong></td>
<td>It simulates Newspaper like appearance.</td>
</tr>
<tr>
<td><strong>PageCurl</strong></td>
<td>It curls up the image corners.</td>
</tr>
<tr>
<td><strong>Polar Coordinates</strong></td>
<td>It gives a circular or a rectangular representation of the image with all the possible polar coordinates and intermediates.</td>
</tr>
<tr>
<td><strong>Ripple</strong></td>
<td>It displaces pixel in ripple pattern. It has various options like Edges, Orientation, and Wrap Type.</td>
</tr>
<tr>
<td><strong>Shift</strong></td>
<td>It shifts pixels rows horizontally or vertically.</td>
</tr>
<tr>
<td><strong>Value Propagate</strong></td>
<td>It works on color borders by spreading pixels that differ in a specified way from their neighboring pixels and setting mode and propagate options.</td>
</tr>
<tr>
<td><strong>Video</strong></td>
<td>It simulates distortion produced by low-resolution monitors.</td>
</tr>
<tr>
<td><strong>Waves, Whirl, and Pinch, Wind</strong></td>
<td>It distorts an image with waves, whirling and pinching and wind-blow effects.</td>
</tr>
</tbody>
</table>

Table 6.2.1.13: Distortion Effects/Filters in GIMP
6.4.2.4 Light and Shadow Filters

These filters render various kinds of illuminations or shadows on the current image. The basic filters are listed in Table 6.2.1.14.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gradient &amp; Lens Flare</td>
<td>They simulate the sun like flares in images by putting a lens like effects in gradients.</td>
</tr>
<tr>
<td>Lighting Effects</td>
<td>Lighting Effects is a powerful tool for creating effects similar to of studio lighting. One application of such tool is to put spot lights to emphasize certain parts of the image. The basic settings consider both directional lights and point lights. Other settings include precise positioning and glowing settings, intensity settings, and bump &amp; environment map settings.</td>
</tr>
</tbody>
</table>
Sparkle | It creates a sparkle-like effect by using a sequence of tiny flare effects for highlighting areas of the current image. This tool has options for adjusting the threshold, intensity, spike length, points, and angle direction with hue, saturation, and transparency.

Supernova | Supernova tries to create a flare with long lines of light that originate from the center. The predominant settings available in this filter are color, the radius of the center, the number of rays or spokes, and a random hue setting that generates a rainbow kind of effect in the light rays.

Table 6.2.1.14: Light and Shadow Filters in GIMP

Gimp also supports the following functionality:

i) Drop **Shadow** effect, which renders a drop shadow behind any selected region/element (any picture/text), of a GIMP image. It has settings to configure the shadow’s position and color to meet the required specifications.

ii) The **Perspective shadow** which renders a perspective shadow to a selected region (i.e. it adjusts light to render a new point of view and aids in changing the aspect of the input image). One may select a color, length, and direction of the shadow as well as the distance from the horizon.

iii) **Each Effect** to apply the 3D effect to a selected region of an image.

The following image (Figure 6.65), is taken as input to apply the succeeding filters.

![Figure 6.65: An input image for Lighting, Noise, and Edge Detection Filters](image)
The basic Lighting filter effects are illustrated in Figure 6.66 (a, b, c, d).
Figure 6.66: Gradient Flare Effects
Figure 6.67 (a): Gradient Flare Effects

Figure 6.67 (b): Lighting Effects
Figure 6.67 (c): Supernova Effect

Figure 6.67 (d): Sparkle Effect

Figure 6.67 (a, b, c, d) Lighting Effects in GIMP
6.4.2.5 Noise Filters

Noise filters add noisy pixels/disturbance to the current image. “HSV noise” creates disturbances in hue, saturation or luminosity value of an image under consideration. “Hurl” as a Noise filter, adds random pixels to the image, making it look disturbed. “Slur” makes a ragged edge to all of the elements in an image by sliding the pixels downwards. “Pick” interchanges few of the pixels with neighboring ones. RGB noise behaves as “Hurl”, besides it also allows selecting pixel colors. The “Spread” works by swapping pixel in one place with a randomly chosen pixel from another source considering color transitions. The Figure 6.68 (a, b, c) demonstrates the application of various noise filters.

a) HSV Noise

![HSV Noise Filter Interface](image)
b) Random Hurl, Slur, and Pick
6.4.2.6 Edge Detection Filters

GIMP also renders edge-detecting filters for searching boundaries between various colors of an image based on gradient calculus methods. One of the famous tools is Difference of Gaussians, which can detect salient details of a photographed figure with an important feature of controlling edge thickness. “Edge” detects edge boundaries. “Neon” simulates the glowing boundary on edges, “Laplace” detects high-resolution edges and “Sobel” simulates direction dependent edge detection (Figure 6.69).
6.4.2.7 Generic Filters

Generic Filters are divided into three main categories:

i) Convolution matrix: It is meant for studying a pixel value of an image by working on mathematical algorithms. A matrix of pixels corresponding to an existing image is enhanced with an extra matrix (kernel matrix), for the effect to be emphasized in the existing image. This filter multiplies each pixel of an existing image with kernel matrix image value, to produce the resultant value.

For example,

```
a b c d e
f g h i j
k l m n o
p q r s t
u v w x y
```

```
1 2 3
4 5 6
7 8 9
```
Final Value after applying enhancement by multiplying with enhancement/Kernel matrix is: $g \times 1 + h \times 2 + i \times 3 + j \times 4 + m \times 5 + \ldots \ldots \ldots \ldots s \times 9$.

ii) **Dilate Filter**: It detects lighter areas of an image to widen and enhance them.

![Dilate Filter Diagram]

iii) **Erode Filter**: It decreases the size of lighter areas in an image.

![Erode Filter Diagram]

**6.4.2.8 Combine Filter**

It groups different images of the same size to a single image by:

i) **Depth Merge**: It combines two images by comparing and joining depth map of each image. It is best suitable for black, gray or white scale images.

ii) **Filmstrip**: It combines layers in the image into a single image that seems like a 35mm film strip.

**6.4.2.9 Artistic Filters**

These filters enhance the image with impressionist work of art such as sketches, paintings, making cartoons etc.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Apply canvas</strong></td>
<td>It renders canvas texture to an image.</td>
</tr>
<tr>
<td><strong>Cartoon</strong></td>
<td>It renders cartoon version of an image. This filter has functionality to adjust the “Mask” and “Percent” sliders in the Cartoon window to modify the photo.</td>
</tr>
<tr>
<td><strong>Clothify</strong></td>
<td>It renders a cloth-like texture to an image</td>
</tr>
<tr>
<td><strong>Cubism</strong></td>
<td>It converts an image to cubic art. Cubic art is a form of modern painting.</td>
</tr>
<tr>
<td><strong>GIMPressionist</strong></td>
<td>It performs artistic operations on an image.</td>
</tr>
<tr>
<td><strong>GlassTile</strong></td>
<td>It renders a simulation of distortion caused by glass tiles.</td>
</tr>
<tr>
<td><strong>Oilify</strong></td>
<td>It renders an oil painting effect via smearing colors.</td>
</tr>
<tr>
<td><strong>Photocopy</strong></td>
<td>It makes the image appear as the output of a copier machine with overdone edges.</td>
</tr>
<tr>
<td><strong>Predator</strong></td>
<td>It renders a predator effect to an image (i.e. it reduces image into few basic colors on a dark background).</td>
</tr>
<tr>
<td><strong>Softglow</strong></td>
<td>It renders an effect that makes a photo softly blurred and overexposed. This filter allows the user to alter the glow radius (i.e. effect spreads), the brightness and sharpness (level of detailing in the image).</td>
</tr>
<tr>
<td><strong>Weave</strong></td>
<td>It renders a knitted texture like of woven bucket.</td>
</tr>
<tr>
<td><strong>Van Gogh</strong></td>
<td>It renders an effect based on the mathematical operation of Line Integral Convolution.</td>
</tr>
</tbody>
</table>

**Table 6.2.1.15: Artistic Filters in GIMP**

Various kinds of Artistic filters are depicted in Figure 6.70.
6.4.2.10 Décor Filters

This filter provides borders to the selected image. The three main filters under this category are as follows:

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Bevel</td>
<td>It adds a bevel to the current image.</td>
</tr>
<tr>
<td>Add Border</td>
<td>It adds borders to the current image.</td>
</tr>
<tr>
<td>Round Corners</td>
<td>It makes corners of the current image smoother by curving them.</td>
</tr>
</tbody>
</table>

Table 6.2.1.16: Décor Filters in GIMP
The two filters: Add Border and Round Coroners are illustrated in Figure 6.72.

Original Image for décor, Map and Render Filters

Figure 6.71
Under “Décor” there are various features filters like Coffee stain, Fuzzy Border, Old Photo, Slide that you may like to explore.

6.4.2.11 Map Filter

Map filters simulate 3D effects in an image by mapping the image into an object. It has the collection of various filters listed in Table 6.2.1.17 (illustrated in Figure 6.73)

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bump Map</td>
<td>It renders an embossing effect.</td>
</tr>
<tr>
<td>Displace</td>
<td>It displaces pixels according to maps.</td>
</tr>
<tr>
<td>Fractal Trace</td>
<td>It transforms image with Mandelbrot fractal.</td>
</tr>
<tr>
<td>Illusion</td>
<td>It superimposes the altered copies of an image.</td>
</tr>
<tr>
<td>Make Seamless</td>
<td>It makes an image seamlessly tileable.</td>
</tr>
<tr>
<td>Paper tile</td>
<td>It cuts and breaks the image into the paper tile-like structure.</td>
</tr>
</tbody>
</table>

Table 6.2.1.17: Map Filters in GIMP
The other three useful filters: “Tile”, “Small Tiles”, “Warp” are also available for applying the 3D Tile effects.

6.4.2.12 Render Filters

This class of filters behaves differently, as they may overwrite a current layer by applying the effect from scratch. It is, therefore, safe to duplicate layer while working with these filters. It has various filters as listed in Table 6.2.1.18.

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Clouds</strong></td>
<td>Difference Clouds: It adds Difference layer Mode in cloud-like areas. Fog: It adds Layer of Fog. Plasma: It generates colorful clouds which can be used for textures. Solid Noise: It adds random gray smoky cloud textures.</td>
</tr>
<tr>
<td><strong>Nature</strong></td>
<td>Flame: It creates cosmic recursive frames. IFS: It is Iterated Function System to create organic shapes.</td>
</tr>
</tbody>
</table>
### Table 6.2.1.18: Render Filters in GIMP

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Patterns</td>
<td>It renders various patterns to images from check-board, grid, jigsaw, maze, qbist, Sinus, CML explorer and diffraction patterns.</td>
</tr>
<tr>
<td>Circuit</td>
<td>It superimposes image with traces of circuit boards like pattern.</td>
</tr>
<tr>
<td>Gfig</td>
<td>It renders geometric shapes and scales.</td>
</tr>
<tr>
<td>Lava</td>
<td>It fills the image with lava effects.</td>
</tr>
<tr>
<td>Line Nova</td>
<td>It uses foreground color to generate rays from the center, spreading in an outward direction.</td>
</tr>
<tr>
<td>Sphere Designer</td>
<td>It adds sphere like texture to the current image.</td>
</tr>
<tr>
<td>Spyrogimp</td>
<td>It adds Spiro-graph curves to the current image.</td>
</tr>
</tbody>
</table>

**Figure 6.74: Illustrations of few of the Render Filters in GIMP**

**6.4.2.13 Web Filters**

The web filters support the use of images in Web pages. They are mainly of three kinds: i. **“Image Map”**, which runs a javascript engine and allows the user to quickly divide the image and creates a hyperlink kind of area; where a user can click and reach the various
links, ii. “Semi-Flatten” renders semitransparent levels with the background color. “Slice” generates tiled table of the current image for use in Web pages.

6.4.2.14 Animation

Animation filter renders a sequence of images, with timing information attached to each frame of the image. The GIMP considers each layer in an image as an animation frame. It supports the conversion of layered images to Indexed format and outputs as GIF files. It has the following emphasizing effects:

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blend</td>
<td>It creates an intermediate layer to blend two or more image frames over the background.</td>
</tr>
<tr>
<td>Rippling</td>
<td>It applies Ripple effect to the current image to create a multi-layer effect.</td>
</tr>
<tr>
<td>Spinning Globe</td>
<td>It creates an animation via spinning sphere effect.</td>
</tr>
<tr>
<td>Waves</td>
<td>It creates an animation via an effect which appears as if the stone was thrown on the image. One can choose the number of frames required for animation. The amplitude and wavelength for the animation could be adjusted.</td>
</tr>
<tr>
<td>Optimize Difference &amp; GIF</td>
<td>They help in reducing the size of animation via optimization (reducing the size of layers by saving only the changes made with time in layers instead of saving again the whole image).</td>
</tr>
</tbody>
</table>

Table 6.2.1.19: Animation Filters in GIMP

When applying animation is finished, one will see a still image of the effect, in the image window. But to view the animated effect, FILTERS/ANIMATION and PLAYBACK option may be selected.

The steps to make a sample wave animation in GIMP are listed below:

i) Open an image file in GIMP.

ii) Under the FILTERS menu, select ANIMATION and WAVES to open the waves control panel. A user can choose a number of frames for the animation.
iii) Adjust the amplitude and wavelength for the animation which may change the nature of the wave.

iv) The program will begin rendering on click of an OK button. When it is finished a user can see a still image of the effect (GIF).

v) To view the animation, choose FILTERS/ANIMATION and PLAYBACK.

vi) The text could be added and its color, font and others factor could be adjusted.

vii) The image is now the way we want it, the text being in the proper place for the final frame.

viii) SAVE AS from the FILE menu is used to save the animation. The animation is saved as GIF animation and, therefore, selects GIF from the file type menu.

ix) The animated image could be exported for future references.

6.4.2.15 Alpha to Logo

This filter is useful in the creation of logos and also in adding special effects to alpha channels that represent the degree of transparency of the color (majorly red, green and blue channels) in an image. Alpha channels define transparent areas. The various effects in this filter are listed below:

<table>
<thead>
<tr>
<th>Effect</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>3D Outline</strong></td>
<td>It outlines the non-transparent areas of the active layer and adds a drop shadow.</td>
</tr>
<tr>
<td><strong>Alien Glow</strong></td>
<td>It adds an eerie glow to the image.</td>
</tr>
<tr>
<td><strong>Alien Neon</strong></td>
<td>It adds psychedelic outlines to the image.</td>
</tr>
<tr>
<td><strong>Basic I and II</strong></td>
<td>They add gradient effect, drop shadow and highlighting effects.</td>
</tr>
<tr>
<td><strong>Blended</strong></td>
<td>It adds blended shadows, highlights, and backgrounds.</td>
</tr>
<tr>
<td><strong>Bovination</strong></td>
<td>It adds cow spots to the selected regions.</td>
</tr>
<tr>
<td><strong>Chalk</strong></td>
<td>It creates a Chalk drawing effect.</td>
</tr>
<tr>
<td><strong>Chip Away</strong></td>
<td>It creates a chip wood carving effect.</td>
</tr>
<tr>
<td><strong>Chrome</strong></td>
<td>It adds a simple chrome effect to the image.</td>
</tr>
<tr>
<td><strong>Comic Book</strong></td>
<td>It adds a comic book effect to the image.</td>
</tr>
<tr>
<td><strong>Cool Metal</strong></td>
<td>It adds a metallic effect to the image.</td>
</tr>
<tr>
<td>Effect</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Frosty</td>
<td>It adds a frost effect to the image.</td>
</tr>
<tr>
<td>Glossy</td>
<td>It adds a glossy effect to the image.</td>
</tr>
<tr>
<td>Glowing Hot</td>
<td>It adds a glowing hot metal effect to the image.</td>
</tr>
<tr>
<td>Gradient Bevel</td>
<td>It adds a shiny look and bevel effect to the image.</td>
</tr>
<tr>
<td>Neon</td>
<td>It converts the image to the neon object.</td>
</tr>
<tr>
<td>Particle Trace</td>
<td>It adds a trace of particles effect to the image.</td>
</tr>
<tr>
<td>Textured</td>
<td>It fills the image with texture and shadows.</td>
</tr>
</tbody>
</table>

Table 6.2.1.20: Alpha to Logo Filters in GIMP

This filter is very useful in adding effects to text in GIMP. The steps for adding effects to text are as follows:

i) Use “File” from the menu bar to select “New” for creating a new document or “Open” if the text is to be added to an existing image.

ii) Click “Tools” from the menu bar and then click “Text.”

iii) Left-click the canvas to type the text. It might be customized with Tool Options.

iv) “Filters” from the menu bar is clicked to select “Alpha to Logo.”

v) Select one of the preset effects mentioned in Table 6.2.1.20.

vi) The selected effect is customized by adjusting the parameters on the Script-Fu window. For example, when applying the “Alien Glow” effect, a user can adjust the glow size and color while for the “Bovination” effect one can specify the spot density and background color.

vii) Click “OK” to apply the selected effect to your text.

The effect of using Alpha to Logo filters on text is demonstrated in Figure 6.75.
GIMP has support for extending and applying macros by using the following supporting language scripts:

- Gimp Script-Fu, SCM scripting system, based on the Scheme language
- Gimp-Perl
- Gimp#
- Ruby
- C or C++ to code a binary plugin

### 6.5 Working with Layers

Layers in GIMP allow a user to work on images placed onto a stack and are accessed in layer by layer manner. Each layer could be imagined as clear glass sheet to place an image. If an image is modified on the current layer, it would not affect the layers above and below the current layer. The Layer Menu is displayed in Figure 6.76. Layers at the top of the layer stack will appear in the foreground of the image whereas layers at the bottom make up the background.
Layer Dialogue has many options available to perform various functionalities. They are listed as follows (Figure 6.77):

A. Adding a new layer: It allows the user to add a layer by naming the layer, setting up width and height, and choosing whether it should be transparent, white, or black in the background.

B. Create New Layer Group: It creates a new layer group and adds it to an image.

C. Move the layer up: It simply moves the layer up in the stack of layers for processing.

D. Move layer down: It moves the layer down and the layer would be placed underneath the background layer.

E. Duplicate the layer: It creates an identical layer by duplicating.

F. Anchor the layer: It merges the image on current layer to another image on the layer below Gimp creates a “floating layer” and this layer contains what a user wants to copy to other layers. Pressing the anchor option will make floating layer disappear, the contents of the floating layer are transferred to the destination layer.

G. Delete the layer: It removes the currently selected layer.
Figure 6.77 (a): Layer Dialogue Options

Figure 6.77 (b): Layer Options

The dialogue also has the following features:

**Mode:** It allows changing appearance (Normal, Dissolve, Darken, Burn etc.) of the selected layer.
Opacity: It acts a slider to change the transparency of the selected layer.

Lock: A locked layer prevents modification of the Layer’s pixels. ‘Lock Alpha channel’ feature is to keep transparent regions intact and confines editing to only opaque portions of the layer.

Layers are important to make up an image composition if a bunch of different images from different files are combined into one image. While creating an image composition in this manner, one could copy and paste images from different files into his/her file but keep them on separate layers. An image on each layer can be scaled, moved, enhanced, re-colored, etc., without affecting the images on the other layers.

A simple example is shown below (Figure 6.77 c).

1. We have an image of a tree (File ➔ Open Image).
2. Let’s try to put up an apple on the tree.
3. We open the image of fruit basket in another layer by using File ➔ Open as Layers.
4. The Selection tool is used to isolate the apple image pixels.
5. The selection is pasted as a Layer into the tree image (Edit ➔ Paste As ➔ New Layer).
6.5.1 Creating a New Layer in GIMP

The New Layer could also be added by selecting from Layer Menu.

The steps are as follows (Figure 6.78 a-b):

i)  Open GIMP.

ii)  Launch a new image file

iii)  Click Layer → New Layer or press Shift+Ctrl+N to create a new layer in an image.
iv) The New Layer window opens up.

Figure 6.78 (b): New Layers Dialogue in GIMP

v) Set up the parameters like Layer Name, Height, Width and Fill Type as listed in Figure 6.78 b.

vi) Save the File.

Besides New Layer we have the following options available with Layers in GIMP:

- **Edit Layer Attributes:** It allows the user to enter a new name for the layer.

- **New Layer from visible:** It creates a new layer comprising of all the elements of the currently visible layers, merged into one layer.

- **Duplicate/Anchor/Delete Layer:** These are similar functions to their icon counterparts.

- **Merge Down:** It merges the currently selected layer with the next visible layer below it.

- **Layer Boundary Size:** Every layer has its boundary and this option adjusts the layer dimensions making it easier for you to demarcate selected and non-selected layers.
- **Layer to Image Size:** It resizes the layer boundary to the image size.
- **Scale Layer:** It changes the size of layer content.
- **Auto crop:** It removes empty borders from the image layer.
- **Stack:** It supports selecting previous, next, top and bottom layers.
- **Add Layer Mask:** It adds a layer mask to the selected layer to avoid destructive changes in editing transparency. This option lets you choose the type of mask you want to apply on the particular layer.
- **Apply/Delete Layer Mask:** *Apply layer* mask appends the changes done in the mask to the current layer and *Delete layer* removes the mask.
- **Show Layer Mask:** It reflects the changes done in the applied mask.
- **Edit Layer Mask:** It allows switching between the layer and its applied mask by either using it or by clicking on the preview.
- **Mask to Selection:** It replaces the selection with the mask layer.
- **Add Alpha Channel:** It adds transparency to the selected layer. It is a very handy tool for creating quick animation with the GIMP.
- **Alpha to Selection:** An Alpha channel encodes information about how transparent a selected layer is at each pixel. This option replaces the selection with layer’s alpha channel.
- **Merge Visible Layer:** It merges all the active visible parts of a layer, in the image.
- **Transform:** It transforms an image on selected layer by applying rotation by 90 or 180 degrees (clockwise or counterclockwise) and flipping horizontally or vertically. It also supports arbitrary rotation.

### 6.5.2 Experimenting with few of the GIMP Layer Options

1. **Changing the Opacity level of images placed in layers** (by scrolling and clicking mouse): It will change the transparency level of images in layers.
Figure 6.79 (a): Opacity level of 100

Figure 6.79 (b): Opacity level of 38
2. **Adding Text over an Image layer**

A text tool in GIMP adds a new layer automatically. When you view your Layers dialog, you will see a new layer containing the text you just created. The text could be modified with editing properties like Font, Style and Color. The correct layer is to be chosen before text addition and editing.

GIMP ➔ Choose the layer ➔ Tools ➔ Text ➔ Write the desired text
3. **Resizing Layer Boundary**

Layer ➔ Layer Boundary Size
4. **Scale Layer**

Layer ➞ Scale Layer

![Scale Layer Diagram](image)

*Figure 6.82: Scale layer*

5. **Transform Image by Rotation**

Layer ➞ Transform Image ➞ Rotation by 180 degrees

![Transform Image on the layer Diagram](image)

*Figure 6.83: Transform Image on the layer*
6.5.3 Layer Masking

Layer masks in GIMP offer an elegant way to edit specific portions of images placed in layers within a GIMP document. It may produce more attractive outputs by refining selections. When a layer mask is applied to an image over the layer, the mask makes parts of the layer transparent so that any layers below are shown through. This could prove to be an impressive way of combining two or more images to produce a final image which combines selected portions of each of them.

The steps for layer masking are as follows:

i) Right Click on the layer needed to be masked and Click on Add Layer Mask.

![Add Layer Mask Options in GIMP](image)

Figure 6.84: Add Layer Mask Options in GIMP

ii) A mask layer option is chosen and thumbnail will appear in right layers window with the image.

iii) Now all the operations performed on the canvas will be on the mask.

iv) Operations like selection; paint etc. could be applied to the mask.
v) After operations, setting the transparency levels will generate an effect in which layer below the mask is visible depending on transparency from black to light gray gradients.

The steps to Add Alpha Channel to a sample image are given below and their use is demonstrated in Figure 6.85.

i) The default layer i.e. background layer opens up in the editor layers dialogue.

ii) Give this layer a color, say, sea green.

iii) Add another layer and let us call it a tree. Paste an image of some tree on this layer.

iv) Drag the background layer above the tree layer. It may be observed that the tree is hidden in the background.

v) Right-click on the background layer and click on Add layer Mask.

vi) A window pops up with several options. Select white (full opacity).

vii) A thumbnail mask, indicated by a white box in front of the background layer in the layers stack, is created.

viii) Select the rectangle tool and draw a rectangle via selection on the background layer.

ix) Change the color to black from foreground and background color option at the end of the toolbox.

x) Select edit menu and click on fill with FG (foreground) color. This will show the selected portion of the tree with full transparency.

xi) Repeat the steps with some dark shade of gray color, light shade of gray color, and light shade of white color.

Please note that black will mean full transparency and white will mean full opacity. The colors lying in between will act as translucent according to the shades.
Figure 6.85 (a): Creating a layer with a Foreground Gradient Fill

Figure 6.85 (b): Selecting a part on the designed layer
Figure 6.85 (c): Add a layer mask to the image

Figure 6.85 (d): Added a layer mask thumb to the image
Figure 6.85 (d): Selection a portion from an image of mask layer and changing foreground to black

Figure 6.85 (f): Result of transparency after changing foreground
6.5.4 Alpha Channels

Alpha channels under Layers Menu are used to signify transparency within an image and are created automatically while creating a new layer in GIMP. The painted black areas within the alpha channel indicate that transparency should appear at that part of the image. The creative use of alpha channels allows partial transparency or fading effects due to the inclusion of a gradient design in the alpha channel.

The steps to Add Alpha Channel to a sample image are given below and their use is demonstrated in Figure 6.86:

1) Default Background layer will appear in the layers dock with a default color white. Change its color to Yellow.
2) Add another layer from layer menu ➔ new layer
3) Let us name this layer as House and paste the image of some house
4) Using the selection tool and select a portion the house.
5) Go to Layer menu ➔ Transparency ➔ Color to Alpha
6) Select white (here white means transparency)
7) The selected portion will get a yellow color similar to the background.
8) Transparency tool has various other options like removing alpha channel which will remove this yellow color and the house will revert to its normal color.

![Layers of background and a house](image1)

**Figure 6.86 (a): Layers of background and a house**

![Adding Color to Alpha for selection](image2)

**Figure 6.86 (b): Adding Color to Alpha for selection**
Channels in GIMP are very similar to layers; however, each layer corresponds to a particular level in the color model of the image (RGB, HSV or CMYK). Channels dialogues (Figure 6.87) can be selected in any combination, and appear as gray shaded, if currently active.
The purpose of ‘Channels’ is to process color channels (applied to images) and maintain selection masks. And the ‘Path’ dialogue with layers and Channels is used to manage paths of images for creation, deletion, saving, converting to or from selections etc.

GIMP is versatile image manipulation software packed with various attractive features, many of which are explored in this chapter. It can be explored for other aspects too for image manipulations and making images more attractive.

**Points to Remember**

- GIMP is an acronym for GNU Image Manipulation Program.
- It is a freely distributed, versatile image manipulation software package with a customizable interface.
- It has support for multiple platforms including Windows and Linux.
- It supports various file formats including .gif, .jpeg, .png, .tiff etc.
- It is a full suite of painting tools including a variety of brushes, pencil etc.
- It has selection tools (Rectangle, Eclipse, free lasso, fuzzy etc., for selecting portions of an image.
- It has transformations tools like rotate, flip, scale and shear.
- It has support for high-quality antialiasing.
- It also supports a variety of Filters for image enhancement or modification in appearance.
- It has full Alpha Channel Support.
- It has the functionality of Layers and Channels.
- It has the functionality of masking of images.
- It also has Plug-ins for easy addition of new file formats, filters and scripting capabilities.

**Exercises**

- What does GIMP stand for?
- What is Gimp’s default graphics file format?
- List five main components of GIMP environment.
- What are Dockable Dialogues in GIMP?
Create a file in GIMP and demonstrate the purpose of paint tools and selection tools.

Open an image of human eyes with red eyes effect in GIMP and perform red-eye correction.

Draw i) a smiley face ii) a house with the help of GIMP.

Apply Comic Book effect to an image in GIMP.

List the steps for cloning in GIMP.

Open an image and change the background of an image in GIMP.

Implement the following features of GIMP on an image:

i) Resize-Crop
ii) Brightness/Contrast
iii) Colorize with Hue and Saturation
iv) Zoom
v) Add a border to an image
vi) Add text to an image.

Animate a bouncing ball in GIMP.

Apply Alpha to Logo effects on your name.

Demonstrate working of Layers in GIMP.

What are the layer masks & channels in GIMP?

Use Gimp to Create a Logo of a Company “ABC”.

How a user can you make only the part of an image, transparent in GIMP?

What is the purpose of alpha channels in GIMP?

How can we create an outline around text in GIMP?

How do we merge an image from a file to the current image in GIMP?

List steps to perform masking of images in GIMP.

What is the purpose of stamp tool in GIMP?

List the possible steps to create a polygon in GIMP.

What is the purpose of Scale image in GIMP?

How can you change the brightness of an image in GIMP?

List the filters that may aid in blurring an image in GIMP.
List the possible steps to create a red colored balloon with some text in GIMP.

How can GIMP be used to create a speech bubble on some cartoon?

List any two plugins with their purpose available in GIMP.

A Partial List of Keywords

<table>
<thead>
<tr>
<th>Airbrush</th>
<th>Edge Detect</th>
<th>RGB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha to Logo</td>
<td>File</td>
<td>Rotate</td>
</tr>
<tr>
<td>Animation</td>
<td>Filters</td>
<td>Saturation</td>
</tr>
<tr>
<td>Blend</td>
<td>Flip</td>
<td>Scale</td>
</tr>
<tr>
<td>Blur</td>
<td>Generic</td>
<td>Selection Editor</td>
</tr>
<tr>
<td>Brushes</td>
<td>Gradients</td>
<td>Sharpen</td>
</tr>
<tr>
<td>Channels</td>
<td>Grayscale</td>
<td>Shear</td>
</tr>
<tr>
<td>Clone</td>
<td>Grid</td>
<td>Smudge</td>
</tr>
<tr>
<td>Color Balance</td>
<td>Guides</td>
<td>Threshold</td>
</tr>
<tr>
<td>Color Picker</td>
<td>Layers</td>
<td>ToolBox</td>
</tr>
<tr>
<td>Color to Alpha</td>
<td>Level</td>
<td>Tools</td>
</tr>
<tr>
<td>Colors</td>
<td>Mode</td>
<td>Web</td>
</tr>
<tr>
<td>Combine</td>
<td>New</td>
<td>Zoom</td>
</tr>
<tr>
<td>Copy</td>
<td>Noise</td>
<td>Pastes</td>
</tr>
<tr>
<td>Crop</td>
<td>Open</td>
<td>Patterns</td>
</tr>
<tr>
<td>Curves</td>
<td>Open as Layers</td>
<td>Perspective</td>
</tr>
<tr>
<td>Cut</td>
<td>Paste</td>
<td>Posterize</td>
</tr>
<tr>
<td>Desaturate</td>
<td>Patterns</td>
<td>Preferences</td>
</tr>
<tr>
<td>Dockable Dialogues</td>
<td>Posterize</td>
<td>RGB</td>
</tr>
<tr>
<td>Dodge</td>
<td>Preferences</td>
<td>Rotate</td>
</tr>
</tbody>
</table>

IT Tools Level - 3
UNIT - 5

Troubleshooting - Hardware, Software and Networking
Troubleshooting - Hardware, Software and Networking

7.1 Introduction

While working with a computer you are sure to come across some hardware, software and networking problems. The objective of this chapter is to help you find a solution to some commonly encountered problems. Having gone through this chapter you will be able to diagnose and fix minor issues. You may need expert advice for advanced problems not covered here. As you gain experience, you would be more confident to handle problems.

Some of these problems would not occur if you work carefully and ensure that connections are in place and proper settings are done. There could be many reasons/causes for a problem on a computer. It is sometimes difficult to judge if it is a hardware-related or software-related problem. Troubleshooting is generally a trial and error process, requiring persistence and patience. Starting with the simplest possible cause, we use the process of elimination to diagnose the problem. One needs to figure out the cause of the problem, i.e., identify the part of the computer system that is not functioning well.

Always take a backup of your important files to another source, like a pen drive or an external hard disk. In case the problem is not solved, this ensures that a copy of your data is available.

7.2 Common Troubleshooting Steps

When you switch on the system, the power supply detects the CPU and the peripherals (the other connected devices). The system boots, and if all peripheral devices have been successfully detected, most systems will produce a beep. If any connected device (such as monitor, keyboard, mouse, and printer) does not switch on, try the following:

Close running programs that are not being currently used

Check the Cables: Check the cable of the specific computer hardware which is not working. Ensure that all connections are tight, correctly plugged in, and the Power button
of these devices is ON. For wireless devices, make sure it is turned on and the batteries are charged.

For example, a laptop’s battery may not be charged. Plug the AC adapter into the electric socket, wait a few minutes, and then try to turn on the laptop.

Repeat the Steps to See if the Problem Recurs: Repeat the sequence of steps that you performed before the problem occurred. Observe if it causes the same response from your computer.

Use Help: Access the Help window by pressing the F1 key. This window helps to find a solution to the problem.

Record Error Messages: Record the full error message for future reference.

Restart the Computer: Restart the peripheral device. If the device still does not switch on, shut down the computer and start it again.

7.3 Troubleshooting Hardware Problem

7.3.1 Monitor is Not Showing any Display/ The Screen is Blank

The System is in Sleep Mode: The computer may be in Sleep mode. Click the mouse or press any key on the keyboard to wake it up.

Check All Connections: For a desktop, ensure a proper connection of a cable connecting the monitor and a computer cabinet. Check that the power cables of the monitor and cabinet are plugged into the electric socket and the power is turned on.

Laptop’s Battery is Low: The laptop’s battery could be very low, causing the laptop to switch off. Connect the charging cable to the laptop and plug it into the electric socket. The laptop will start charging, and in a few minutes, the laptop can be switched on.

7.3.2 Keyboard Troubleshooting

If the keyboard is not responding, try the following:

Check Connections: Check the connection of the keyboard to the computer. If it is not connected, or the connection is loose, connect it properly to the computer.

Check for any Damage: Inspect the keyboard cord for any damage. If any damage is found, the keyboard may need to be repaired or replaced.

Change Batteries: For a wireless keyboard, the batteries may have discharged. You may need to change the batteries.
Keys are Stuck: If one of the keys on your keyboard is stuck, you need to clean the keyboard. You will have to first turn off the computer. As the keyboard is stuck, you may need to use a mouse if required. Remove dust with the help of a brush, and wipe the keyboard clean with a damp cloth (water should not be dripping from the cloth).

7.3.3 Mouse Troubleshooting

In case the mouse is not working, try the following troubleshooting options:

Check Connections: Make sure that the mouse is securely plugged into the computer.

Check for any Damage: Inspect the mouse cord for any damage. If the damage is noticed, the mouse may need to be replaced.

Check the Cordless Mouse: For a cordless mouse which is not working, switch off, and then switch on the cordless mouse. This should re-establish a connection with the system.

Clean the Mouse: Try cleaning the mouse with a damp cloth. Clean the area around the button located on the underside of the mouse.

7.3.4 Troubleshooting Printer Problems

7.3.4.1 Printer is Not Responding (Not Printing)

The printer could not be responding due to a number of reasons. Check for each of the following causes, taking necessary action as required:

The Printer is Not Connected Properly or Not Switched On: Ensure that the printer cables are connected properly. If the printer is not switched on, switch it on.

The Printer is Out Of Paper: If the printer does not have paper, put paper in the paper tray and try printing again.

The Printer Paper Jam (Paper is Caught in the Printer): Open the printer and remove the paper caught in the printer. Close the printer and try printing again.

The Ink Cartridge of Printer is Empty: Most printers give a warning message when the ink levels are low (insufficient for printing). Change the ink cartridge and try again.

Incorrect Printer Driver: The printer driver may be incorrect. You would need to install a new printer driver. The latest driver can be downloaded from the manufacturer’s website. Some printers, when connected to the internet, give a message when driver updates are available. Consult your system administrator before installing any new software.
The Printer and Computer are Communicating Properly: This problem is more common when a wireless connection is being used to connect a PC/ laptop to a printer. Check that the IP address configured on your computer matches the Dynamic IP address allocated to the printer (If the printer is connected through WI-FI (a wireless network) the configured IP Address could be different from the one stored on your PC).

Before troubleshooting the printer’s IP address, you need to ensure that both your system and printer are connected by means of a network – through a wireless connection or through Ethernet. (Discussed in Section 7.5)

You can access your printer settings and check the IP address and change the settings (if required). Follow the following steps:

**Step 1:** Open the devices and printer dialog box by clicking **Start button > Control Panel > Hardware and Sound > Devices and Printers (or Start button > Control Panel > All Control Panel Items > Devices and Printers)**, and select the printer whose IP address you wish to check/change. (The example below, Figure 7.1, shows an HP Printer. Other printer models also have similar interfaces).

![Figure 7.1: Screen to select the device (Printer)](image-url)
**Step 2:** Select the desired Printer (here HP Deskjet 3540 was selected). The following screen (Figure 7.2) shows the programs that can be selected to manage the printer, change its settings, etc.

![Figure 7.2: Printer Screen allowing you to choose a program](image)

**Step 3:** Run the **HP Print Assistant** (as shown in Figure 7.3). This program manages the printer and gives access to the Help information. The **HP Print Assistant** program may take some time to open, as your PC/ laptop would try to establish a connection with the printer.
**Step 4:** Click on the **Utilities** icon to get the printer utilities screen (Figure 7.4).

![Figure 7.3: HP printer Assistant: Processing](image)

![Figure 7.4: Printer Utilities](image)
**Step 5:** Run the ‘Update IP Address’ utility. Before the utility program starts, a pop-up message appears - “Do you want to allow the following program to make changes to your computer?”. On confirmation, a screen (Figure 7.5) showing the printer’s Previous IP address appears (in this case 192.168.1.11). Please note that the box next to the Test button would be blank.

![Figure 7.5: Update HP Software with Printer IP Address](image)

**Step 6:** We have to now check whether the printer’s Previous IP address matches the Printer’s current IP address.

Your system may be connected to the printer through a wireless or an Ethernet connection.

**For Wireless Connection:** Press the Wireless button or touch the wireless icon on the printer display. The printer’s IP address appears (see Figure 7.6). As shown in this screen, it is 192.168.1.5. In case, the printer does not have a display, print the Wireless Network Test Report. This report includes the printer's IP address.
For an Ethernet Connection: Press the Ethernet icon on the printer display. The printer’s IP address appears. In case the printer does not have a display, print the Network Configuration page. This report includes the printer’s IP address.

**Step 7:** Update HP Software with Printer IP Address: From the above screens (Figure 7.5 and Figure 7.6), we can see that the **Printer’s previous IP address** saved on your system (192.168.1.11) does not match the **Printer’s current IP address** (192.168.1.5). Enter **Printer’s current IP address** or hostname in the box provided (HP Software screen is shown in Figure 7.5) and Click **Test** (to test the printer connection with the changed IP address). On successfully connecting to a printer with the current IP address, the software shows a **Success** message. Click **Save** to update the software with this new IP address.

### 7.3.4.2 Print Jobs are Being Sent to the Wrong Printer

When there are multiple printers on a network, a possible problem could be that a print job is being sent to a wrong printer. This is because your system has set the default printer as Printer A, but you had actually wanted the print job to go to Printer B. You could either change the default printer to Printer B or choose Printer B for the current job.

**Change the Default Printer**

To change the Default Printer, open the devices and printer dialog box. Click **Start button > Control Panel > Hardware and Sound > Devices and Printers.** Alternatively, click **Start button > Control Panel > All Control Panel Items > Devices and Printers.** The screen below (Figure 7.7) shows the default printer as HP Deskjet 3540 (Printer A). There is a tick inside a small green circle next to its icon (this signifies that HP Deskjet 3540 has been set as the default printer).
Suppose you wish to change the default printer to say, HP Laserjet 1020 (Printer B). Right click on the icon for this printer, a pop-up menu is displayed (as shown in screen in Figure 7.7). Select, **Set as default printer** from this pop-up menu. The screen will now look like the one below (Figure 7.8). The tick next to the HP Laserjet 1020 icon shows that it is now the default printer.
Note: Changing the default printer to Printer B, as described above, is possible even if Printer B is not connected to your network. Give a print job only if your system and Printer B are connected via a network. You must ensure that Printer B is on your network and that your system can establish a connection with it.

Choose an Alternate Printer for the Current Print Job

When you give a print job, a Print screen opens, as shown in Figure 7.9. The Default Printer (here HP Deskjet 3540) is automatically selected for the print job.

If you wish to change to an alternate printer for the current print job, click on one of the available printer icons in the list. The next screen (Figure 7.10) shows HP Laserjet 1020 as the printer selected for the current job. As you can see, printer HP Laserjet 1020 is offline (not connected to your system via a network/cable). The Print program allows you to select the printer even when the printer is offline. Ensure that this printer is online (connected to your system via a network/cable), before you click on the Print button and start the print job.

Figure 7.9: Print Screen
7.3.4.3 Printer is Slow

The printing speed can be improved by reducing the printing quality and using Fast Draft/Fast Printing. This works well for everyday printing. Change the default printer quality setting from Normal to Fast Draft.

To do this, click the Preferences button (as seen on the screen in Figure 7.9 and 7.10). This will open the Printing Preferences screen (Figure 7.11). Under the Printing Shortcuts Tab choose Fast/Economical Printing.
7.3.5 Sound Troubleshooting

When you are not getting sound from the speakers, troubleshoot using the suggestions given below:

**Check Speaker Volume**

Check the volume level of the speakers. Click the **Audio button in Task Bar** to make sure the sound is turned on and that the volume is up (Figure 7.12).

![Figure 7.12: Checking for the volume level of the Speaker](image)

**Check Audio Player Controls**

Many audios and video players have their own separate audio controls. Ensure that the sound is turned **on** and that the volume is set large enough to be heard.

**Check the Cables**

In case external speakers are used, ensure that the speakers are plugged into the electric socket, turned on, and connected to the correct audio port or a USB port on your system. If your computer has color-coded ports, the audio output port will usually be green.

**Check the Sound Using Headphones**

Connect headphones to the audio output port of your computer, and check whether you can hear sound from the headphones. If you can, that means there is something wrong with your speakers. Contact a Service Engineer.
7.4 Troubleshooting Software Problems

7.4.1 Common Troubleshooting Technique - Close the Program and Reopen it

A simple troubleshooting technique would be to close the application/program and reopen it. If the problem persists, try other troubleshooting techniques.

7.4.2 An Application is Running Slow

Check for Available Updates

If restarting the application does not improve the speed of the application, check for updates. Click the Help menu and look for an option to check for Updates. In case this option is unavailable, you can search online for application updates.

7.4.3 An Application is Frozen

Sometimes an application may freeze. When this happens, you will not be able to close the window or click any button within the application. The following troubleshooting options may be tried:

Forcefully End the Application

On a PC / Laptop keyboard, press (and hold) Ctrl+Alt+Delete (the Control, Alt, and Delete keys). This will open the Windows Task Manager (Figure 7.13). Open the Applications tab on this screen. You will see a list of applications. The applications should have the status as Running. An application which is not responding would have the status as Not Responding. Select the application which is not responding from the list and click the End Task button. This forcefully terminates the application. Now restart the application.

Restart the Computer

If you are unable to forcefully end an application, close all running programs and restart the computer.

If you are unable to shutdown/ restart your system, perform a hard reboot by pressing the Power button, i.e. manually turn off the computer. This step should be performed in extreme situations, as a last resort. Remember that hard reboot may cause data loss.

Once the system is responding, run the virus check to scan the system for viruses.

7.4.4 All Programs on the Computer Run Slowly

7.4.4.1 Check for Viruses

You may have malware running in the background, which is slowing applications on your
system. Viruses generally lower the system’s performance. Run the virus scanner installed on your system.

7.4.4.2 Free Space on the Hard Drive

Check Minimum Free Disk Space Required

There should be at least 200-500 MB of free hard drive space on your system. Non-availability of free space slows the functioning of the computer. To check the amount of disk space available, Open the Windows Explorer Application and click on My Computer. This will show the different hard disk partitions such as C, and D. To check the amount of disk space available on the C drive, highlight the C drive and right click to get a pop-up menu (Figure 7.14).

![Figure 7.14: Pop-up Menu showing operations on a Disk](image)
Select the **Properties** option from this pop-up Menu. Choose the **General Tab** of this application. The screenshot in Figure 7.15 shows the available **Free Space** on the C Disk, shown by the purple area in the Pie chart (here 69.1 GB).

![Figure 7.15: Free Space on a Disk](image)

**Run a Disk Clean Up Application**

To get some more disk space, run the Disk Cleanup Application. On the **General tab** shown in Figure 7.15, click on the **Disk Cleanup button**, to start disk cleanup.

Once the Disk Cleanup is complete, the Disk Cleanup dialog box opens (Figure 7.16). Click on **Clean up system files button**. This will delete any unnecessary system-related files from the local disk.

![Figure 7.16: Disk Cleanup](image)
Delete Unused Files and Programs

Periodically delete files and programs you do not need. This will increase the free space on your disk, increasing the performance of your computer. Images and videos take up a lot of space. These can be moved to an external drive. This will free some space on the disk drive.

Empty Your Recycle Bin

This can be done by right-clicking on the Recycle Bin icon (usually on the desktop), and then selecting Empty Recycle Bin.

![Empty Recycle Bin](image)

Remove Temporary files

It is important to periodically remove the temporary files and the Internet browsing history. This too will increase the free space on your disk. To do this you would need to first open the network and sharing dialog box. Click Start button> Control Panel > Network and Internet > Network and Sharing Center (Figure 7.18, same as Figure 7.25). Alternatively click, Start button> Control panel > All Control Panel Items> Network and Sharing Center.
On the bottom left corner of this screen, click on the link **Internet Options**. This opens the Internet Properties dialog box (Figure 7.19). Select the **General tab**. Under Browsing History, check the **Delete browsing history on exit checkbox**, and then click the **Delete… button**. This deletes the browsing history. Click the **OK button** to exit.
Disk Defragmentation
The information in our files changes frequently. This results in gaps or spaces in the file stored in the memory (hard disk). The file thus takes more space on the computer, and may cause the computer to slow down. You need to run a Disk Defragmentation program to reclaim these gaps in space. This can be achieved as follows.

Open the Windows Explorer Application and click on My Computer. Highlight the C drive and right click to get a pop-up menu (Figure 7.14). Select the Properties option from this pop-up Menu. The dialog box showing the properties of the local disk (C:) is displayed (Figure 7.20). Choose the Tools Tab of this application. Click the Defragment now… button.

![Figure 7.20: Running the Defragmentation Application](image)

Remove Unused Programs
Old or unused programs that are not being used may still have components running behind the scenes when you start your computer. This can slow down the system. To prevent these programs from running when your computer starts, turn off unused program services. For
this purpose, from the Windows startup, click **Start button > All Programs > Startup**. Right-click the shortcuts that you do not need and click **Delete** (Figure 7.21).

![Figure 7.21: Removing unused Shortcuts](image)

**Disable Unused Program Services:** This is done in two steps. First, the unused program service is stopped. It is then disabled so that it does not run at Startup.

Click **Start button> Control Panel> Administrative Tools> Services**. For each program/service that you are sure that you do not need, click on the Service to highlight it, click the **Stop link** to stop the service from running (Figure 7.22).

Now double-click the stopped service and choose **Startup Type** as **Disabled**, and click **OK** (Figure 7.23).
7.4.5 The Computer is Frozen

Sometimes the computer may become completely unresponsive, or frozen. When this happens, you won’t be able to click anywhere on the screen, open or close applications or access shut-down options.
**Force System Restart**

In such a situation, you would have to force a system shutdown. Press and hold the **Power button**. The **Power button** is usually located on the front or side of the computer. On a laptop, the **Power button** is usually located in the top center or left/right corner of the keyboard. Press and hold the **Power button** for 5-10 seconds to force the computer to shut down. Now switch on the computer again.

### 7.5 Troubleshooting Networking Problems

#### 7.5.1 Unable to Connect to the Network

**7.5.1.1 Checking for Network Connectivity**

A common problem is that you are unable to open a web page that you had requested. This could be because you are unable to connect to the Internet. To check the internet connection, view the **Network icon** (triangular in shape). This is on the **Task Bar** (bottom right of the screen) (Figure 7.24). The screenshot in this figure shows that there is no network connection (an orange star on the network icon).

![Figure 7.24: Task Bar showing no Internet connection](image)

An alternate method to check for network connectivity is to click **Start button > Control Panel > Network and Sharing Centre** (Figure 7.25). The red cross between the **USER-PC** and **Internet** shows that the computer is not connected to the Internet. You would have to establish an internet connection. You may need to run the diagnosis to find the cause of the problem.
Figure 7.25: Checking for network connectivity through Control Panel

On the Task Bar, click the **Network icon** to see the available Internet connections. If you have opened the Network and Sharing dialog box (*Start button > Control Panel > Network and Sharing Center*), click on the link **Connect to a network**. This will open a list of Wireless Network Connections in the vicinity of your system, (Figure 7.26). Click on one of the connections and then click the **Connect button**.

Figure 7.26: Wireless Network Connections in the vicinity of the system
Once you have requested for network connectivity, the troubleshooting application will display a few screens while the system attempts to diagnose the issue: *Windows Network Diagnostics: Investigate router or access point issues, Detecting problems, Resolving the problems, Detecting additional problems, etc.* These screens will guide you in establishing a connection. For example, while investigating router or access point issues, it would ask you to turn off the router and restart it again (Figure 7.27).

![Figure 7.27: Investigation of router or access point issues](image)

If you are still unable to connect to the internet, the troubleshooting application would report the Problem in network connectivity. Figure 7.28 shows ‘Problem with wireless adapter or access point’. Try **Switching Off** and then **Switching On** the adapter. If that still does not work, repeat the whole process again after some time. Your network connectivity issue would probably be solved after a few attempts.
7.5.1.2 Check for the Validity of IP Address

If the above steps do not help in establishing a network connection, you would have to check a few more system settings.

First check the validity of the IP address of your system. In the bottom left corner of your Windows screen click **Start**. In the Search box type **CMD** and press **Enter** (Figure 7.29a).
Alternatively, in the bottom left corner of your Windows screen click Start. In the Search box type Run and press Enter. This will open the Run application, which opens a program or document that you request it to. Type CMD in the Open textbox and press Enter (Figure 7.29b).

![Figure 7.29b: Opening COMMAND PROMPT using the Run application](image)

The COMMAND PROMPT (an MS-DOS window) will open. Type IPCONFIG and press Enter. The results should show the Connection-specific DNS Suffix, IP Address, etc., as seen in Figure 7.30. This information will only show if your system is connected to the internet, else, it will show Media State: Media disconnected.

![Figure 7.30: IPCONFIG showing the system's IP address in the COMMAND PROMPT WINDOW](image)
7.5.1.3 The Network Fly lead is Not Working Properly

The fly lead is the cable that connects the network card in your computer to a network point (usually on the wall). A non-operational network fly lead could also cause failure in the internet connection. The network fly lead is seated in the network slot on your computer. This slot is located either at the back of the computer or on the side, depending on your PC/laptop. Ensure that the fly lead is plugged securely into the network point on the wall. Check whether the cable or point has been damaged. If so, seek assistance from a network administrator.

Your fly lead could be faulty or damaged. To check if your fly lead is faulty, borrow a working fly lead from someone and repeat the previous steps with the borrowed fly lead. If this borrowed fly lead works, your own fly lead is faulty. Seek assistance from a network administrator.

Sometimes, the network point on the wall may not be activated. A network point will not work until it is activated. For this purpose, get help from your network administrator.

7.5.1.4 The Network Card is Not Working Properly

A working network card is essential to connect to the Internet. The network card lights must be flashing or lit up. If there are no lights, either the network card is broken, or there is no network to connect to. A broken network card needs repair or replacement. Contact a Service Engineer.

Seek assistance from a network administrator to check whether the fly lead is plugged into the correct network card. If the machine has more than one network cards, you need to ensure that the cable is plugged into the network card configured for it (i.e. the fly lead should connect the network card to the network point on the wall, for which it is configured).

To check whether the network card is working open a command prompt window (Start >Run >type CMD) (as discussed in Section 7.5.1.2). An MS-DOS window will open, type ping 127.0.0.1 at the prompt.

Alternatively, click Start and in the Search box type ping 127.0.0.1 and press Enter. This will run the ping command in the command prompt window.

If you get a reply (as seen in Figure 7.31), the network card is working.
Points to Remember

While working with a computer one comes across hardware, software and networking problems. In this chapter, we learned how to diagnose and fix minor problems. The following summarizes what we learned:

- It is sometimes difficult to judge if the problem is hardware-related or software-related. Identify the part of the computer system that is not functioning properly.

- Before handing over your machine to an engineer, take a backup of important files to another source, like a pen drive or an external hard disk. This would ensure a copy of your data is available, in case something unforeseen happens while your computer is being repaired.

- Most systems produce a beep when a system boots successfully (i.e. all peripheral devices have been successfully detected). If any connected device does not switch on, try the common troubleshooting tips: close running programs that are not being currently used; check the cables; repeat to see if the problem recurs; use help; record error messages and restart the computer.

- If the monitor is not showing any display or the screen is blank: the system could be in sleep mode; check all the connections; the laptop’s battery may be low.
If the keyboard is not responding: check connections; check for any damage; try changing batteries in a wireless keyboard; the keys may be stuck, replacing the keyboard.

In case the mouse is not working: check connections; check for any damage and replace the mouse if required; restart the cordless mouse; clean the mouse.

The printer may not be responding because: it may not be connected properly or not switched on; the printer could be out of paper; there could be a paper caught in the printer; printer's ink cartridge could be empty; an incorrect printer driver may be configured.

The printer and computer may not be communicating properly when a wireless connection is being used to connect a PC/ laptop to a printer. The IP address configured on your computer should match the Dynamic IP address allocated to the printer.

When the print jobs are being sent to the wrong printer: change the default printer or choose an alternate printer for the current print job.

To improve the printing speed, reduce the printing quality by using Fast Draft/ Fast Printing.

When there is no sound from the speakers: check speaker volume; check audio player controls; check the cables; check the sound using headphones.

When an application is running slow, check for available updates.

Sometimes an application may freeze. Forcefully end the application or restart the computer.

When all programs on the computer run slowly, check for viruses or try freeing space on the hard disk.

To free space on the hard drive: check minimum free disk space required; run a disk clean up application; delete unused files and programs; empty the recycle bin; remove temporary files; run the disk defragmentation program; remove unused shortcuts and program services

Force system restart when the computer freezes.

When the computer is unable to connect to the network: check the network connectivity; check the validity of IP address; the network fly lead or network card may not be working properly.
Exercises

1. List some common troubleshooting steps that you should keep in mind.
2. What steps would you take if the monitor is not showing any display, or the screen is blank?
3. What would you do when your keyboard or mouse is not responding/working properly?
4. What troubleshooting step will you take when the printer is not responding?
5. How can you check the IP address of a printer connected through a wireless connection?
6. What steps do you need to take to change the default printer?
7. What could be the reasons for the print jobs being sent to the wrong printer?
8. What checks would you undertake when the speaker is not working?
9. What are the troubleshooting steps taken when an application freezes?
10. What could be the possible cause for all the applications to be running slow?
11. How can one free disk space on the computer?
12. How do we remove temporary files?
13. Why is disk defragmentation required? How can we achieve disk defragmentation?
14. What steps do we take to remove unused shortcuts and program services?
15. How can we check the network connectivity of your system?
16. Explain how you would check the validity of the IP address.
17. How will you check whether the network fly lead is working properly?
18. Describe the procedure to check whether the network card is working properly.
ITDC-306

UNIT - 6

Work Integrated Learning IT-ISM
This unit aims at providing an understanding of identification and application of the knowledge gained in the previous chapters. The key concepts that will be addressed are

- Identifying the potential areas of application
- A typical case study

8.1 Introduction

Previous chapters provided an insight into the working of a computer system, the various automation tools, multimedia tools and ways of troubleshooting any problem you encounter while working with a computer. An insight into how computers can be connected together as a network and the various relevant issues associated with a network, in today’s life, such as network security, social networking was also presented. This chapter will focus on helping you understand the various domains where you can apply this knowledge with the help of a typical case study of an educational organization.

8.2 Identification of Potential Work Areas

The IT tools that you have studied in the previous chapters are applicable in almost all domains. Let’s see a few areas and, by the end of list, we are sure you will be able to create a much bigger list than this.
Banking
Hotel industry
Travel industry
Education
Research
Medical
Finance
Entertainment

And the list continues..............

In all these domains you need to communicate where you can use Open office writer for writing your official letters/memos/notes. The organizations’ financial handling like salary/budget/profit-loss statements etc can be handled through the Open Office Calc. Projecting new ideas to peer groups/customers etc can be easily achieved through the Impress. Simultaneously multimedia knowledge can be applied to provide visualization reach to the prospective client.

In all, the complete knowledge can help you move smoothly through organizations’ day-to-day activities. To enumerate this point further, let’s pick up a case study which will help you get a clear picture of successful application of these concepts!

8.3 Case study: Educational organization- XYZ school

Let us just pick up an educational institute; it could be your school or the university where you plan to go after finishing your school. Now let’s understand how you can sail smoothly through the working of your institute, by your newly acquired skills explained in the previous chapters. Not only you yourself, but you can be a big help to your school administration through this workable knowledge.

To make things easier we go step-by-step through your organization’s automation! For fun, we will call each step in automation as a Phase of your movement.
Step I: Set up Laboratory

![A Computer Laboratory](image)

**Figure 8.1: A Computer Laboratory**

Choose your Hardware

The first step towards automation of your institute would be to find appropriate machines for working environment. This is also important for those buying their own machine!

*Remember you need to get the best state-of-art technique, keeping in mind their requirements of your institute and the financial constraints!*

So your choice of machine will be dependent on the following parameters

- **Processor**
  - Type

  Explore in the market what all type of processors is being offered by various companies and what will suit your organization. Common examples are Intel Core i3/i5/i7 processors from a leading vendor Intel, AMD’s APU and FX series. Remember machines are not changed every day, so it is critical that you choose a reliable vendor!
Speed

Ideally we want the highest possible speed, but that comes with a high cost. On the other hand a low-speed processor will demotivate the employees from using the system. So balancing the choice of speed, should be your priority. This will depend on the kind of work to be done commonly to be done.

Memory

RAM

Amount of RAM (preferably in Gigabytes) will decide how many tasks your computer can perform at hand! So more the memory better it is.

Hard disk

This is the place where almost all of your data is stored. So without much of reasoning, go for higher capacity (gigabytes/Terabytes) hard disk, unless you want to use cloud storage. Options of flash hard drive or the solid-state one should only be used if extra fast speed is required and you can settle in for a small hard disk, as this is expensive!

Monitor

Various visual display units (popularly known as monitor) are available in the market. The prime purpose of these is to connect the user with the machine, by providing an interface where the information from the machine can be visualized. There are three main kind of display devices available: the CRT (the Cathode Ray tube), the LCD (Liquid Crystal Display) and the LED (Light emitting diodes). The variation not only is in their back-end technology used but also in the power consumption, resolution, weight and cost, to name a few. Explore and see what suits best, given the organization's resources and constraints.

Networking

Resources should be pooled. So networking is essential. For a small organization a LAN will perfectly suit the needs. However connection to the outside world can be maintained through internet. So choose network connection media suitably from Optical fiber or the traditional Ethernet cable!
Choose the Software

◆ Operating System

As discussed in the previous chapter, if you need a multiuser operating system then go ahead and choose one such as Linux. A single-user system like Windows is commonly used, but you need to pay for it.

◆ Protecting your machine

Your computer is susceptible to outside attacks which threaten to destroy your files and the crucial data/information lying therein. You need to protect your machine against malicious programs like Viruses, Worms and Trojans. Investment in a good anti-virus will definitely be a good option.

A computer virus is a malicious program that attaches itself to a program or file (usually an executable file). When this file is executed the infection spreads from one computer to another.

A worm is similar in nature to virus. However it spreads itself across various machines by using the internal knowledge of how how things move in a system. It is self replicating in nature and unlike a virus does not need any human intervention.

A Trojan horse appears to be a useful software but can allow for comprising the confidential information of user. They are not self-replicating in nature as worm, nor do they reproduce by infecting other files.

◆ Software

For an educational organization, the software requirements will be of primarily two kinds. For general usage such as Open Office etc. and about which education is to be imparted. Your strategy should be to identify the syllabus and provide for few development environments ( C/C++ /Java),databases central to the curriculum to be made available in the laboratory.

Step II : Identify the work done in each department

a) Teaching

In teaching work you can utilize the IT tools for the following purpose

– Create Notes (Writer)- The faculty can use Office Writer to create
notes for teaching the students. Managing notes digitally not only keeps them handy, but also allows for easy upgradation as and when required. Suitable integration with references from related fields will help the current students but will also provide reference points for coming generations!

- Teaching slides (Impress)- Notes provide detailed information, but during class teaching presentations can be more effective as they provide a point-by-point information to be disseminated through the lecture.

- Use of Multimedia techniques for interactive lectures – Visualizing things is always more effective than normal text language. So simulation of things using multimedia would not only be more engaging for the students, but also help them in retaining the knowledge.

- Maintaining attendance record (Calc)- Keeping record of the attendance through Calc has the advantage that by applying simple formulas we can easily calculate total attendance over a period of time, identify which all students are short in attendance, average attendance of the class/student and various other attendance based metrics, which are otherwise tedious tasks to do manually.
Report generation(Calc): Report generation is a tedious task, but the effort can be reduced by using the Open Office Calc. Calculation of the students’ scores can be achieved through use of formulas. Any modification in the policy also can be easily incorporated by a single change and will consistently change across all the reports. And since it is available electronically, so saving of physical space.
- **Communication with students/parents (Writer):** Usually the organization needs to contact the parents of the students. Sending of customized individual letters addressed to parents can be easily achieved through the features of Writer such as Mailmerge.

![Image](image_url)

*Figure 8.5: Communication with parents using Writer*

In a similar manner the Office of your organization can utilize these tools for

- Official documentation
- Financial management (Fee calculation, Salary generation, Bills)

And the list is big……

**Step III: Web presence**

The computerization of your organization is not complete, if you have not shown its web presence. That is creating a web site or most simply put up your organization on a social network for it to garner more popularity and bind its alumni/students/faculty together. Create a blog for people who want to share their view/knowledge with others!

**Step IV: Maintenance**

Your work does not end with setting up the laboratory and identifying the correct software. Responsibility of ensuring its smooth functioning and sustainability for a long period of
time is also yours. This is where your knowledge of trouble shooting skills will help. At times you may encounter problems such as machine not working. By skilful tracing you need to decide if you can fix it yourself (if it is a simple case of dangling connection) or you need an engineer to handle (if the power supply unit has stopped working).

**Exercises**

1. Go ahead and identify the possible areas around you where automation would of help

2. List the hardware requirements at each of these places. *Remember not each would have the same requirement*

3. List the software requirements at each of these places. *This has to be done keeping in mind the nature of work done there!*

4. Create a list of vendors and the services provided for possible assistance in case of technical trouble.

   *Give it back to the community!*

   *You can always bring out your creative spirit and through social networking sites, bring together all such information which can be of help for automation in your neighbourhood for easy access to all. Such as Name, Contact numbers, email ids, service provided etc of all service providers*